Temas relacionados
×
Fórmulas y funciones
Fórmulas y funciones

BUSCARX

Use la función BUSCARX para buscar elementos en una tabla o rango por fila. Por ejemplo, puede buscar el precio de una pieza de automóvil por el número de pieza o buscar un nombre de empleado en función de su ID. de empleado. Con BUSCARX, puede buscar en una columna un término de búsqueda y devolver un resultado de la misma fila en otra columna, independientemente de en qué lado se encuentre la columna de retorno.

Nota: BUSCARX no está disponible en Excel 2016 y Excel 2019, pero puede encontrarse con una situación de uso de un libro en Excel 2016 o Excel 2019 con la función BUSCARX en él creada por otra persona que usa una versión más reciente de Excel.

Su explorador no admite vídeo. Instale Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Sintaxis

La función BUSCARX busca en un rango o una matriz y, a continuación, devuelve el elemento correspondiente a la primera coincidencia que encuentra. Si no existe ninguna coincidencia, BUSCARX puede devolver la coincidencia más cercana (aproximada). 

=BUSCARX(valor_buscado; matriz_buscada; matriz_devuelta; [si_no_se_encuentra]; [modo_de_coincidencia]; [modo_de_búsqueda]) 

argumento

Descripción

valor_buscado

Necesario*

El valor que se va

a buscar *Si se omite, BUSCARX devuelve las celdas en blanco que encuentra en lookup_array.   

matriz_buscada

Requerido

La matriz o rango para buscar

matriz_devuelta

Requerido

La matriz o rango para devolver

[si_no_se_encuentra]

Opcional

Si no se encuentra una coincidencia válida, devolver el texto [if_not_found] que proporcione.

Si no se encuentra una coincidencia válida y falta [if_not_found], se devuelve #N/A .

[modo_de_coincidencia]

Opcional

Especifique el tipo de coincidencia:

0: coincidencia exacta. Si no se encuentra ninguno, devolver #N/A. Este valor es el predeterminado.

-1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más pequeño.

1: coincidencia exacta. Si no se encuentra ninguna, devolver el siguiente elemento más grande.

2: una coincidencia comodín donde *, ? y ~ tienen significado especial.

[modo_de_búsqueda]

Opcional

Especifique el modo de búsqueda que se usará:

1: realizar una búsqueda empezando por el primer elemento. Este valor es el predeterminado.

-1: realizar una búsqueda inversa empezando por el último elemento.

2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden ascendente. Si no está ordenada, se devolverán resultados no válidos.

-2: realizar una búsqueda binaria que se base en que lookup_array se ordene en orden descendente. Si no está ordenada, se devolverán resultados no válidos.

Ejemplos

En el ejemplo 1    se usa BUSCARX para buscar el nombre de un país en un rango y, a continuación, se devuelve el código de país del teléfono. Incluye los argumentos lookup_value (celda F2), lookup_array (rango B2:B11) y return_array (rango D2:D11). No incluye el argumento match_mode , ya que BUSCARX produce una coincidencia exacta de forma predeterminada.

Ejemplo de uso de la función BUSCARX para devolver un nombre de empleado y un departamento basándose en el ID. de empleado. La fórmula es =BUSCARX(B2;B5:B14;C5:C14).

Nota: BUSCARX usa una matriz de búsqueda y una matriz de retorno, mientras que BUSCARV usa una matriz de tabla única seguida de un número de índice de columna. La fórmula equivalente de BUSCARV en este caso sería: =BUSCARV(F2;B2:D11;3;FALSO)

———————————————————————————

El ejemplo 2    busca la información de los empleados basándose en un número de identificación de empleado. A diferencia de BUSCARV, BUSCARX puede devolver una matriz con varios elementos, por lo que una sola fórmula puede devolver tanto el nombre de empleado como el departamento de las celdas C5:D14.

Ejemplo de uso de la función BUSCARX para devolver un nombre de empleado y un departamento basándose en el ID. de empleado. La fórmula es =BUSCARX(B2;B5:B14;C5:D14;0;1)

———————————————————————————

El ejemplo 3    agrega un argumento if_not_found al ejemplo anterior.

Ejemplo de uso de la función BUSCARX para devolver un nombre de empleado y un departamento basándose en el ID. de empleado con el argumento if_not_found. La fórmula es =BUSCARX(B2;B5:B14;C5:D14;0;1;"Empleado no encontrado")

———————————————————————————

El ejemplo 4    busca en la columna C los ingresos personales especificados en la celda E2 y encuentra un tipo impositivo coincidente en la columna B. Establece el if_not_found argumento para devolver 0 (cero) si no se encuentra nada. El argumento match_mode se establece en 1, lo que significa que la función buscará una coincidencia exacta y, si no encuentra una, devuelve el siguiente elemento más grande. Por último, el argumento search_mode se establece en 1, lo que significa que la función buscará desde el primer elemento hasta el último.

Imagen de la función BUSCARX usada para devolver un tipo impositivo basado en los ingresos máximos. Esta es una coincidencia aproximada. La fórmula es: =BUSCARX(E2;C2:C7;B2:B7;1;1)

Nota: La columna lookup_array de XARRAY está a la derecha de la columna return_array , mientras que BUSCARV solo puede buscar de izquierda a derecha.

———————————————————————————

Ejemplo 5    usa una función anidada BUSCARX para realizar una coincidencia vertical y horizontal. Primero busca Beneficio bruto en la columna B, luego busca Trim1 en la fila superior de la tabla (rango C5:F5) y, por último, devuelve el valor en la intersección de los dos. Esto es similar a usar las funciones INDICE y COINCIDIR juntas.

Sugerencia: También puede usar BUSCARX para reemplazar la función BUSCARH.

Imagen de la función BUSCARX usada para devolver datos horizontales de una tabla anidando 2 funciones BUSCARX. La fórmula es: : =BUSCARX (D2;$B6:$B17;BUSCARX ($C3;$C5:$G5;$C6:$G17))

Nota: La fórmula de las celdas D3:F3 es: =BUSCARX(D2;$B 6:$B 17;BUSCARX($C 3;$C 5:$G 5;$C 6:$G 17))..

———————————————————————————

Ejemplo 6    usa la función SUMA y dos funciones XLOOKUP anidadas para sumar todos los valores entre dos rangos. En este caso, queremos sumar los valores de uvas, plátanos e incluir peras, que están entre ambos.

Uso de BUSCARX con SUMA para sumar un intervalo de valores entre dos selecciones

La fórmula de la celda E3 es: =SUMA(BUSCARX(B3;B6:B10;E6:E10):BUSCARX(C3;B6:B10;E6:E10))

¿Cómo funciona? BUSCARX devuelve un rango, por lo que, cuando calcula, la fórmula tiene un aspecto similar a este: =SUMA($E$7:$E$9). Puede ver cómo funciona por su cuenta seleccionando una celda con una fórmula BUSCARX similar a esta, después seleccione Fórmulas > Auditoría de fórmulas > Evaluar fórmula y, a continuación, seleccione Evaluar para realizar el cálculo paso a paso.

Nota: Gracias al MVP de Microsoft Excel, Bill Jelen, por sugerir este ejemplo.

———————————————————————————

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Obtener respuestas gratuitas y en directo en Excel

Vea también

Función COINCIDIRX

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos

Explorar los cursos >

Obtener nuevas características primero

Unirse a Microsoft Insider >

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×