Tärkeää: Kokeile uutta XHAKU-funktiota, PHAKU-funktion parannettua versiota, joka toimii mihin tahansa suuntaan ja palauttaa oletusarvoisesti tarkat vastineet, mikä helpottaa ja helpottaa sen edeltäjän käyttöä.

Kun luot PHAKU- tai VHAKU-funktion, kirjoitat solualueen, kuten D2:F39. Tätä aluetta kutsutaan table_array-argumentiksi, ja argumentti on vain tieto, jota funktio tarvitsee suorittaakseen. Tässä tapauksessa funktio etsii kyseisistä soluista tietoja, joita yrität löytää.

Table_array-argumentti on aina PHAKU- tai VHAKU-funktion toinen argumentti (ensimmäinen on etsimässäsi arvo) eikä funktiot toimi ilman sitä.

Ensimmäinen argumentti eli etsittava arvo voi olla tietty arvo, kuten "41" tai "smith", tai se on soluviittaus, kuten F2. Ensimmäinen argumentti voi siis näyttää tältä:

=PHAKU(F2;...

Table_array-argumentti seuraa aina hakuarvoa, kuten tässä:

=PHAKU(F2;B4:D39;...

Solualue, joka on lueteltu table_array voi käyttää suhteellisia tai absoluuttisia soluviittauksia. Jos aiot kopioida funktion, sinun on käytettävä absoluuttisia viittauksia, kuten tässä:

=PHAKU(F2,$B$2:BD$39, ...

Myös table_array-argumentin solut voivat olla työkirjan toisessa laskentataulukossa. Jos näin on, argumentti sisältää taulukon nimen ja taulukon nimen, ja syntaksi näyttää tältä:

=PHAKU(F2,Taulukko2!$C$14:E$42, ...

Varmista, että sijoitat huutomerkkinä taulukon nimen perään.

Lopuksi (vihjaa) kolmas argumentti, joka sisältää etsittävät arvot. Tätä kutsutaan hakusarakkeeksi. Ensimmäisessä esimerkissä käytettiin solualuetta B4–D39, joka on kolme saraketta. Oletetaan, että oletetaan, että haluat nähdä arvot reaaliaikaisesti sarakkeessa D eli solualueen kolmannessa sarakkeessa, joten viimeinen argumentti on 3.

=PHAKU(F2;B4:D39;3)

Voit käyttää valinnaista neljättä argumenttia, joko Tosi tai Epätosi. Yleensä haluat käyttää epätosi-arvona.

Jos käytät Tosi-funktiota tai jätät neljännen argumentin tyhjäksi, funktio palauttaa summittaisen vastineen ensimmäisen argumentin arvoon. Jatka esimerkkiä, jos ensimmäinen argumentti on "smith" ja käytät Tosi-funktiota, funktio palauttaa arvon "Smith", "Smithberg" ja niin edelleen. Jos kuitenkin käytät Epätosi-funktiota, funktio palauttaa vain "Smithin", tarkan vastineen, ja useimmat haluavat sitä.

Tosi-funktion käyttäminen on hankalampaa, jos hakusarake (kolmannen argumentin sarake) ei ole lajiteltu nousevaan järjestykseen (A–Ö tai pienimmästä suurimpaan), funktio saattaa palauttaa väärän tuloksen. Lisätietoja on kohdassa Arvojen etsiminen PHAKU-funktiolla ja muilla funktioilla.

Lisätietoja PHAKU- ja VHAKU-funktioista on kohdassa:

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Insider-käyttäjille

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteestasi.

×