Vihje: Kokeile käyttää uutta XHAKU- -funktiota, PHAKU-funktion parannettua versiota, joka toimii mihin tahansa suuntaan ja palauttaa tarkat vastineet oletusarvoisesti, jolloin sitä on helpompi ja kätevämpi käyttää kuin edeltäjää.

PHAKU-funktiolla voit etsiä kohteita taulukosta tai alueelta riveittäin. Voit esimerkiksi etsiä auton osan hinnan osanumeron perusteella tai työntekijän nimen työntekijätunnuksen perusteella.

Yksinkertaisin PHAKU-funktion muoto on seuraava:

=PHAKU(Mitä haluat etsiä, mistä haluat etsiä sitä, palautettavan arvon sisältävän alueen sarakenumero, palauttaa Likimääräinen- tai Tarkka-vastineen, joka on merkitty arvoksi 1/TOSI tai 0/EPÄTOSI).

Selaimesi ei tue videotoimintoa. Asenna Microsoft Silverlight, Adobe Flash Player tai Internet Explorer 9.

Vihje: PHAKU-funktion toiminta perustuu tietojen järjestämiseen siten, että haettu arvo (osan numero) on palautettavan arvon (osan hinta) vasemmalla puolella.

PHAKU-funktion avulla voit etsiä arvon taulukosta.

Syntaksi 

PHAKU (hakuarvo; taulukko_matriisi; sar_indeksi_nro; [alue_haku])

Esimerkki:

  • =PHAKU(A2;A10:C20;2;TOSI)

  • =PHAKU("Sallinen",B2:E7,2,EPÄTOSI)

  • =PHAKU(A2;'Asiakkaan tiedot'! A:F,3,EPÄTOSI)

Argumentin nimi

Kuvaus

hakuarvo    (pakollinen)

Tämä on haettava arvo. Haettavan arvon on oltava taulukkomatriisissa määrittämäsi solualueen ensimmäisessä sarakkeessa.

Jos esimerkiksi taulukkomatriisi kattaa solut B2:D7, hakuarvon on oltava sarakkeessa B. Katso alla oleva kuva.

Hakuarvo voi olla arvo tai solun viittaus.

taulukko_matriisi    (pakollinen)

Solualue, jolta PHAKU etsii hakuarvoa ja palautusarvoa. Voit käyttää nimettyä aluetta tai taulukkoa ja käyttää argumentissa nimiä soluviittausten sijaan. 

Solualueen ensimmäisessä sarakkeessa on oltava hakuarvo (kuten alla olevassa kuvassa sukunimi). Solualueella on oltava myös palautusarvo (kuten alla olevassa kuvassa etunimi).

Katso lisätietoja laskentataulukon alueiden valitsemisesta.

sar_indeksi_nro    (pakollinen)

Sarakenumero (alkaa numerosta 1 taulukkomatriisin vasemmanpuoleisimmasta sarakkeesta), joka sisältää palautusarvon.

alue_haku   (valinnainen)

Totuusarvo, jolla määritetään, hakeeko PHAKU epätarkan vai tarkan vastineen:

  • Likimääräinen vastine - 1/TRUE olettaa, että taulukon ensimmäinen sarake lajitellaan joko numeerisesti tai aakkosjärjestykseen, ja hakee sitten lähimmän arvon. Tämä on oletusarvoinen menetelmä, jos muuta ei ole määritetty. Esimerkiksi =PHAKU(90,A1:B100,2,TOSI).

  • Tarkka vastine – 0/EPÄTOSI etsii täsmällistä arvoa ensimmäisestä sarakkeesta. Esimerkiksi =PHAKU("Smith",A1:B100,2,EPÄTOSI).

Näin pääset alkuun

Anna seuraavat neljä tietoa, jotta voit muodostaa PHAKU-funktion syntaksin:

  1. Hakemasi arvo, eli hakuarvo.

  2. Alue, jossa hakuarvo sijaitsee. Muista, että hakuarvon tulisi aina löytyä alueen ensimmäisestä sarakkeesta, jotta PHAKU-funktio toimisi oikein. Jos esimerkiksi hakuarvo on solussa C2, määrittämäsi alueen tulisi alkaa sarakkeesta C.

  3. Hakualueen sarakenumero, joka sisältää palautusarvon. Jos esimerkiksi määrität alueeksi B2: D11, sinun tulisi laskea B ensimmäiseksi sarakkeeksi, C toiseksi ja niin edelleen.

  4. Voit halutessasi antaa määritelmän TOSI, jos haluat palautusarvon epätarkan vastineen tai EPÄTOSI, jos haluat palautusarvon tarkan vastineen. Jos et määritä mitään, oletusarvona on aina TOSI tai epätarkka vastine.

Nyt yhdistä kaikki edellä mainitut seuraavasti:

=PHAKU(hakuarvo; hakuarvon sisältävä alue; palautusarvon sisältävän hakualueen sarakenumero; halutessasi määritä TOSI, jos haluat epätarkan vastineen tai EPÄTOSI, jos haluat tarkan vastineen).

Esimerkkejä

Tässä muutama lisäesimerkki PHAKU-funktiosta:

Esimerkki 1

=PHAKU (B3;B2:E7;2;EPÄTOSI)

PHAKU etsii Fontanaa table_array B2:E7 ensimmäisestä sarakkeesta (sarake B) ja palauttaa Olivierin table_array toisesta sarakkeesta (sarake C).  Epätosi palauttaa tarkan vastineen.

Esimerkki 2

=PHAKU (102;A2:C7;2;EPÄTOSI)

PHAKU etsii tarkkaa vastinetta (EPÄTOSI) sukunimestä 102 (lookup_value) A2:C7-alueen toisesta sarakkeesta (sarake B) ja palauttaa Fontanan.

Esimerkki 3

=JOS(PHAKU(103;A1:E7;2;EPÄTOSI)="Souse","Sijainti","Ei löytynyt")

JOS tarkistaa, palauttaako PHAKU Sousan työntekijän sukunimeksi, joka korreloi arvoon 103 (lookup_value) solussa A1:E7 (table_array). Koska sukunimi, joka vastaa lukua 103, on Leal, JOS-ehto on epätosi ja Ei löytynyt näytetään.

Esimerkki 4

=INT(YEARFRAC(DATE(2014,6,30),PHAKU(105;A2:E7;5;FLASE),1))



PHAKU etsii A2:E7-alueella (table_array) olevan työntekijän syntymäaikaa 109 (lookup_value) ja palauttaa arvon 03/04/1955. Sitten VUOSIRAKENTA vähentää tämän syntymäajan 30.6.2014 alkaen ja palauttaa arvon, jonka INY muuntaa kokonaisluvuksi 59.

Esimerkki 5

JOS(ISNA(PHAKU(105;A2:E7;2;FLASE))=TOSI,"Työntekijä ei löydy",PHAKU(105;A2:E7;2;EPÄTOSI))



JOS tarkistaa, palauttaako PHAKU sukunimen arvon sarakkeesta B 105 (lookup_value). Jos PHAKU löytää sukunimen, JOS näyttää sukunimen, muussa tapauksessa JOS palauttaa Työntekijän ei löydy. ISNA varmistaa, että jos PHAKU palauttaa #N/A, virhe korvataan työntekijällä, jota ei löydy, #N/A:n sijaan.



Tässä esimerkissä palautusarvo on Burke, joka on sukunimi, joka vastaa arvoa 105.

PHAKU-funktion avulla voit yhdistää useita taulukoita yhdeksi taulukoksi, kunhan yhdessä taulukoista on yhteisiä kenttiä kaikkien muiden kanssa. Tämä voi olla erityisen hyödyllistä, jos sinun on jaettava työkirja sellaisten henkilöiden kanssa, joilla on vanhempi Excel-versio, joka ei tue dataominaisuuksia, joissa on useita taulukoita tietolähteinä - yhdistämällä lähteet yhdeksi taulukoksi ja vaihtamalla dataominaisuuden tietolähteeksi uusi taulukko, dataominaisuutta voidaan käyttää vanhemmissa Excel-versioissa (edellyttäen, että vanhempi versio tukee itse dataominaisuutta).

Laskentataulukko, jossa on PHAKU-funktiota käyttäviä sarakkeita tietojen hakemiseen muista taulukoista

Sarakkeissa A–F ja H on arvoja tai kaavoja, joissa käytetään vain laskentataulukon arvoja, ja muissa sarakkeissa käytetään PHAKU-funktiota ja sarakkeen A (asiakaskoodi) ja sarakkeen B (Asianajaja) arvoja tietojen hakemiseen muista taulukoista.

  1. Kopioi taulukko, jossa on yhteiset kentät, uuteen laskentataulukkoon ja anna sille nimi.

  2. Avaa Suhteiden hallinta-valintaikkuna valitsemalla Tiedot > Datatyökalut > Yhteydet.

    Hallitse suhteita -valintaikkuna
  3. Huomaa seuraavat tiedot kunkin luettelossa olevan yhteyden osalta:

    • Kenttä, joka linkittää taulukot (valintaikkunan sulkeissa). Tämä on PHAKU-kaavan lookup_value.

    • Liittyvän hakutaulukon nimi. Tämä on PHAKU-kaavan table_array.

    • Liittyvän hakutaulukon kenttä (sarake), jossa on haluamasi tiedot uudessa sarakkeessa. Näitä tietoja ei näytetä Suhteiden hallinta-valintaikkunassa – sinun on tarkasteltava Aiheeseen liittyvää hakutaulukkoa nähdäksesi, minkä kentän haluat noutaa. Haluat merkitä sarakkeen numeron (A=1) muistiin– tämä on kaavan col_index_num.

  4. Jos haluat lisätä kentän uuteen taulukkoon, kirjoita PHAKU-kaava ensimmäiseen tyhjään sarakkeeseen käyttämällä vaiheessa 3 kerättyjä tietoja.

    Esimerkissämme sarake G käyttää asianajotoimistoa ( lookup_value) saadakseen laskun korkotiedot neljännestä sarakkeesta (col_index_num = 4) Asianajajien laskentataulukkotaulukosta tblAttorneys ( table_array) kaavalla =PHAKU([@Attorney],tbl_Attorneys,4,EPÄTOSI).

    Kaavassa voi käyttää myös soluviittausta ja alueviittausta. Esimerkissämme se olisi =PHAKU(A2,'Asianajajat'! A:D,4,EPÄTOSI).

  5. Jatka kenttien lisäämistä, kunnes sinulla on kaikki tarvitsemasi kentät. Jos yrität valmistella työkirjaa, joka sisältää useita taulukoita käyttäviä tieto-ominaisuuksia, muuta tieto-ominaisuuden tietolähde uudeksi taulukoksi.

Ongelma

Mistä ongelma johtuu?

Väärä arvo palautettiin

Jos alue_haku on TOSI tai se on jätetty pois, ensimmäinen sarake on lajiteltava numero- tai aakkosjärjestykseen. Jos ensimmäistä saraketta ei ole lajiteltu, palautusarvo voi olla odottamaton. Lajittele ensimmäinen sarake tai hae tarkka vastine EPÄTOSI-funktiolla.

#PUUTTUU! solussa

  • Jos alue_haku on TOSI ja hakuarvo on pienempi kuin taulukko_matriisin ensimmäisen sarakkeen pienin arvo, palautetaan virhearvo #PUUTTUU!.

  • Jos alue_haku on EPÄTOSI, #PUUTTUU!-virhearvo tarkoittaa, ettei tarkkaa lukua löydy.

Lisätietoja PHAKU-funktion #PUUTTUU!-virhearvon ratkaisemiseksi löytyy kohdasta PHAKU-funktion #PUUTTUU-virheen korjaaminen.

#VIITTAUS! solussa

Jos sar_indeksi_nro on suurempi kuin taulukkomatriisin sarakkeiden määrä, palautetaan virhearvo #REF! ‑virhearvon.

Lisätietoja #REF ratkaisemisesta! Lisätietoja PHAKU-funktion #REF!-virhearvon ratkaisemiseksi löytyy kohdasta #REF!-virheen korjaaminen..

#ARVO! solussa

Jos taulukko_matriisi on pienempi kuin 1, palautetaan virhearvo #VALUE! ‑virhearvon.

Lisätietoja #VALUE ratkaisemisesta! Lisätietoja PHAKU-funktion virheistä löytyy kohdasta PHAKU-funktion #VALUE!-virheen korjaaminen..

#NIMI? solussa

#NIMI? -virhearvo tarkoittaa yleensä, että kaavasta puuttuvat lainausmerkit. Kun etsit henkilön nimeä, varmista, että nimi on lainausmerkeissä kaavassa. Kirjoita esimerkiksi nimi muodossa "Sallinen" kaavassa =PHAKU("Sallinen",B2:E7,2,EPÄTOSI).

Katso lisätietoja kohdasta #NAME!-virheen korjaaminen..

#SPILL! solussa

Tämä #SPILL!-virhe yleensä kaava käyttää hakuarvon implisiittistä leikkauskohtaa ja käyttää viittauksena koko saraketta. Esimerkiksi =PHAKU(A:A,A:C,2,EPÄTOSI). Voit ratkaista ongelman ankkuroimalla hakuviittauksen @-operaattoriin seuraavasti: =PHAKU(@A:A,A:C,2,EPÄTOSI). Vaihtoehtoisesti voit käyttää perinteistä PHAKU-menetelmää ja viitata yhteen soluun koko sarakkeen sijaan: =PHAKU(A2,A:C,2,EPÄTOSI).

Tee näin

Miksi

Käytä suoria viittauksia alue_haussa

Suorien viittausten avulla voit täyttää kaavan siten, että se suorittaa haun aina samalla hakualueella.

Katso lisätietoja suorien soluviittausten käyttämisestä.

Älä tallenna luku- tai päivämääräarvoja tekstinä.

Kun etsit lukua tai päivämääräarvoja, varmista, että taulukko_matriisi-argumentin ensimmäisen sarakkeen tiedot on tallennettu tekstiarvoina. Muussa tapauksessa PHAKU-funktio saattaa palauttaa virheellisen tai odottamattoman arvon.

Ensimmäisen sarakkeen lajitteleminen

Lajittele taulukko_matriisin ensimmäinen sarake ennen PHAKU-funktion käyttämistä, jos alue_haku on TOSI.

Yleismerkkien käyttäminen

Jos alue_haku on EPÄTOSI ja etsittävä_teksti on etsittävä teksti, voit käyttää etsittävä_teksti-argumentissa yleismerkkejä, kysymysmerkkiä (?) ja tähteä (*). Kysymysmerkki vastaa mitä tahansa yksittäistä merkkiä. Tähti vastaa mitä tahansa merkkijonoa. Jos haluat löytää tekstissä olevan kysymysmerkin tai tähden, kirjoita tilde (~) ennen kysymysmerkkiä.

Esimerkiksi =PHAKU("Fontan?",B2:E7,2,FALSE) etsii kaikki Fontanan esiintymät, joiden viimeinen kirjain voi vaihdella.

Varmista, ettei tiedoissa ole virheellisiä merkkejä.

Kun etsit tekstiarvoja ensimmäisestä sarakkeesta, tarkista, että ensimmäisen sarakkeen tietojen alussa tai lopussa ei ole välilyöntejä ja etteivät tiedot sisällä epäyhtenäisesti käytettyjä suoria (' tai ") ja kaarevia (‘ tai “) lainausmerkkejä tai tulostumattomia merkkejä. Muussa tapauksessa PHAKU-funktio saattaa palauttaa odottamattoman arvon.

Lopussa olevat välilyönnit täytyy ehkä poistaa, jotta saat tarkat tulokset. KokeileSIIVOA-funktiota tai POISTA.VÄLIT-funktiota.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Hanki reaaliaikaisia ja ilmaisia vastauksia Excelissä

Katso myös

Pikaopas: PHAKU-funktion kertaus
Pikaopas: PHAKU-funktion vianmääritysvihjeet
PHAKU-funktion #VALUE!-virheen korjaaminen
#N/A-virheen korjaaminen PHAKU-funktiossa
Yleiskatsaus Excelin kaavoista
Viallisten kaavojen välttäminen
Excel-funktioiden (aakkosjärjestyksessä)Excel-funktioiden virheiden havaitseminen (luokittain)
PHAKU (maksuton esikatselu)

Tarvitsetko lisäohjeita?

Kehitä taitojasi

Tutustu koulutusmateriaaliin >

Saat uudet ominaisuudet ensimmäisten joukossa

Liity Microsoft Insider-käyttäjille >

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×