Vihje: Kokeile uutta XHAKU-funktiota, PHAKU-funktion parannettua versiota, joka toimii mihin tahansa suuntaan ja palauttaa oletusarvoisesti tarkat vastineet, mikä helpottaa ja helpottaa sen edeltäjän käyttöä.

Käytä PHAKU-funktiota, kun haluat etsiä tietoja taulukosta tai alue riviltä. Voit esimerkiksi etsiä auton osan hinnan osanumeron perusteella tai etsiä työntekijän nimen työntekijätunnuksen perusteella.

Yksinkertaisin PHAKU-funktion muoto on seuraava:

=PHAKU(Etsittävä alue, josta haluat etsiä sitä, palautettavan arvon sisältävän alueen sarakenumero, palauta summittainen tai tarkka vastine, joka ilmaistaan arvona 1/TOSI tai 0/EPÄTOSI).

Selaimesi ei tue videotoimintoa.

Vihje: PHAKU-funktion salaisuus on tietojen järjestäminen niin, että etsimäsi arvo (Hedelmät) on etsimäsi palautusarvon (Summa) vasemmalla puolella.

PHAKU-funktion avulla voit etsiä arvon taulukosta.

Syntaksi 

PHAKU (hakuarvo; taulukko_matriisi; sar_indeksi_nro; [alue_haku])

Esimerkki:

  • =PHAKU(A2;A10:C20;2;TOSI)

  • =PHAKU("Sallinen",B2:E7,2,EPÄTOSI)

  • =PHAKU(A2;'Asiakkaan tiedot'! A:F,3,EPÄTOSI)

Argumentin nimi

Kuvaus

hakuarvo    (pakollinen)

Tämä on haettava arvo. Etsittävän arvon on oltava solualueen ensimmäisessä sarakkeessa, jonka määrität table_array.

Jos esimerkiksi taulukko-matriisi kattaa solut B2:D7, taulukon lookup_value on oltava sarakkeessa B.

Hakuarvo voi olla arvo tai solun viittaus.

taulukko_matriisi    (pakollinen)

Solualue, jolta PHAKU etsii hakuarvoa ja palautusarvoa. Voit käyttää nimettyä aluetta tai taulukkoa ja käyttää argumentissa nimiä soluviittausten sijaan. 

Solualueen ensimmäisen sarakkeen on sisällettävä lookup_value. Solualueella on myös oltava etsittävä palautusarvo.

Katso lisätietoja laskentataulukon alueiden valitsemisesta.

sar_indeksi_nro    (pakollinen)

Palautusarvon sisältävä sarakkeen numero (alkaen numerosta 1table_array vasemmanpuoleisimman sarakkeen numerosta).

alue_haku   (valinnainen)

Totuusarvo, jolla määritetään, hakeeko PHAKU epätarkan vai tarkan vastineen:

  • Arvioitu vastine – 1/TOSI olettaa, että taulukon ensimmäinen sarake on lajiteltu numero- tai aakkosjärjestykseen ja etsii sitten lähimmän arvon. Tämä on oletusarvoinen menetelmä, jos muuta ei ole määritetty. Esimerkiksi =PHAKU(90,A1:B100,2,TOSI).

  • Tarkka vastine – 0/EPÄTOSI etsii ensimmäisen sarakkeen tarkan arvon. Esimerkiksi =PHAKU("Smith";A1:B100;2;EPÄTOSI).

Näin pääset alkuun

Anna seuraavat neljä tietoa, jotta voit muodostaa PHAKU-funktion syntaksin:

  1. Hakemasi arvo, eli hakuarvo.

  2. Alue, jossa hakuarvo sijaitsee. Muista, että hakuarvon tulisi aina löytyä alueen ensimmäisestä sarakkeesta, jotta PHAKU-funktio toimisi oikein. Jos esimerkiksi hakuarvo on solussa C2, määrittämäsi alueen tulisi alkaa sarakkeesta C.

  3. Hakualueen sarakenumero, joka sisältää palautusarvon. Jos esimerkiksi määrität alueeksi B2:D11, sinun on laskettava B ensimmäiseksi sarakkeeksi, C toiseksi ja niin edelleen.

  4. Voit halutessasi antaa määritelmän TOSI, jos haluat palautusarvon epätarkan vastineen tai EPÄTOSI, jos haluat palautusarvon tarkan vastineen. Jos et määritä mitään, oletusarvona on aina TOSI tai epätarkka vastine.

Nyt yhdistä kaikki edellä mainitut seuraavasti:

=PHAKU(hakuarvo, hakuarvon sisältävä alue, alueen sarakenumero, joka sisältää palautusarvon, Summittainen vastine (TOSI) tai Tarkka vastine (EPÄTOSI)).

Esimerkkejä

Seuraavassa on muutamia esimerkkejä PHAKU-funktiosta:

Esimerkki 1

=PHAKU (B3,B2:E7,2,EPÄTOSI)

PHAKU etsii Fontana-arvon sarakkeen B ensimmäisestä sarakkeesta (sarake B) table_array solusta B2:E7 ja palauttaa Olivierin sarakkeen toisesta sarakkeesta (sarake C) table_array.  Epätosi palauttaa tarkan vastineen.

Esimerkki 2

=PHAKU (102,A2:C7,2,EPÄTOSI)

PHAKU etsii tarkan vastineen (EPÄTOSI) sukunimistä 102 (lookup_value) toisesta sarakkeesta (sarake B) solualueella A2:C7 ja palauttaa arvon Fontana.

Esimerkki 3

=JOS(PHAKU(103,A1:E7,2,EPÄTOSI)="Souse","Sijainti","Ei löydy")

JOS tarkistaa, palauttaako PHAKU Sousa työntekijän sukunimi korrelaatio-arvona 103 (lookup_value) alueella A1:E7 (table_array). Koska lukua 103 vastaava sukunimi on Leal, JOS-ehto on epätosi ja Ei löydy näytetään.

Esimerkki 4

=INT(YEARFRAC(DATE(2014;6;30);PHAKU(105;A2:E7;5;FLASE);1))

PHAKU etsii sellaisen työntekijän syntymäpäivän, joka vastaa lukua 109 (lookup_value) alueella A2:E7 (table_array) ja palauttaa arvon 4.3.1955. Tämän jälkeen VUOSI.OSA vähentää tämän syntymäpäivän päivämäärästä 6.2.2014 ja palauttaa arvon, joka muunnetaan iny-funktiolla kokonaislukuun 59.

Esimerkki 5

JOS(ONNA(PHAKU(105,A2:E7,2,FLASE))=TOSI,"Työntekijää ei löydy",PHAKU(105,A2:E7,2,EPÄTOSI))

JOS tarkistaa, palauttaako PHAKU sukunimi arvon sarakkeesta B arvolle 105 (lookup_value). Jos PHAKU löytää sukunimi, JOS näyttää sukunimi, muussa tapauksessa JOS palauttaa Työntekijän ei löydy. ISNA varmistaa, että jos PHAKU palauttaa #N/A-funktion, virhe korvataan työntekijällä, jota ei löydy, #N/A-funktion sijaan.



Tässä esimerkissä palautusarvo on Burke, joka on sukunimi, joka vastaa lukua 105.

PHAKU-funktion avulla voit yhdistää useita taulukoita yhdeksi taulukoksi, kunhan yhdessä taulukoista on yhteisiä kenttiä muiden kanssa. Tämä voi olla erityisen hyödyllistä, jos haluat jakaa työkirjan niiden käyttäjien kanssa, joilla on vanhempi Excel-versio, jotka eivät tue useiden taulukoiden tietoominaisuuksia tietolähteinä– yhdistämällä lähteet yhdeksi taulukoksi ja muuttamalla tietoominaisuuden tietolähteen uuteen taulukkoon, tietotoimintoa voidaan käyttää vanhemmissa Excel-versioissa (jos vanhempi versio tukee itse tieto-ominaisuutta).

Laskentataulukko, jonka sarakkeissa käytetään PHAKU-funktiota tietojen keruussa muista taulukoista

Sarakkeissa A–F ja H on arvoja tai kaavoja, jotka käyttävät vain arvoja laskentataulukossa, ja muissa sarakkeissa käytetään PHAKU-funktiota sekä sarakkeen A (asiakaskoodi) ja sarakkeen B (Attorney) arvoja tietojen keruuseen muista taulukoista.

  1. Kopioi taulukko, jossa on yhteisiä kenttiä, uuteen laskentataulukkoon ja anna sille nimi.

  2. Avaa Yhteyksien hallinta >->valitsemalla Tietotyökalut ja Yhteydet.

    Yhteyksien hallinta -valintaikkuna
  3. Ota huomioon seuraavat seikat jokaisen luetellun yhteyden suhteen suhteen mukaisesti:

    • Kenttä, joka linkittää taulukot (lueteltu valintaikkunan sulkeissa). Tämä on lookup_value PHAKU-kaavan arvo.

    • Liittyvän hakutaulukon nimi. Tämä on table_array PHAKU-kaavassa.

    • Liittyvä hakutaulukko -kenttä (sarake), joka sisältää uuteen sarakkeeseen liittyvät tiedot. Näitä tietoja ei näytetä Yhteyksien hallinta -valintaikkunassa. Sinun on haettava aiheeseen liittyvä hakutaulukko, jotta näet, minkä kentän haluat noutaa. Haluat ottaa huomioon sarakkeen numeron (A=1) – tämä col_index_num kaavassa.

  4. Jos haluat lisätä kentän uuteen taulukkoon, kirjoita PHAKU-kaava ensimmäiseen tyhjään sarakkeeseen käyttämällä vaiheessa 3 kerättyjä tietoja.

    Tässä esimerkissä sarake G käyttää Attorney -saraketta (lookup_value) laskun tietojen saamiseen neljännestä sarakkeesta (col_index_num = 4) Attorneys-laskentataulukosta tblAttorneys (the table_array), jossa on kaava =PHAKU([@Attorney],tbl_Attorneys,4,FALSE).

    Kaava voi käyttää myös soluviittausta ja alueviittausta. Tässä esimerkissä se olisi =PHAKU(A2,'Attorneys'! A:D,4,FALSE).

  5. Jatka kenttien lisäämistä, kunnes kaikki tarvittavat kentät ovat sinulla. Jos yrität valmistella useita taulukoita sisältäviä tietoominaisuuksia sisältävän työkirjan, muuta tietoominaisuuden tietolähde uuteen taulukkoon.

Ongelma

Mistä ongelma johtuu?

Väärä arvo palautettiin

Jos alue_haku on TOSI tai se on jätetty pois, ensimmäinen sarake on lajiteltava numero- tai aakkosjärjestykseen. Jos ensimmäistä saraketta ei ole lajiteltu, palautusarvo voi olla odottamaton. Lajittele ensimmäinen sarake tai hae tarkka vastine EPÄTOSI-funktiolla.

#PUUTTUU! solussa

  • Jos alue_haku on TOSI ja hakuarvo on pienempi kuin taulukko_matriisin ensimmäisen sarakkeen pienin arvo, palautetaan virhearvo #PUUTTUU!.

  • Jos alue_haku on EPÄTOSI, #PUUTTUU!-virhearvo tarkoittaa, ettei tarkkaa lukua löydy.

Lisätietoja PHAKU-funktion #PUUTTUU!-virhearvon ratkaisemiseksi löytyy kohdasta PHAKU-funktion #PUUTTUU-virheen korjaaminen.

#VIITTAUS! solussa

Jos col_index_num on suurempi kuin taulukko matriisin sarakkeiden määrä,saat #REF! -virhearvon.

Lisätietoja ongelmien ratkaisemisesta #REF! -virheet PHAKU-funktiossa, katso #REF!.

#ARVO! solussa

Jos table_array on pienempi kuin 1, saat #VALUE! -virhearvon.

Lisätietoja ongelmien ratkaisemisesta #VALUE! -virheistä on kohdassa PHAKU-funktion #VALUE!-virheen korjaaminen.

#NIMI? solussa

#NIMI? -virhearvo tarkoittaa yleensä, että kaavasta puuttuvat lainausmerkit. Kun etsit henkilön nimeä, varmista, että nimi on lainausmerkeissä kaavassa. Kirjoita esimerkiksi nimi muodossa "Sallinen" kaavassa =PHAKU("Sallinen",B2:E7,2,EPÄTOSI).

Lisätietoja on kohdassa #NAME!.

#SPILL! solussa

Tämä #SPILL! -virhe tarkoittaa yleensä sitä, että kaava käyttää hakuarvon implisiittistä leikkaamiskohtaa ja käyttää koko saraketta viittauksena. Esimerkiksi =PHAKU( A:A,A:C,2,EPÄTOSI). Voit ratkaista ongelman ankkuroitumalla hakuviittauksen @-operaattoriin seuraavasti: =PHAKU( @A:A,A:C,2,EPÄTOSI). Vaihtoehtoisesti voit käyttää perinteistä PHAKU-menetelmää ja viitata yksittäiseen soluun koko sarakkeen sijaan: =PHAKU( A2,A:C,2,EPÄTOSI).

Tee näin

Miksi

Käytä suoria viittauksia alue_haussa

Suorien viittausten avulla voit täyttää kaavan siten, että se suorittaa haun aina samalla hakualueella.

Katso lisätietoja suorien soluviittausten käyttämisestä.

Älä tallenna luku- tai päivämääräarvoja tekstinä.

Kun etsit lukua tai päivämääräarvoja, varmista, että taulukko_matriisi-argumentin ensimmäisen sarakkeen tiedot on tallennettu tekstiarvoina. Muussa tapauksessa PHAKU-funktio saattaa palauttaa virheellisen tai odottamattoman arvon.

Ensimmäisen sarakkeen lajitteleminen

Lajittele taulukko_matriisin ensimmäinen sarake ennen PHAKU-funktion käyttämistä, jos alue_haku on TOSI.

Yleismerkkien käyttäminen

Jos range_lookup on EPÄTOSI ja lookup_value on tekstiä, voit käyttää lookup_value yleismerkkejä: kysymysmerkkiä (?) ja tähteä(*). Kysymysmerkki vastaa mitä tahansa yksittäistä merkkiä. Tähti vastaa mitä tahansa merkkijonoa. Jos haluat löytää tekstissä tekstissä kysymysmerkin tai tähden, kirjoita tilde (~) merkin eteen.

Esimerkiksi =PHAKU("Fontti?",B2:E7,2,EPÄTOSI) etsii kaikki Teepika-esiintymät, joiden viimeinen kirjain voi vaihdella.

Varmista, ettei tiedoissa ole virheellisiä merkkejä.

Kun etsit tekstiarvoja ensimmäisestä sarakkeesta, tarkista, että ensimmäisen sarakkeen tietojen alussa tai lopussa ei ole välilyöntejä ja etteivät tiedot sisällä epäyhtenäisesti käytettyjä suoria (' tai ") ja kaarevia (‘ tai “) lainausmerkkejä tai tulostumattomia merkkejä. Muussa tapauksessa PHAKU-funktio saattaa palauttaa odottamattoman arvon.

Lopussa olevat välilyönnit täytyy ehkä poistaa, jotta saat tarkat tulokset. KokeileSIIVOA-funktiota tai POISTA.VÄLIT-funktiota.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Katso myös

Pikaopas: PHAKU-funktion kertaus
Pikaopas: PHAKU-funktion vianmääritysvihjeet
PHAKU-funktion #VALUE!-virheen korjattu
PHAKU-funktion #N/A-virheen korjattu
Yleistä kaavojen Excel
Katkenneiden kaavojen välttäminen
Kaavoissa havaittavien virheiden etsiminen
Excel funktiot (aakkosjärjestyksessä)
Excel funktiot (luokittain)
PHAKU (ilmainen esikatselu)

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Insider-käyttäjille

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteestasi.

×