Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Le support de Windows Vista Service Pack 1 (SP1) a pris fin le 12 juillet 2011. Pour continuer à recevoir des mises à jour de sécurité pour Windows, assurez-vous que vous exécutez Windows Vista avec Service Pack 2 (SP2). Pour plus d’informations, consultez cette page web de Microsoft : La prise en charge se termine pour certaines versions de Windows.

Symptômes

Vous essayez de télécharger un fichier d’une taille supérieure à 50000000 octets à partir d’un dossier web sur Windows XP Service Pack 2 (SP2) ou d’une version ultérieure de Windows. Vous pouvez recevoir un message d’erreur similaire au suivant :

Impossible de copier le nom du fichier: Impossible de lire à partir du fichier ou disque source

Remarque Dans ce message d’erreur, FileName est un espace réservé pour le nom du fichier.

Ce problème se produit également sur un ordinateur Windows Vista ou un ordinateur Windows XP Service Pack 1 (SP1) sur qui la mise à jour de sécurité 896426 (MS05-028) est installée.

Dans ce scénario sur Windows 7, 8 ou 8.1, vous pouvez recevoir le message d’erreur suivant :

Copier un dossier

Une erreur inattendue vous empêche de copier le dossier. Si vous continuez à recevoir cette erreur, vous pouvez utiliser le code d’erreur pour rechercher de l’aide pour résoudre ce problème.

Erreur 0x800700DF : La taille du fichier dépasse la limite autorisée et ne peut pas être enregistrée.

<nom de fichier>

Réessayer: Annuler

Cause

Ce problème se produit parce qu’une modification de sécurité introduite dans Windows XP SP2 affecte le redirecteur WebDAV (WebDAV). Cette modification de sécurité permet de s’assurer qu’un serveur non autorisé ne peut pas forcer un ordinateur client en déni de service. Si vous essayez de télécharger un fichier d’une taille supérieure à 50000000 octets, l’ordinateur client interprète ce téléchargement comme un déni de service. Par conséquent, le processus de téléchargement s’arrête.

Résolution

Importante Cette section, méthode ou tâche contient les étapes qui vous indiquent comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour plus de protection, effectuez une sauvegarde du Registre avant de le modifier. Vous serez alors en mesure de le restaurer en cas de problème. Pour plus d'informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :

322756 Comment faire pour restaurer le Registre dans Windows Si vous avez
Windows XP SP2, Vista ou 7, allez à la section « Corriger pour moi » pour exécuter le correctif. Si vous préférez résoudre ce problème vous-même ou si vous utilisez Windows 8 ou 8.1, allez à la section « Laissez-moi le résoudre vous-même ».

Windows XP SP2, Vista ou 7 : le corriger pour moi



Pour résoudre ce problème automatiquement, cliquez sur le bouton ou le lien Corriger. Cliquez ensuite sur Exécuter dans la boîte de dialogue Téléchargement de fichier, puis suivez les étapes de l’Assistant Réparation.

Notez que le correctif ci-après ne fonctionne pas avec Windows 8 ou une suite ultérieure.




Notes

  • Lorsque vous suivez l’Assistant Résoudre le problème, vous devez entrer une valeur FileSizeLimitInBytes supérieure à la taille du fichier à télécharger.

  • Il se peut que cet Assistant ne soit disponible qu’en anglais. Toutefois, la résolution automatique fonctionne aussi pour d’autres versions linguistiques de Windows.

  • Si vous n’utilisez pas l’ordinateur concerné, vous pouvez enregistrer la solution sur un lecteur flash ou sur un CD-ROM et ensuite l’exécuter sur l’ordinateur concerné par le problème.


Ensuite, allez à la section « Le problèmeest-ilcorrigé ? ».



Je résous le problème moi-même


Pour résoudre ce problème, suivez ces étapes :

  1. Windows XP SP2, Vista ou 7 : Cliquez sur Démarrer,sur Exécuter,tapez regedit, puis cliquez sur OK.

    Windows 8 ou une suite : Balayez à partir de la droite pour faire défiler les icônes, puis sélectionnez Rechercher et taper regedit (ou tapez regedit dans l’écran d’accueil). Sélectionnez regedit dans les résultats de la recherche pour l’exécuter.

  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. Dans le volet droit, cliquez avec le bouton droit sur la valeur
    FileSizeLimitInBytes, puis cliquez sur
    Modifier.

    Si la valeur
    FileSizeLimitInBytes n’est pas disponible, cliquez avec le bouton droit sur l’espace vide dans le volet droit, cliquez sur Nouveau, sur Valeur DWORD,tapez FileSizeLimitInBytes, puis cliquez sur
    OK.

  4. Dans la zone Modifier la valeur DWORD, cliquez pour sélectionner l’option Décimale. Dans la zone sous Données de lavaleur, tapez une valeur supérieure à la taille du fichier à télécharger. Cliquez sur OK.

    Remarque La valeur par défaut de la limite de taille de fichier est 50000000 octets.

  5. Quittez l’Éditeur du Registre. Redémarrez l'ordinateur.


Le problème est-il résolu ?

  • Vérifiez que le problème est résolu. Si c'est le cas, vous n'avez plus besoin de cette section. Sinon, vous pouvez contacter le support technique.

  • Vos commentaires sont les bienvenus. Pour envoyer des commentaires ou signaler des problèmes avec cette solution, veuillez laisser un commentaire sur le blog « Résoudre le problème pourmoi» ou nous envoyer un e-mail.

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×