Ha az ÁTLAG vagy a SZUM függvény olyan cellára hivatkozik, amely #ÉRTÉK! hibát tartalmaz, akkor a képlet eredménye is #ÉRTÉK! hiba lesz.

#ÉRTÉK! hiba az ÁTLAG függvényben

A hibaérték elkerüléséhez létrehozunk egy olyan képletet, amely figyelmen kívül hagyja a hibákat a hivatkozott tartományban, és az átlagot a fennmaradt „normál” értékekből számítja ki.

A képletben az ÁTLAG függvényt a HA és a HIBÁS függvénnyel kombináljuk annak meghatározásához, hogy található-e hiba a megadott tartományban. Ez a megoldás tömbképlet használatát igényli:

=ÁTLAG(HA(HIBÁS(B2:D2);"";B2:D2))

Ez egy tömbképlet. Ezért vagy le kell nyomni az ENTER billentyűt (csak Microsoft 365 ) vagy a CTRL+SHIFT+ENTER billentyűkombinációt a képletben.

Megjegyzés: Ha az Microsoft 365 aktuálisverziójával rendelkezik, akkor egyszerűen beírhatja a képletet a kimeneti cellába, majd az ENTER billentyűt lenyomva megerősítheti a képlet dinamikus tömbképletként való megerősítését. Ellenkező esetben a képletet régi típusú tömbképletként kell beírnia úgy, hogy először kijelöli a kimeneti cellát, beírja a képletet a kimeneti cellába, majd a megerősítéshez lenyomja a CTRL+SHIFT+ENTER billentyűkombinációt. Az Excel a képlet elejére és végére beszúrja Ön helyett a kapcsos zárójeleket. A tömbképletekről további információt az Útmutatások és példák tömbképletek használatához című cikkben talál.

Tömbképlet az ÁTLAG függvényben az #ÉRTÉK! hiba javítása

Megjegyzés: A fenti képlet nemcsak az #ÉRTÉK! hibákhoz, de a #HIÁNYZIK, a #NULLA, a #ZÉRÓOSZTÓ! és más hibák esetében is használható.

A SZUM függvényt is használhatja hasonlóképpen:

=SZUM(HA(HIBÁS(B2:D2);"";B2:D2))

Kérdése van egy adott függvénnyel kapcsolatban?

Tegye fel kérdését az Excel közösségi fórumában

További segítségre van szüksége?

Kérdéseivel mindig felkeresheti az Excel technikai közösség egyik szakértőjét, vagy segítséget kérhet az Answers-közösségben.

Lásd még

Az #ÉRTÉK! hiba javítása

ÁTLAG függvény

SZUM függvény

A képletek áttekintése az Excelben

A képlethibák feltárása

Minden Excel függvény (betűrendes)

Az Excel függvényeinek kategória szerinti listája

További segítségre van szüksége?

Ismeretek bővítése
Oktatóanyagok megismerése
Új szolgáltatások listájának lekérése
Csatlakozás Microsoft Office Insiderekhez

Hasznos volt az információ?

Mennyire elégedett a fordítás minőségével?
Mi befolyásolta a felhasználói élményét?

Köszönjük a visszajelzését!

×