Topik terkait
×
PivotTable
You have multiple accounts
Choose the account you want to sign in with.
PivotTable

Memfilter data di PivotTable

PivotTable sangat cocok untuk mengambil kumpulan data berukuran besar dan membuat ringkasan detail mendalam. 

Browser Anda tidak mendukung video. Instal Microsoft Silverlight, Adobe Flash Player, atau Internet Explorer 9.

Anda bisa menyisipkan satu atau beberapa pemotong untuk cara yang cepat dan efektif untuk memfilter data Anda. Pemotong memiliki tombol yang bisa Anda klik untuk memfilter data, dan tombol tersebut tetap terlihat dengan data Anda, sehingga Anda selalu mengetahui bidang apa yang diperlihatkan atau disembunyikan dalam PivotTable yang difilter.

  1. Pilih sel mana pun dalam PivotTable, lalu masuk ke AnalisisPivot Table > Sisipkan Pemotong Slicer.

  2. Pilih bidang yang ingin Anda buat pemotongnya. Lalu pilih OK.

  3. Excel akan menempatkan satu pemotong pada lembar kerja untuk setiap pilihan yang Anda buat, namun terserah Anda untuk menyusun dan mengukurnya sesuai untuk Anda.

  4. Klik tombol pemotong untuk memilih item yang ingin Anda perlihatkan dalam PivotTable.

Pilihan Pemotong dengan tombol multi-pilih disorot

Filter manual menggunakan FilterOtomatis. Pemotong bekerja bersama dengan pemotong, sehingga Anda dapat menggunakan pemotong untuk membuat filter tingkat tinggi, lalu menggunakan FilterOtomatis untuk menyelam lebih dalam.

  1. Untuk menampilkan FilterOtomatis, pilih panah menurun Filter Panah menurun filter, yang bervariasi tergantung pada tata letak laporan.

    Tata Letak Ringkas   

    PivotTable dalam formulir Ringkas default dengan bidang Nilai di area Baris

    PivotTable dalam formulir Ringkas default dengan bidang Nilai di area Kolom

    Bidang Nilai berada di area Baris

    Bidang Nilai berada di area Kolom

    Tata Letak

    Kerangka/Tabular   

    PivotTable dalam bentuk Kerangka atau TabulasiMenampilkan nama bidang Nilai di sudut kiri atas

  2. Untuk memfilter dengan membuat ekspresi bersyarah, pilih Filter Label, lalu buat filter label.

  3. Untuk memfilter menurut nilai, pilih Filter Nilai lalu buat filter nilai.

  4. Untuk memfilter menurut label baris tertentu (dalam Tata Letak Ringkas) atau label kolom (dalam Kerangka atau Tata Letak Tabulasi), kosongkan centang Pilih Semua, lalu pilih kotak centang di samping item yang ingin Anda perlihatkan. Anda juga bisa memfilter dengan memasukkan teks dalam kotak Pencarian .

  5. Pilih OK.

Tips: Anda juga bisa menambahkan filter ke bidang Filter PivotTable. Ini juga memberi Anda kemampuan untuk membuat lembar kerja PivotTable individual untuk setiap item dalam bidang Filter. Untuk informasi selengkapnya, lihat Menggunakan Daftar Bidang untuk menyusun bidang dalam PivotTable.

Anda juga bisa menerapkan filter untuk memperlihatkan 10 nilai teratas atau terbawah atau data yang memenuhi kondisi tertentu.

  1. Untuk menampilkan FilterOtomatis, pilih panah menurun Filter Panah menurun filter, yang bervariasi tergantung pada tata letak laporan.

    Tata Letak Ringkas   

    PivotTable dalam formulir Ringkas default dengan bidang Nilai di area Baris

    PivotTable dalam formulir Ringkas default dengan bidang Nilai di area Kolom

    Bidang Nilai berada di area Baris

    Bidang Nilai berada di area Kolom

    Tata Letak

    Kerangka/Tabular   

    PivotTable dalam bentuk Kerangka atau TabulasiMenampilkan nama bidang Nilai di sudut kiri atas

  2. Pilih Filter Nilai > 10 Teratas.

  3. Dalam kotak pertama, pilih Atas atau Bawah.

  4. Dalam kotak kedua, masukkan angka.

  5. Dalam kotak ketiga, lakukan hal berikut:

    • Untuk memfilter menurut jumlah item, pilih Item.

    • Untuk memfilter menurut persentase, pilih Persentase.

    • Untuk memfilter menurut jumlah, pilih Jumlah.

  6. Dalam kotak keempat, pilih bidang Nilai .

Dengan filter laporan, Anda dapat menampilkan sekumpulan nilai yang berbeda dalam PivotTable dengan cepat. Item yang dipilih dalam filter ditampilkan dalam PivotTable, dan item yang tidak dipilih akan disembunyikan. Jika ingin menampilkan halaman filter (sekumpulan nilai yang sesuai dengan item filter laporan yang dipilih) pada lembar kerja terpisah, Anda dapat menentukan opsi tersebut.

Menambahkan filter laporan

  1. Klik di mana pun dalam PivotTable.

    Panel Bidang PivotTable akan muncul.

  2. Dalam Daftar Bidang PivotTable, klik bidang di suatu area lalu pilih Pindahkan ke Filter Laporan.

Anda dapat mengulangi langkah ini untuk membuat lebih dari satu filter laporan. Filter laporan ditampilkan di atas PivotTable agar mudah diakses.

  • Untuk mengubah urutan bidang, di area Filter, Anda dapat menyeret bidang ke posisi yang diinginkan, atau mengklik ganda bidang dan memilih Pindahkan ke Atas atau Pindahkan ke Bawah. Urutan filter laporan akan terlihat sebagaimana ditentukan dalam PivotTable.

Menampilkan filter laporan dalam baris atau kolom

  1. Klik PivotTable atau PivotTable yang terkait dari PivotChart.

  2. Klik kanan di mana saja dalam PivotTable, kemudian klik Opsi PivotTable.

  3. Dalam tab Tata Letak, tentukan opsi berikut:

    1. Di bawah area Filter Laporan, dalam kotak daftar Susun bidang, lakukan salah satu hal berikut:

      • Untuk menampilkan filter laporan dalam baris dari atas ke bawah, pilih Turun, Lalu Naik.

      • Untuk menampilkan filter laporan dalam kolom dari kiri ke kanan, pilih Naik, Lalu Turun.

    2. Dalam kotak Filter bidang per kolom, ketik atau pilih jumlah bidang untuk ditampilkan sebelum mengisi kolom atau baris lain (berdasarkan pengaturan Susun bidang yang ditentukan dalam langkah sebelumnya).

Memilih item dalam filter laporan

  1. Di PivotTable, klik panah daftar menurun di samping filter laporan.

  2. Pilih kotak centang di samping item yang ingin ditampilkan dalam laporan. Untuk memilih semua item, klik kotak centang di samping (Pilih Semua).

    Filter laporan kini menampilkan item yang difilter.

Menampilkan halaman filter laporan pada lembar kerja terpisah

  1. Klik di mana saja dalam PivotTable (atau PivotTable yang terkait dari PivotChart) yang memiliki satu atau beberapa filter laporan.

  2. Klik Analisis PivotTable (pada pita) > Opsi > Perlihatkan Halaman Filter Laporan.

  3. Dalam kotak dialog Tampilkan Halaman Filter Laporan, pilih bidang filter laporan, lalu klik OK.

  1. Dalam PivotTable, pilih satu atau beberapa item di bidang yang ingin difilter berdasarkan pilihan.

  2. Klik kanan item dalam pilihan, lalu klik Filter.

  3. Lakukan salah satu hal berikut:

    • Untuk menampilkan item yang dipilih, klik Tampilkan Item yang Dipilih Saja.

    • Untuk menyembunyikan item yang dipilih, klik Sembunyikan Item yang Dipilih.

      Tips: Anda dapat menampilkan kembali item tersembunyi dengan menghapus filter. Klik kanan item lainnya di bidang yang sama, klik Filter, lalu klik Hapus Filter.

Jika Anda ingin menerapkan beberapa filter tiap bidang, atau jika Anda tidak ingin memperlihatkan tombol Filter dalam PivotTable Anda, berikut ini cara Anda bisa mengaktifkan dan menonaktifkan pemfilteran:

  1. Klik di mana saja dalam PivotTable untuk memperlihatkan tab PivotTable pada pita.

  2. Pada tab Analisis PivotTable, klik Opsi.

    1. Dalam kotak dialog Opsi PivotTable , klik tab Total & Filter.

    2. Di area Filter, centang atau kosongkan kotak centang Perbolehkan beberapa filter per bidang tergantung pada apa yang Anda perlukan.

    3. Klik tab Tampilan , lalu centang atau kosongkan kotak centang Tampilkan Keterangan bidang dan filter , untuk memperlihatkan atau menyembunyikan keterangan bidang dan menu menurun filter.

Anda bisa menampilkan dan berinteraksi dengan PivotTable di Excel untuk webdengan membuat pemotong dan dengan pemfilteran manual.

Pemotong menyediakan tombol yang bisa Anda klik untuk memfilter tabel, atau PivotTable. Selain pemfilteran cepat, pemotong juga menunjukkan status pemfilteran saat ini, yang memudahkan untuk memahami apa yang saat ini ditampilkan.

Pemotong dengan item yang dipilih

Untuk informasi selengkapnya, lihat Menggunakan pemotong untuk memfilter data.

Jika Anda memiliki aplikasi desktop Excel, Anda bisa menggunakan tombol Buka di Excel untuk membuka buku kerja dan membuat pemotong baru untuk data PivotTable Anda di sana. Klik Buka di Excel dan filter data Anda di PivotTable.

Filter manual menggunakan FilterOtomatis. Pemotong bekerja bersama dengan pemotong, sehingga Anda dapat menggunakan pemotong untuk membuat filter tingkat tinggi, lalu menggunakan FilterOtomatis untuk menyelam lebih dalam.

  1. Untuk menampilkan FilterOtomatis, pilih panah menurun Filter Panah menurun filter, yang bervariasi tergantung pada tata letak laporan.

    Kolom   

    Tunggal
    Formulir Tata Letak default dengan bidang Nilai di area BarisTata Letak default menampilkan bidang Nilai di area Baris

    Pisahkan Kolom   


    Formulir Pisahkan Tata Letak Kolom dengan bidang Baris bertumpuk dalam kolom yang berbeda Menampilkan bidang Baris bertumpuk dalam kolom yang berbeda

  2. Untuk memfilter dengan membuat ekspresi bersyarah, pilih <Nama bidang>Filter Label >, lalu buat filter label.

  3. Untuk memfilter menurut nilai, pilih <Nama bidang>Filter Nilai > lalu buat filter nilai.

  4. Untuk memfilter menurut label baris tertentu, pilih Filter, kosongkan centang Pilih Semua, lalu pilih kotak centang di samping item yang ingin Anda perlihatkan. Anda juga bisa memfilter dengan memasukkan teks dalam kotak Pencarian .

  5. Pilih OK.

Tips: Anda juga bisa menambahkan filter ke bidang Filter PivotTable. Ini juga memberi Anda kemampuan untuk membuat lembar kerja PivotTable individual untuk setiap item dalam bidang Filter. Untuk informasi selengkapnya, lihat Menggunakan Daftar Bidang untuk menyusun bidang dalam PivotTable.

  1. Klik di mana saja dalam PivotTable untuk memperlihatkan tab PivotTable (Analisis PivotTable dan Desain) pada pita.

  2. Klik Analisis PivotTable > Sisipkan Pemotong.

  3. Dalam kotak dialog Sisipkan Pemotong, centang kotak dari bidang yang ingin Anda potong.

  4. Klik OK.

    Pemotong muncul untuk setiap bidang yang Anda centang dalam kotak dialog Sisipkan Pemotong.

  5. Di setiap pemotong, klik item yang Anda inginkan untuk terlihat di PivotTable.

Pemotong dengan item yang dipilih

Tips: Untuk mengubah tampilan pemotong, klik pemotong untuk memperlihatkan tab Pemotong pada pita. Anda dapat menerapkan gaya pemotong atau mengubah pengaturan menggunakan berbagai opsi tab.

  1. Di PivotTable, klik panah Panah menurun filter pada Label Baris atau Label Kolom.

  2. Di daftar label baris atau kolom, hapus centang kotak (Pilih Semua) di bagian atas daftar, lalu centang kotak item yang ingin Anda perlihatkan dalam PivotTable.

  3. Panah pemfilter berubah menjadi ikon Ikon filter yang diterapkan untuk mengindikasikan bahwa filter telah diterapkan. Klik ini untuk mengubah atau menghapus filter dengan mengklik Hapus Filter Dari <Nama Bidang>.

    Untuk menghapus semua pemfilteran sekaligus, klik tab Analisis PivotTable > Hapus > Hapus Filter.

Dengan filter laporan, Anda dapat menampilkan sekumpulan nilai yang berbeda dalam PivotTable dengan cepat. Item yang dipilih dalam filter ditampilkan dalam PivotTable, dan item yang tidak dipilih akan disembunyikan. Jika ingin menampilkan halaman filter (sekumpulan nilai yang sesuai dengan item filter laporan yang dipilih) pada lembar kerja terpisah, Anda dapat menentukan opsi tersebut.

Menambahkan filter laporan

  1. Klik di mana pun dalam PivotTable.

    Panel Bidang PivotTable akan muncul.

  2. Dalam Daftar Bidang PivotTable, klik bidang di suatu area lalu pilih Pindahkan ke Filter Laporan.

Anda dapat mengulangi langkah ini untuk membuat lebih dari satu filter laporan. Filter laporan ditampilkan di atas PivotTable agar mudah diakses.

  • Untuk mengubah urutan bidang, di area Filter, Anda dapat menyeret bidang ke posisi yang diinginkan, atau mengklik ganda bidang dan memilih Pindahkan ke Atas atau Pindahkan ke Bawah. Urutan filter laporan akan terlihat sebagaimana ditentukan dalam PivotTable.

Menampilkan filter laporan dalam baris atau kolom

  1. Klik PivotTable atau PivotTable yang terkait dari PivotChart.

  2. Klik kanan di mana saja dalam PivotTable, kemudian klik Opsi PivotTable.

  3. Dalam tab Tata Letak, tentukan opsi berikut:

    1. Di bawah area Filter Laporan, dalam kotak daftar Susun bidang, lakukan salah satu hal berikut:

      • Untuk menampilkan filter laporan dalam baris dari atas ke bawah, pilih Turun, Lalu Naik.

      • Untuk menampilkan filter laporan dalam kolom dari kiri ke kanan, pilih Naik, Lalu Turun.

    2. Dalam kotak Filter bidang per kolom, ketik atau pilih jumlah bidang untuk ditampilkan sebelum mengisi kolom atau baris lain (berdasarkan pengaturan Susun bidang yang ditentukan dalam langkah sebelumnya).

Memilih item dalam filter laporan

  1. Di PivotTable, klik panah daftar menurun di samping filter laporan.

  2. Pilih kotak centang di samping item yang ingin ditampilkan dalam laporan. Untuk memilih semua item, klik kotak centang di samping (Pilih Semua).

    Filter laporan kini menampilkan item yang difilter.

Menampilkan halaman filter laporan pada lembar kerja terpisah

  1. Klik di mana saja dalam PivotTable (atau PivotTable yang terkait dari PivotChart) yang memiliki satu atau beberapa filter laporan.

  2. Klik Analisis PivotTable (pada pita) > Opsi > Perlihatkan Halaman Filter Laporan.

  3. Dalam kotak dialog Tampilkan Halaman Filter Laporan, pilih bidang filter laporan, lalu klik OK.

Anda juga bisa menerapkan filter untuk memperlihatkan 10 nilai teratas atau terbawah atau data yang memenuhi kondisi tertentu.

  1. Di PivotTable, klik panah Panah menurun filter di samping Label Baris atau Label Kolom.

  2. Klik kanan item dalam pilihan, lalu klik Filter > 10 Teratas atau 10 Terbawah.

  3. Dalam kotak pertama, masukkan angka.

  4. Dalam kotak kedua, pilih opsi filter yang Anda inginkan. Opsi berikut ini tersedia:

    • Untuk memfilter menurut jumlah item, pilih Item.

    • Untuk memfilter menurut persentase, pilih Persentase.

    • Untuk memfilter menurut jumlah, pilih Jumlah.

  5. Dalam kotak pencarian, Anda dapat mencari nilai tertentu secara opsional.

  1. Dalam PivotTable, pilih satu atau beberapa item di bidang yang ingin difilter berdasarkan pilihan.

  2. Klik kanan item dalam pilihan, lalu klik Filter.

  3. Lakukan salah satu hal berikut:

    • Untuk menampilkan item yang dipilih, klik Tampilkan Item yang Dipilih Saja.

    • Untuk menyembunyikan item yang dipilih, klik Sembunyikan Item yang Dipilih.

      Tips: Anda dapat menampilkan kembali item tersembunyi dengan menghapus filter. Klik kanan item lainnya di bidang yang sama, klik Filter, lalu klik Hapus Filter.

Jika Anda ingin menerapkan beberapa filter tiap bidang, atau jika Anda tidak ingin memperlihatkan tombol Filter dalam PivotTable Anda, berikut ini cara Anda bisa mengaktifkan dan menonaktifkan pemfilteran:

  1. Klik di mana saja dalam PivotTable untuk memperlihatkan tab PivotTable pada pita.

  2. Pada tab Analisis PivotTable, klik Opsi.

    1. Dalam kotak dialog Opsi PivotTable, klik tab Tata Letak.

    2. Di area Tata Letak, centang atau hapus centang kotak Izinkan beberapa filter per bidang sesuai kebutuhan Anda.

    3. Klik tab Tampilan , lalu centang atau kosongkan kotak centang Keterangan bidang dan filter , untuk memperlihatkan atau menyembunyikan keterangan bidang dan menu menurun filter.

Perlu bantuan lainnya?

Anda dapat bertanya kapan saja kepada pakar di Komunitas Teknologi Excel atau mendapatkan dukungan di Komunitas Jawaban.

Lihat Juga

Video: Memfilter data di PivotTable

Membuat PivotTable untuk menganalisis data lembar kerja

Membuat PivotTable untuk menganalisis data eksternal

Membuat PivotTable untuk menganalisis data dalam beberapa tabel

Mengurutkan data dalam PivotTable

Mengelompokkan atau memisahkan data di PivotTable

Perlu bantuan lainnya?

Kembangkan keterampilan Anda
Jelajahi pelatihan
Dapatkan fitur baru terlebih dahulu
Gabung Microsoft Office Insiders

Apakah informasi ini bermanfaat?

Seberapa puaskah Anda dengan kualitas bahasanya?
Apa yang memengaruhi pengalaman Anda?

Terima kasih atas umpan balik Anda!

×