We couldn’t sign you in
Select the account you want to use.

Suggerimento: Provare a usare la nuova funzione CERCA.X, una versione migliorata di CERCA.V che funziona in qualsiasi direzione e restituisce corrispondenze esatte per impostazione predefinita, semplificando e rendendo più conveniente l'uso rispetto al predecessore.

Usare CERCA.VERT per cercare valori in una tabella o un intervallo per riga. Ad esempio è possibile cercare un prezzo di un componente di un’auto in base al numero del pezzo o trovare il nome di un dipendente in base al suo ID dipendente.

Nella sua forma più semplice, la funzione CERCA.VERT è:

=CERCA.VERT(Cosa cercare, dove si vuole cercarlo, il numero di colonna nell'intervallo contenente il valore da restituire, restituire una corrispondenza approssimativa o esatta, indicata come 1/VERO o 0/FALSO).

Il browser in uso non supporta le funzionalità video. Installare Microsoft Silverlight, Adobe Flash Player o Internet Explorer 9.

Suggerimento: Per usare al meglio la funzione CERCA.VERT, occorre organizzare i dati in modo che il valore di ricerca (Frutta) si trovi a sinistra del valore restituito da trovare (Quantità).

Usare la funzione CERCA.VERT per cercare un valore in una tabella.

Sintassi 

CERCA.VERT (valore; matrice_tabella; indice; [intervallo])

Ad esempio:

  • =CERCA.VERT(A2;A10:C20;2;VERO)

  • =CERCA.VERT("Leoni";B2:E7;2;FALSO)

  • =CERCA.VERT(A2;'Dettagli client'! A:F,3,FALSO)

Nome argomento

Descrizione

valore    (obbligatorio)

Valore da cercare. Il valore da cercare deve trovarsi nella prima colonna dell'intervallo di celle specificato nell'argomento matrice_tabella.

Ad esempio, se matrice_tabella occupa l'intervallo di celle B2:D7, il valore da cercare deve essere nella colonna B.

valore può essere un valore o un riferimento a una cella.

matrice_tabella    (obbligatorio)

Intervallo di celle in cui CERCA.VERT cercherà il valore e valore restituito. È possibile usare un intervallo denominato o una tabella e i nomi nell'argomento al posto dei riferimenti di cella. 

La prima colonna dell'intervallo di celle deve contenere il valore_cerca. L'intervallo di celle deve includere anche il valore da trovare.

Informazioni su come selezionare intervalli in un foglio di lavoro.

indice    (obbligatorio)

Numero della colonna (a partire da 1 per la colonna all'estrema sinistra di matrice_tabella) che contiene il valore restituito.

intervallo   (facoltativo)

Valore logico che specifica se si vuole trovare una corrispondenza esatta o approssimativa mediante la funzione CERCA.VERT:

  • Corrispondenza approssimativa: 1/VERO presuppone che la prima colonna della tabella sia in ordine numerico o alfabetico e quindi cerca il valore più prossimo. Questo è il metodo predefinito, se non se ne specifica uno. Ad esempio, =CERCA.VERT(90;A1:B100;2;VERO).

  • Corrispondenza esatta: 0/FALSO cerca il valore esatto nella prima colonna. Ad esempio, =CERCA.VERT("Smith",A1:B100,2,FALSO).

Come iniziare

Per creare la sintassi di CERCA.VERT sono necessari quattro tipi di informazioni:

  1. Il valore da cercare, detto anche valore di ricerca.

  2. L'intervallo che contiene il valore di ricerca. Tenere presente che il valore di ricerca deve trovarsi sempre nella prima colonna dell'intervallo affinché CERCA.VERT funzioni correttamente. Ad esempio, se il valore di ricerca è nella cella C2, l'intervallo deve iniziare con C.

  3. Il numero di colonna nell'intervallo che contiene il valore restituito. Ad esempio, se si specifica B2:D11 come intervallo, occorre considerare B come la prima colonna, C come la seconda e così via.

  4. Se si vuole, si può specificare VERO se si vuole ottenere una corrispondenza approssimativa o FALSO se si vuole ottenere una corrispondenza esatta del valore restituito. Se non si specifica nulla, il valore predefinito sarà sempre VERO o una corrispondenza approssimativa.

Ora disporre tutte queste informazioni nel modo seguente:

=CERCA.VERT(valore di ricerca; intervallo che contiene il valore di ricerca; numero di colonna nell'intervallo che contiene il valore restituito, corrispondenza approssimativa (VERO) o corrispondenza esatta (FALSO)).

Esempi

Ecco alcuni esempi della funzione CERCA.VERT:

Esempio 1

=CERCA.VERT (B3;B2:E7;2;FALSO)

CERCA.VERT cerca Fontana nella prima colonna (colonna B) della matrice_tabella B2:E7 e restituisce Olivier dalla seconda colonna (colonna C) della matrice_tabella.  Falso restituisce una corrispondenza esatta.

Esempio 2

=CERCA.VERT (102;A2:C7;2;FALSO)

CERCA.VERT cerca una corrispondenza esatta (FALSO) del cognome per 102 (lookup_value) nella seconda colonna (colonna B) dell'intervallo A2:C7 e restituisce Fontana.

Esempio 3

=SE(CERCA.VERT(103;A1:E7;2;FALSO)="Sous";"Trova";"Non trovato")

SE verifica se CERCA.VERT restituisce Sousa come cognome del dipendente corrispondente a 103 (lookup_value) in A1:E7 (matrice_tabella). Poiché il cognome corrispondente a 103 è Leal, la condizione SE è falsa e viene visualizzata la condizione Non trovato.

Esempio 4

=INT(FRAZIONE.ANNO(DATA(2014;6;30);CERCA.VERT(105;A2:E7;5;FLASE);1))



VERCA.VERT cerca la data di nascita del dipendente corrispondente a 109 (valore) nell'intervallo A2:E7 (matrice_tabella) e restituisce il 04/03/1955. Quindi, FRAZIONE.ANNO sottrae questa data di nascita dal 30/06/2014 e restituisce un valore, che viene quindi convertito da INY nell'intero 59.

Esempio 5

SE(ISNA(CERCA.VERT(105;A2:E7;2;FLASE))=VERO,"Dipendente non trovato",CERCA.VERT(105;A2:E7;2;FALSO))



SE verifica se CERCA.VERT restituisce un valore per il cognome dalla colonna B per 105 (lookup_value). Se CERCA.VERT trova un cognome, se ne visualizza il cognome, altrimenti SE restituisce Dipendente non trovato. ISNA assicura che se CERCA.VERT restituisce #N/D, l'errore viene sostituito da Dipendente non trovato invece di #N/D.



In questo esempio il valore restituito è Burke, ovvero il cognome corrispondente a 105.

È possibile usare CERCA.VERT per combinare più tabelle in una sola, purché una delle tabelle abbia campi in comune con tutte le altre. Ciò può risultare particolarmente utile se è necessario condividere una cartella di lavoro con utenti che hanno versioni precedenti di Excel che non supportano le caratteristiche dati con più tabelle come origini dati; combinando le origini in un'unica tabella e modificando l'origine dati della caratteristica dati nella nuova tabella, la caratteristica dati può essere usata nelle versioni Excel precedenti, purché la stessa caratteristica sia supportata dalla versione precedente.

Foglio di lavoro con colonne che usano CERCA.VERT per recuperare dati da altre tabelle

In questo caso, le colonne A-F e H contengono valori o formule che utilizzano solo valori nel foglio di lavoro e le altre colonne usano CERCA.VERT e i valori della colonna A (Codice client) e della colonna B (Attorney) per ottenere dati da altre tabelle.

  1. Copiare la tabella che contiene i campi comuni in un nuovo foglio di lavoro e assegnarle un nome.

  2. Fare clic su Data > Data Tools > Relationships per aprire la finestra di dialogo Gestisci relazioni.

    Finestra di dialogo Gestisci relazioni
  3. Per ogni relazione elencata, tenere presente quanto segue:

    • Campo che collega le tabelle (tra parentesi nella finestra di dialogo). Questo è il valore per la formula CERCA.VERT.

    • Nome tabella di ricerca correlata. Questa è la matrice_tabella nella formula CERCA.VERT.

    • Campo (colonna) della tabella di ricerca correlata contenente i dati desiderati nella nuova colonna. Queste informazioni non vengono visualizzate nella finestra di dialogo Gestisci relazioni. È necessario esaminare la tabella di ricerca correlata per visualizzare il campo da recuperare. Si vuole prendere nota del numero di colonna (A=1), ovvero il col_index_num nella formula.

  4. Per aggiungere un campo alla nuova tabella, immettere la formula CERCA.VERT nella prima colonna vuota usando le informazioni raccolte nel passaggio 3.

    In questo esempio la colonna G usa Attorney (il valore) per ottenere i dati della tariffa di fatturazione dalla quarta colonna (col_index_num = 4) dalla tabella del foglio di lavoro Attorneys, tblAttorneys (il matrice_tabella), con la formula =CERCA.VERT([@Attorney],tbl_Attorneys,4,FALSO).

    La formula può anche usare un riferimento di cella e un riferimento di intervallo. In questo esempio sarebbe =CERCA.VERT(A2;'Attorneys'! A:D,4,FALSO).

  5. Continuare ad aggiungere campi fino ad avere tutti i campi necessari. Se si sta tentando di preparare una cartella di lavoro contenente funzionalità di dati che usano più tabelle, modificare l'origine dati della caratteristica dati nella nuova tabella.

Problema

Descrizione dell'errore

Valore errato restituito

Se intervallo ha valore VERO o viene omesso, la prima colonna deve essere ordinata alfabeticamente o numericamente. Se la prima colonna non è ordinata, il valore restituito potrebbe non essere quello previsto. Ordinare la prima colonna oppure usare FALSO per ottenere una corrispondenza esatta.

#N/D in una cella

  • Se intervallo ha valore VERO e il valore di valore è inferiore al valore più piccolo nella prima colonna di matrice_tabella, viene restituito il valore di errore #N/D.

  • Se intervallo è FALSO, il valore di errore #N/D indica che non è stato trovato il numero esatto.

Per altre informazioni su come correggere gli errori #N/D in CERCA.VERT vedere Come correggere un errore #N/D nella funzione CERCA.VERT.

#RIF! in una cella

Se il valore di indice è maggiore del numero di colonne in matrice_tabella, viene restituito il valore di errore #RIF! .

Per altre informazioni su come correggere gli errori #RIF! in CERCA.VERT, vedere Come correggere un errore #RIF!..

#VALORE! in una cella

Se il valore di matrice_tabella è inferiore a 1, viene restituito il valore di errore #VALORE! .

Per altre informazioni su come correggere gli errori #VALORE! in CERCA.VERT vedere Come correggere un errore #VALORE! nella funzione CERCA.VERT.

#NOME? in una cella

Il valore di errore #NOME? indica in genere che nella formula mancano le virgolette. Per cercare il nome di una persona, racchiuderlo tra virgolette nella formula. Ad esempio, immettere il nome nel formato "Leoni" in =CERCA.VERT("Leoni";B2:E7;2;FALSO).

Per altre informazioni, vedere Come correggere un errore #NOME?.

Errori #SPILL! in una cella

Questo particolare errore #SPILL! in genere significa che la formula si basa su un'intersezione implicita per il valore di ricerca e usa un'intera colonna come riferimento. Ad esempio, =CERCA.VERT(A:A;A:C;2;FALSO). È possibile risolvere il problema ancorando il riferimento di ricerca con l'operatore @ in questo modo: =CERCA.VERT(@A:A,A:C,2,FALSO). In alternativa, è possibile usare il metodo tradizionale CERCA.VERT e fare riferimento a una singola cella invece che a un'intera colonna: =CERCA.VERT(A2;A,A:C,2,FALSO).

Operazione da eseguire

Motivo

Usare riferimenti assoluti per intervallo

L'uso di riferimenti assoluti consente di copiare in basso una formula in modo che si riferisca sempre allo stesso intervallo di ricerca esatto.

Altre informazioni su come usare i riferimenti di cella assoluti.

Non memorizzare valori numerici o di data come testo.

Quando si cercano valori numerici o date, assicurarsi che i dati nella prima colonna di matrice_tabella non siano memorizzati come valori di testo, altrimenti CERCA.VERT potrebbe restituire un valore non corretto o imprevisto.

Ordinare la prima colonna

Ordinare la prima colonna di matrice_tabella prima di usare CERCA.VERT quando intervallo è VERO.

Usare caratteri jolly

Se intervallo è FALSO e valore è un valore di testo, è possibile usare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*), in valore. Un punto interrogativo corrisponde a qualsiasi carattere singolo. Un asterisco corrisponde a qualsiasi sequenza di caratteri. Per trovare un vero e proprio punto interrogativo o asterisco, anteporre una tilde (~) a tale carattere.

Ad esempio, =CERCA.VERT("Leon?";B2:E7;2;FALSO) cercherà tutte le istanze di Fontana, con l'ultima lettera variabile.

Verificare che i dati non contengano caratteri errati.

Quando si cercano valori di testo nella prima colonna, assicurarsi che i dati in tale colonna non contengano spazi iniziali, spazi finali, un uso non coerente delle virgolette semplici (' o ") e inglesi (‘ o “) o caratteri non stampabili. In questi casi, CERCA.VERT potrebbe restituire un valore imprevisto.

Per ottenere risultati precisi, provare a usare la funzione LIBERA o la funzione ANNULLA.SPAZI per rimuovere gli spazi finali dopo i valori di tabella in una cella.

Servono altre informazioni?

È sempre possibile rivolgersi a un esperto nella Tech Community di Excel oppure ottenere supporto nella community Microsoft.

Ottenere risposte in tempo reale e gratuite in Excel

Vedere anche

Scheda di riferimento rapido: aggiornamento di CERCA.VERT
Scheda di riferimento rapido: suggerimenti per la risoluzione dei problemi relativi a CERCA.VERT
Come correggere un errore di #VALUE! nella funzione CERCA.VERT
Come correggere un errore #N/D nella funzione CERCA.VERT
Panoramica delle formule in Excel
Come evitare errori nelle formule
Rilevare errori nelle formule
Funzioni di Excel (in ordine alfabetico)
Funzioni di Excel (per categoria)
CERCA.VERT (anteprima gratuita)

Serve aiuto?

Amplia le tue competenze
Esplora i corsi di formazione
Ottieni in anticipo le nuove caratteristiche
Partecipa a Microsoft Office Insider

Queste informazioni sono risultate utili?

Come valuti la qualità della lingua?
Cosa ha influito sulla tua esperienza?

Grazie per il feedback!

×