デスクトップ データベースのアクセスの基本的なタスク

適用先
Access for Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Access データベースを使用すると、在庫、連絡先、ビジネス プロセスなど、ほとんどすべての種類の情報を保存および追跡できます。 Access デスクトップ データベースを作成し、データを追加し、新しいデータベースをカスタマイズして使用するための次の手順について説明します。

この記事の内容

テンプレートを選ぶ

Access テンプレートには、すぐに使用できる組み込みのテーブル、クエリ、フォーム、レポートがあります。 テンプレートは、Access を起動したときに最初に表示されるものの 1 つで、オンラインでその他のテンプレートを検索できます。

Access の起動画面のテンプレート ビュー

  1. Access で、[ ファイル>新規] を選択します。
  2. デスクトップ データベース テンプレートを選択し、[ ファイル名] でデータベースの名前を入力します。 適切なテンプレートが見つからない場合は、[ オンライン テンプレートの検索 ] ボックスを使用してください。
  3. Access が [ ファイル名 ] ボックスの下に表示する既定の場所を使用することも、フォルダー アイコンを選択してファイル名を選択することもできます。
  4. [作成] を選択します。

テンプレートから Access デスクトップ データベースを作成する

テンプレートによっては、開始するために次のいずれかの操作が必要になる場合があります。

  • Access で、空のユーザー リストの [ ログイン] ダイアログ ボックスが表示される場合:

    1. [新しいユーザー] を選択します。
    2. [ ユーザー詳細 ] フォームに入力します。
    3. [保存して閉じる] を選択します。
    4. 先ほど入力したユーザー名を選択し、[ ログイン] を選択します。
  • Access のメッセージ バーに セキュリティ警告 メッセージが表示され、テンプレートの発行元が信頼できる場合は、[ コンテンツを有効にする] を選択します。 データベースにログインが必要な場合は、もう一度サインインします。

詳細については、「 テンプレートから Access デスクトップ データベースを作成する」を参照してください。

データベースを一から作成する

どのテンプレートもニーズに合わない場合は、空のデスクトップ データベースから始めることができます。

  1. Access で、[新規作成>空白のデスクトップ データベース] を選択します。
  2. [ ファイル名 ] ボックスにデータベースの名前を入力します。
  3. Access が [ ファイル名 ] ボックスの下に表示する既定の場所を使用することも、フォルダー アイコンを選択してファイル名を選択することもできます。
  4. [作成] を選択します。

表を追加する

データベースでは、複数の関連テーブルに情報が格納されます。 テーブルを作成するには:

  1. データベースを初めて開くと、データを追加できるデータシート ビューに空のテーブルが表示されます。 別のテーブルを追加するには、[作成>テーブル] を選択します。 空のフィールド (セル) へのデータの入力を開始するか、Excel ブックなどの別のソースからデータを貼り付けることができます。

  2. 列 (フィールド) の名前を変更するには、列見出しをダブルクリックして、新しい名前を入力します。

    ヒント

    意味のある名前は、各フィールドの内容を表示せずに各フィールドに何が含まれているかを知るのに役立ちます。

  3. [ ファイル>保存] を選択します。

  • さらにフィールドを追加するには、[ クリックして追加 ] 列に入力します。
  • 列を移動するには、列見出しをクリックして列を選択し、目的の場所にドラッグします。 隣接する列を選択して、それらを一緒に新しい場所にドラッグすることもできます。

詳細については、「テーブルの概要」を参照してください。

データをコピーして貼り付ける

Excel や Word などの別のプログラムからデータをコピーし、Access のテーブルに貼り付けることができます。 これは、データが列に区切られている場合に最適です。 データが Word などのワープロ プログラムにある場合は、コピーする前に、タグを使用して列を区切るか、データを表形式に変換します。

  1. フル ネームを姓と名に区切るなど、データを編集する必要がある場合は、最初にソース プログラムで編集を行います。

  2. ソースを開き、 Ctrl+C を押してデータをコピーします。

  3. データシート ビューでデータを追加する Access テーブルを開き、 Ctrl + V キーを押して貼り付けます。

  4. 各列見出しをダブルクリックして、意味のある名前を入力します。

  5. [ ファイル>保存] を選択し、新しいテーブルに名前を付けます。

    注

    Access では、各列の 1 行目に貼り付ける情報に基づいて各フィールドのデータ型が設定されるため、次の行の情報が 1 行目と一致していることを確認してください。

他のソースからデータをインポートすることも、保存されている場所から情報を移動せずに Access からデータにリンクすることもできます。 複数のユーザーがデータを更新し、最新バージョンが表示されていることを確認したい場合、または記憶域を節約したい場合、リンクは良いオプションです。 ほとんどの形式では、データにリンクするかデータをインポートするかを選択できます。 詳細については、「 別の Access データベースのデータのインポートとリンクの設定」を参照してください。

このプロセスはデータ ソースによって若干異なりますが、次の手順が作業を開始するのに役立ちます。

  1. [ 外部データ] タブの [リンクのインポート ] グループ & [ 新しいデータ ソース] を選択し、一覧表示されているサブメニュー オプションからインポート元またはリンク先のデータ形式を選択します。

    注

    それでも正しい形式が見つからない場合は、まず、区切りテキスト ファイルなどの Access でサポートされているファイル形式にデータをエクスポートする必要があります。

  2. [ 外部データの取り込み] ダイアログ ボックスの指示に従います。

リンクすると、一部の形式は読み取り専用として使用できます。 データをインポートまたはリンクできる外部ソースを次に示します。

発生元 インポート リンク
Excel はい はい (読み取り専用)
Access ○ ○
SQL Server などの ODBC データベース はい ○
テキストまたはコンマ区切り (CSV) ファイル はい はい (新規レコードの追加のみ)
SharePoint リスト はい ○
XML はい
データ サービス はい (読み取り専用)
HTML ドキュメント はい ○
Outlook フォルダー はい ○

詳細については、「 別の Access データベースのデータのインポートとリンクの設定」を参照してください。

テーブルの正規化を使用してデータを整理する

テーブル アナライザー ウィザードを使用すると、冗長なデータをすばやく識別できます。 そうすると、データを個別のテーブルに整理する簡単な方法がウィザードで提供されます。 元のテーブルはバックアップとして保存されます。

  1. 分析するテーブルを含む Access データベースを開きます。
  2. [データベース ツール]>[テーブルの分析] を選択します。 ウィザードの最初の 2 ページには、例を含む短いチュートリアルが含まれています。 [概要ページを表示しますか?] というラベルの付いたチェック ボックスが表示されている場合は、それを選択し、[戻る] を 2 回選択して概要を表示します。 紹介ページを再度表示したくない場合は、[ 紹介ページを表示しますか?] をオフにします。

詳細については、「 テーブル アナライザーを使用してデータを正規化する」を参照してください。

ページの先頭へ

次のステップ

残りのデザイン プロセスは、何を行うかによって異なりますが、クエリ、フォーム、レポート、およびマクロの作成を検討することをお勧めします。 次の記事が役に立ちます。

ページの先頭へ