クエリを作成、読み込み、または編集する (power Query) Excelクエリ)

Power Query には、Power クエリを作成してブックに読み込む方法がいくつか用意されています。 [クエリ オプション] ウィンドウで既定のクエリ読み込 み設定を設定 することもできます。   

ヒント      ワークシート内のデータが Power Query で整形されたのかを確認するには、データのセルを選択し、[クエリ コンテキスト] リボン タブが表示される場合は、Power Query からデータが読み込まれます。 

クエリ内のセルを選択して [クエリ] タブを表示する

使用している環境を確認する Power Query は、データのインポート、接続の処理、ピボット テーブル、Excel テーブル、名前付き範囲の編集を行う場合に特に、Excel ユーザー インターフェイスに十分に統合されています。 混乱を避けるためには、現在どの環境を使用Excel Power Query を使用するかが重要です。

使い慣れたExcel、リボン、グリッド

Power Query エディターリボンとデータ プレビュー 

一般的なExcelワークシート 一般的な Power Query エディター ビュー

たとえば、ワークシート内のデータを操作Excel Power Query とは根本的に異なります。 さらに、Excel ワークシートに表示される接続されたデータは、Power Query が背後で動作してデータを形成する場合と機能しない場合があります。 これは、Power Query からワークシートまたはデータ モデルにデータを読み込場合にのみ発生します。

ワークシートのタブの名前を変更する    ワークシートのタブの名前は、特に多くのタブがある場合は、意味のある方法で名前を変更する方法をお勧めしています。 データのワークシートと Power Query Editor から読み込まれたワークシートの違いを明確にすることが特に重要です。 ワークシートが 2 つしかなくても、1 つは Sheet1 という名前の Excel テーブルを持ち、もう1つはテーブル1という名前の Excel テーブルをインポートして作成されたクエリです。 ワークシート タブの既定の名前を、より意味のある名前に変更する方法は常に有効です。 たとえば、Sheet1 の名前を DataTable、Table1QueryTable に変更します。 これで、どのタブにデータが含まれており、どのタブにクエリがあるのかが明らかです。

インポートしたデータからクエリを作成するか、空のクエリを作成できます。

インポートされたデータからクエリを作成する

これは、クエリを作成する最も一般的な方法です。

  1. データをインポートします。 詳細については、「外部データ ソース からデータをインポートする」を参照してください

  2. データ内のセルを選択し、[クエリ] を選択 し、[編集 ]> 選択します

空のクエリを作成する

最初から始めるのが良い場合があります。 これを行うには 2 つの方法があります。

  • [Data > Get Data > From Other Sources (その他のソースからデータ> を取得する) を選択します

  • [データの取得>データの取得] を> Power Query エディター を起動します

この時点で、Power Query M の数式言語が十分にわかっている場合は、手動で手順と 数式を追加できます。

または、[ホーム] を選択 し、[新しいクエリ] グループで コマンドを選択 します。 次のいずれかの操作を行います。

  • [新 しいソース] を 選択してデータ ソースを追加します。 このコマンドは、リボンの[>データの取得] Excel似たコマンドです。

  • [ 最近使用したソース] を選択して、使用しているデータ ソースから選択します。 このコマンドは、リボンの[>ソース] コマンドとExcel似たコマンドです。

  • [データ の入力] を選択 して、データを手動で入力します。 このコマンドを選択すると、外部データ ソースとは別に Power Query エディターを試用できます。

クエリが有効であり、エラーがない場合は、ワークシートまたはデータ モデルに読み込み戻します。

Power Query エディターからクエリを読み込む

Power Query エディターで、次のいずれかの操作を行います。

  • ワークシートに読み込むには、[ホーム]>閉じる] &を>を&します

  • データ モデルに読み込むには、[ホーム]> [閉&ロード>を&] を選択します

    [データのインポート] ダイアログボックスで、[このデータをデータ モデルに追加する] を選択します

ヒント   [読み 込み] コマンド が淡色表示または無効になっている場合があります。 これは、ブックでクエリを初めて作成する場合に発生する可能性があります。 この場合は、新しいワークシートで [& Loadを閉じる] を選択し、[データ>クエリ &接続> クエリ] タブを選択し、クエリを右クリックし、[読み込み] を選択します。 または、Power Query エディターのリボンで、[ クエリ] を選択> 読み込み] を選択します。

[クエリと接続] ウィンドウからクエリを読み込む 

このExcel、別のワークシートまたはデータ モデルにクエリを読み込む必要があります。

  1. [Excelで、[クエリと接続>データ&]を選択し、[クエリ] タブを選択します。

  2. クエリの一覧でクエリを探し、クエリを右クリックして、[読み込み先] を選択します。 [データのインポート] ダイアログ ボックスが表示されます。

  3. データのインポート方法を決定し、[OK] を選択します。 このダイアログ ボックスの使用の詳細については、疑問符 (?) を選択します。

ワークシートに読み込まれたクエリを編集するには、いくつかの方法があります。

ワークシート内のデータからクエリをExcelする

  • クエリを編集するには、Power Query エディターから以前に読み込まれたクエリを探し、データ内のセルを選択し、[クエリ] を選択>します

[クエリと接続] ウィンドウから&編集する

1 つのブックに多数のクエリ 含&、すばやく検索したい場合は、[クエリと接続] ウィンドウの方が使いやすい場合があります。

  1. [Excelで、[クエリと接続>データ&]を選択し、[クエリ] タブを選択します。

  2. クエリの一覧でクエリを探し、クエリを右クリックして、[編集] を 選択します

[クエリのプロパティ] ダイアログ ボックスからクエリを編集する

  • Excelで、[データ>データ & 接続> クエリ] タブを選択し、クエリを右クリックして [プロパティ] を選択し、[プロパティ]ダイアログ ボックスの [定義] タブを選択し、[クエリの編集] を選択します。

ヒント    クエリを含むワークシート内にある場合は、[Data >Properties]を選択し、[プロパティ]ダイアログ ボックスの [定義] タブを選択し、[クエリの編集] を選択します。 

データ モデルには、通常、リレーションシップに配置された複数のテーブルが含まれます。 クエリをデータ モデルに読み込むには、[読み込み]コマンドを使用して [データのインポート] ダイアログ ボックスを表示し、[このデータをデータ モード l に追加する]チェックボックスをオンにします。 データ モデルの詳細については、「ブック のデータ モデルで使用されているデータ ソースを確認する」、Excelでデータ モデルを作成する、および「複数のテーブルを使用してピボットテーブルを作成する」を参照してください。

  1. データ モデルを開く場合は 、[Power Pivot] を選択し、[管理>選択します

  2. Power Pivot ウィンドウの下部で、目的のテーブルのワークシート タブを選択します。

    正しいテーブルが表示されていることを確認します。 データ モデルには、多数のテーブルを含めできます。

  3. テーブルの名前をメモします。

  4. Power Pivot ウィンドウを閉じるには、[ファイル] を選択>閉じます。 メモリの再利用には数秒かかる場合があります。

  5. [クエリ]> [& プロパティ>] を選択し、クエリを右クリックし、[編集] を選択します

  6. Power Query エディターで変更を行い終わったら、[ファイル] を選択 し、[読 み込> 閉&します

結果

ワークシート内のクエリとデータ モデル内のテーブルが更新されます。

クエリをデータ モデルに読み込むのに、ワークシートへの読み込みよりもはるかに長い時間がかかる場合は、Power Query の手順を確認して 、Contains 演算子を使用してテキスト列またはリスト構造化列をフィルター処理しているのか確認してください。 このアクションにより、Excelのデータ セット全体を再度列挙します。 さらに、Excelマルチスレッド実行を効果的に使用することはできません。 回避策として、Equals や Begins With などの別の演算子 を使用してみてください

Microsoft は、この問題を認識し、調査中です。

Power Query を読み込むには、次の方法があります。

  • ワークシートに。 Power Query エディターで、[ホーム] を選択し、[>閉じる&ロード>を&します

  • データ モデルに。 Power Query エディターで、[ホーム] を選択 し、[> 閉じる& >を閉& を選択 します

    既定では、Power Query は 1 つのクエリを読み込むときに新しいワークシートにクエリを読み込み、同時に複数のクエリをデータ モデルに読み込む。  すべてのブックまたは現在のブックの既定の動作を変更できます。 これらのオプションを設定しても、Power Query では、ワークシートやデータ モデルのデータと注釈のクエリ結果は変更されません。

    [ファイルの読み込み] を選択した後に表示される [インポート] ダイアログ ボックスを使用して、クエリの既定&オーバーライドすることもできます。 

すべてのブックに適用されるグローバル設定

  1. Power Query エディターで、[クエリ オプション] の [ ファイル > オプション と設定> 選択します

  2. [クエリオプション] ダイアログボックスの左側にある[GLOBAL]セクションで、[データ   の読み込み]を選択します

  3. [既定のクエリの読み込み設定]セクションで、次の操作を行います。

    • [標準の負荷設定を使用する] を選択します。 

    • [既定の読み込み設定を指定する] を選択し、[ワークシートに読み込む] または [データ モデルに読み込む   ] をオンまたはオフにします

ヒント    ダイアログ ボックスの下部にある [既定値に戻す] を選択すると、既定の設定に簡単に戻る可能性があります。

現在のブックにのみ適用されるブックの設定

  1. [クエリオプション] ダイアログボックスの左側にある [現在のブック] セクションで、[データの読み込み]を選択します

  2. 次の操作のいずれか、または複数の操作を行います。

    • [ 型の検出]で、非構造化ソースの列の種類と ヘッダーの検出を選択またはオフにします

      既定の動作では、それらを検出します。 データを自分で整形する場合は、このオプションをオフにします。

    • [ リレーションシップ] で、初めてデータ モデルに追加するときにテーブル間のリレーションシップを作成する] を オンまたはオフします

      データ モデルに読み込む前の既定の動作では、リレーショナル データベースの外部キーなど、テーブル間の既存のリレーションシップを検索し、データと一緒にインポートします。 自分で行う場合は、このオプションをオフにします。

    • [ リレーションシップ] で、[データ モデルに読み込まれたクエリを更新するときにリレーションシップを更新 する] をオンまたはオフします

      既定の動作では、リレーションシップは更新されません。 データ モデルに既に読み込まれているクエリを更新すると、Power Query はリレーショナル データベース内の外部キーなどのテーブル間の既存のリレーションシップを検索して更新します。 これにより、データのインポート後に手動で作成されたリレーションシップが削除される場合や、新しいリレーションシップが導入される場合があります。 ただし、これを行う場合は、オプションを選択します。

    • [ 背景データ] で、[バックグラウンドでダウンロード するデータのプレビューを許可する] をオンまたはオフします

      既定の動作では、バックグラウンドでデータ プレビューをダウンロードします。 すべてのデータを今すぐ表示する場合は、このオプションをオフにします。

関連項目

Power Query for Excel のヘルプ

クエリを管理する Excel

web Excelには、Power Query (Get & Transform とも呼ばれる) テクノロジが組み込まれており、インポートされたデータ ソースを操作するときにより優れた機能を提供します。 [クエリ] 作業ウィンドウで、クエリと関連する詳細を表示できます。

注: Web と Power Query の統合に関するExcelの詳細については、ご確認ください。

[クエリ] 作業ウィンドウを表示する 

  1. [編集] ビューが表示 されている必要があります ([編集中に表示 ]> 選択します)。

  2. [Data > クエリ] を選択します

結果

Excel[クエリ] 作業ウィンドウと、現在のブック内のすべてのクエリが、行数、最後の更新日、場所、読み込み状態などのクエリの詳細と共に表示されます。 クエリがグリッドではなくデータ モデルに読み込まれる場合、Excelのみ" と表示されます。

クエリと [クエリ] 作業ウィンドウの表示

関連項目

Power Query for Excel のヘルプ

ヘルプを表示

スキルを磨く
トレーニングの探索
新機能を最初に入手
Microsoft Insider に参加する

この情報は役に立ちましたか?

翻訳品質にどの程度満足していますか?
どのような要因がお客様の操作性に影響しましたか?

フィードバックをお送りいただきありがとうございます!

×