マイクロソフトでは、Microsoft SQL Server 2012 の修正を 1 つのダウンロード可能なファイルとして配布しています。 修正は累積的であるため、新しいリリースの修正には、以前のリリースの SQL Server 2012 の修正に含まれていたすべての修正プログラムとセキュリティ更新プログラムが含まれています。
現象
たとえば次のようなシナリオを考えてみます。
- SQL Server 2012 マスター データ サービスには、再帰リレーションシップの下に 1 つ以上の非再帰レベルがある、再帰派生階層があります。
- 再帰派生階層に対してサブスクリプション ビューを作成します。
このシナリオでは、ビューの作成動作は失敗します。 さらに、以下のエラー メッセージが表示されます。
注
サブスクリプション ビューの保存中にエラーが発生しました
解決策
累積的な更新プログラムの情報
SQL Server 2012
この問題の修正プログラムは、SQL Server 2012 Service Pack RTM の累積的な更新プログラム 2 で最初にリリースされました。 この累積的な更新プログラム パッケージの関連情報を参照するには、以下の「サポート技術情報」 (Microsoft サポート技術情報) をクリックしてください。
2703275 SQL Server 2012 用の累積的な更新プログラム パッケージ 2 (注: ビルドは累積的であるため、新しくリリースされた各修正プログラムには、以前の SQL Server 2012 更新プログラムのリリースに含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれています。 この修正プログラムが含まれている最新リリースの修正の適用を検討することを推奨します。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。
2692828 SQL Server 2012 のリリース以降にリリースされた SQL Server 2012 ビルドには、特定の SQL Server Service Pack 用に Microsoft SQL Server 2012 修正プログラムが作成されます。 SQL Server 2012 Service Pack RTM のインストールには、SQL Server 2012 Service Pack RTM 修正プログラムを適用する必要があります。 既定では、1 つの SQL Server Service Pack で提供されているすべての修正プログラムは、次の SQL Server Service Pack に含まれています。
注: この問題の修正プログラムは、SQL Server 2012 Service Pack 1 に含まれています。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
追加情報
再帰階層 (マスター データ サービス) の詳細については、以下のマイクロソフト Web サイトを参照してください。