KB2767183 - 修正: コマンド ラインを使用して、SQL Server の同じインスタンスに追加のデータベースに SQL Server 2012 リモート Blob ストアをインストールしようとすると、インストールが失敗する

適用先
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web

マイクロソフトでは、Microsoft SQL Server 2012 の修正を 1 つのダウンロード可能なファイルとして配布しています。 修正は累積的であるため、新しいリリースの修正には、以前のリリースの SQL Server 2012 の修正に含まれていたすべての修正プログラムとセキュリティ更新プログラムが含まれています。

現象

コマンド ラインを使用して、SQL Server の同じインスタンスに追加のデータベース用の Microsoft SQL Server 2012 リモート Blob ストアをインストールすることを想定しています。 たとえば、コマンド ラインで次のコマンドを実行します。

msiexec /qn /lvx* rbs_install_log_2.txt /i rbs.msi REMOTEBLOBENABLE=1 FILESTREAMPROVIDERENABLE=1 DBNAME="Database Name" FILESTREAMSTORENAME=FilestreamProvider_1 ADDLOCAL=EnableRBS,FilestreamRunScript DBINSTANCE="Domain\ServerName"

このシナリオでは、このインストールは失敗します。 また、次のようなエラー メッセージが表示されます。

注

RBS エラー。 元のエラー: 番号 2601、重大度 14、状態 1、プロシージャ rbs_sp_add_blob_store、行 64、

メッセージ: 一意のインデックス 'rbs_internal_blob_stores_ix_name' を持つオブジェクト 'mssqlrbs_resources.rbs_internal_blob_stores' に重複するキー行を挿入できません。 重複するキー値は (FilestreamProvider_1) です。EXECUTE 後のトランザクション数は、BEGIN ステートメントと COMMIT ステートメントの数が一致していないことを示します。 以前のカウント = 1、現在のカウント = 0。

原因

この問題は、2 回目のインストールで最初のインストールから派生した変数に正しくない値が使用されているために発生します。

これらの変数には、FILESTREAM データベース名とインスタンス名が格納されます。 2 回目のインストール時に、これらの変数の値がレジストリから取得され、コマンド ラインで定義した値が上書きされます。

解決策

累積的な更新プログラムの情報

SQL Server 2012 SP1 の累積的な更新プログラム 2

この問題の修正プログラムは、累積的な更新プログラム 2 で最初にリリースされました。 SQL Server 2012 SP1 用のこの累積的な更新プログラム パッケージを入手する方法の詳細については、以下のサポート技術情報番号をクリックしてください。

2790947 SQL Server 2012 Service Pack 1 の累積的な更新プログラム パッケージ 2 注: ビルドは累積的であるため、新しくリリースされた修正プログラムには、以前の SQL Server 2012 SP1 更新プログラムのリリースに含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれています。 この修正プログラムが含まれている最新リリースの修正の適用を検討することを推奨します。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。

2772858 SQL Server 2012 Service Pack 1 以降にリリースされた SQL Server 2012 のビルド

SQL Server 2012 の累積的な更新プログラム 5

この問題の修正プログラムは、累積的な更新プログラム 5 で最初にリリースされました。 SQL Server 2012 用のこの累積的な更新プログラム パッケージを入手する方法の詳細については、以下のサポート技術情報番号をクリックしてください。

2777772 SQL Server 2012 用の累積的な更新プログラム パッケージ 5 (注: ビルドは累積的であるため、新しくリリースされた各修正プログラムには、以前の SQL Server 2012 更新プログラムのリリースに含まれていたすべての修正プログラムおよびセキュリティ更新プログラムが含まれています)。 この修正プログラムが含まれている最新リリースの修正の適用を検討することを推奨します。 詳細については、次のマイクロソフト サポート技術情報番号をクリックしてください。

2692828 SQL Server 2012 以降にリリースされた SQL Server 2012 ビルド

回避策

この問題を回避するには、コマンド ラインではなく UI モードを使用してリモート BLOB ストアをインストールします。

状態

Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。