KB4530496 - 修正: 2019 SQL Server でマスター上のデータベースを削除できなかった場合、データ プール データベースが削除される場合がある

適用先
SQL Server 2019 on Linux SQL Server 2019 on Windows

現象

SQL Server 2019 のマスター ノードで DROP DATABASE を実行したが、操作が失敗したとします。 マスター ノードでの障害が原因でマスターで "データベースのドロップ" 操作が失敗した場合 (たとえば、データベースがマスター インスタンス上の既存のセッションによって使用されている場合)、データ プール ノード上の対応するバックエンド データベースが削除される可能性があります。 外部の理由 (データベースがコントローラー ノードに接続できないなど) により Master で "データベースの削除" 操作が失敗した場合、データ プール ノード上の対応するバックエンド データベースは削除されない可能性があります。

状態

Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。

解決策

この問題は、SQL Server 用の次の累積的な更新プログラムで解決されています。

SQL Server の累積的な更新プログラムについて:
      

SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。

参考資料

マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。