現象
Microsoft SQL Server 2016、2017、または 2019 の 1 つ以上のテーブルで動的データ マスキングが有効になっているとします。 まれに、エラー メッセージの処理中にロック競合が発生し、SQL Server が予期せず終了することがあります。 さらに、次のようなエラー エントリがエラー ログに記録されることがあります。
DateTime SpidId Stack Overflow Dump not possible - ExceptionExceptionId EXCEPTION_STACK_OVERFLOW at ExceptionAddress
DateTime SpidId ex_terminator: スタックの展開中に例外が原因で終了する可能性があります。
状態
Microsoft は、これが "適用対象" セクションに記載されている Microsoft 製品の問題であることを確認しました。
解決策
この問題は、次の SQL Server の累積的な更新プログラムで修正されています。
SQL Server の累積的な更新プログラムについて:
SQL Server 用の新しい累積的な更新プログラムには、以前の累積的な更新プログラムに含まれていたすべての修正プログラムとすべてのセキュリティ修正プログラムが含まれています。 SQL Server の最新の累積的な更新プログラムを確認してください。
回避策
この問題を回避するには、テーブルからすべてのデータ マスクを削除します。
参考資料
マイクロソフトでソフトウェア更新プログラムの説明に使用する用語集を参照してください。