Visio の図形間にコネクタを追加する

適用先
Visio Plan 1 Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2016 Visio Standard 2016

Visio を使うと、図面の図形を簡単に接続できます。

オートコネクトを使って、図形を追加するときに接続したり、コネクタ ツールを使って既存の図形を接続したりすることができます。 ミニ ツール バーに表示される図形を変更したり、オートコネクトを有効または無効にしたりすることもできます。

図形を自動的に接続する

ページ上の既存の図形を接続する

別のページの図形に接続する

テーマを使用してコネクタの外観を変更する

代替コネクタ図形を使用する

オートコネクト ミニ ツール バーの図形を変更する

オートコネクトを有効または無効にする

図形を自動的に接続する

図形を接続する 1 つの方法として、図形をページに追加するときに、Visio で自動的に接続することができます。 これは、フローチャートを作成するときに特に便利です。

  1. オートコネクトがアクティブになっていることを確認します。 [表示] タブの [視覚補助] グループで、[オートコネクト] が選択されていることを確認します。

  2. [図形] ウィンドウからページに図形をドラッグします。

  3. 図形をポイントして、図形の周囲にオートコネクト矢印が表示されるまでそのままにします。

    オートコネクトがアクティブであることを示すスクリーンショット。図形にカーソルを合わせると、接続矢印が表示されます。

  4. 図形を追加する方向の矢印をポイントします。

    [オートコネクト] 矢印の上にマウス ポインターを置くと、追加する図形のツール バーが表示されているスクリーンショット。

    現在、[クイック図形] ステンシルにある最初の 4 個のクイック図形を含むミニツール バーが表示されます。 ツールバーの図形をポイントすると、ページにその図形のプレビューが表示されます。

  5. 追加する図形を選択します。

  6. 続ける場合は、新しく追加した図形のオートコネクトの矢印をポイントし、別の図形を追加します。その図形は自動的に接続されます。

    新しく追加された図形の上にマウス ポインターを置くと、別の図形を追加するための [オートコネクト] 矢印が表示されているスクリーンショット。

ページの先頭へ

ページ上の既存の図形を接続する

ヒント

[ホーム] タブの [ツール] グループのコマンドを使用すると、Visio が異なる状態やモードになり、わかりにくい場合があります。 キーボードを使用すると、ポインター ツールのオブジェクトの選択 (Ctrl+1 キーを押す) ツールとコネクタ ボタンの画像 (Ctrl+3 キーを押す) ツールを簡単に切り替えることができます。 テキスト ブロックや接続ポイントなど、どのツールを使っていても、Esc キーを数回押すとオブジェクト選択ツールに戻ります。

  1. [ ホーム] タブの [ツール ] グループで [ コネクタ]ボタンの画像 を選択するか、 Ctrl + 3 キーを押します。
  2. 図形を選び、コネクタを別の図形にドラッグします。
  3. 完了したら、[ポインター ツール] を選択し、[ホーム] タブの [ツール] グループで [オブジェクト] を選択するか、Ctrl + 1 キーを押します。

アニメーションを表示する/非表示にする

コネクタ ツールが各端点にポイント接続がある図形に接続することを示すスクリーンショット。

または、[図形の接続] コマンドをリボンに追加し、このコマンドを使用して複数の図形を、選択した順に接続することができます。

接続図形のビデオを示すスクリーンショット

ヒント

リボンに表示されていない便利なコマンドは、[ファイル] >[オプション] > [リボンのユーザー設定] の順に選択することで追加できます。

ページの先頭へ

別のページの図形に接続する

コネクタは、同じページ上の図形の間でのみ使うことができます。 別のページ上の図形に接続するには、[外部ページ参照] 図形を使ってページ間にハイパーリンクを作成します。また、同じドキュメント内の別のページに移動できるように [ハイパーリンク] と [ダブルクリック] アクションを任意の図形に追加する方法もあります。

外部ページ参照を使用する

  1. [ 基本フローチャート用図形 ] ステンシルを開き、[ 外部ページ参照] 図形を現在のページにドラッグします。

    [外部ページ参照] 図形を示すスクリーンショット

  2. [ 外部ページ参照 ] ダイアログ ボックスで [ OK ] を選択して、現在のページと新しく作成したページに図形を追加します。

  3. 新しいページで、図の作成を続けます。

  4. [外部ページ参照] 図形の外観を変更するには、図形を右クリックし、[別のページへの参照]、[別のページからの参照]、[円]、または [矢印] を選びます。

ページ間を移動するには、いずれかのページの [外部ページ参照] 図形をダブルクリックします。 詳細については、「[外部ページ参照] ダイアログ ボックス」をご覧ください。

  1. 図形を右クリックして [ ハイパーリンク] を選択するか、図形を選択して Ctrl+K* キーを押します。

  2. [サブアドレス] フィールドの横にある [参照] を選択し、[ページ] の横のドロップダウン リストを選択して目的のページを選択します。

    [ハイパーリンク] ダイアログ ボックスのスクリーンショット

    注

    ハイパーリンクに対して、移動先ページにある図形の名前を指定することもできます。 [ 開発] タブを選択し、[ 図形名] を選択するか、[ 名前 ] フィールドで既定の名前を使用するか、編集して [OK] を選択します。

    ユーザーは、 図形の名前 と 動作の指示に従う前に [開発] タブを有効にする必要がある場合があります。

  3. 図形のダブルクリック アクションを設定するには、[ 開発] タブを選択し、[ 動作] を選択します。

  4. [ ダブルクリック] タブを選択し、[ ページに移動 ] オプションを選択してから、ドロップダウン リストを選択して目的のページを選択します。

    Visio Double-Click アクションを示すスクリーンショット

    注

    ページ名はここで自動的に更新されないため、ページ名を編集した後にのみ行ってください。

ページの先頭へ

テーマを使用してコネクタの外観を変更する

コネクタの既定の外観は単純な線ですが、矢印など、装飾を追加するテーマと共に動作するように設計されている場合があります。 組み込みテーマは、[デザイン] タブの [テーマ] ギャラリーから適用できます。スタイル、色、太さなどのコネクタの属性を変更するには、「コネクタ形状の編集」を参照してください。

アニメーションを表示する/非表示にする

非表示のアニメーションを示すスクリーンショット

注

他の装飾を表示するには、[ デザイン ] タブを選択します。[ バリエーション] グループで、ドロップダウン矢印を選択し、[ コネクタ] を選択します。 非表示のアニメーションを示すスクリーンショット - 1

代替コネクタ図形を使用する

その他の図形>Visio Extras>Connectors ステンシルで使用可能なものなど、任意のコネクタ図形を使用して、既定の動的コネクタ図形を使用するのではなく、図形を接続することができます。 これらのコネクタ図形は、ページにドラッグ アンド ドロップすることも、[コネクタ] ツールおよび [図形の接続] ツールで使用するために選択することも、既存のコネクタを置換するためにだけ使用することもできます。

  1. 代替コネクタ図形を含むステンシルを開く
  2. ページ上で置換する既存のコネクタを選択します。
  3. [編集] グループの [ホーム] タブで、[図形の変更] を選択し、目的のコネクタ図形を選択します。

アニメーションを表示する/非表示にする

図形の変更の非表示のアニメーションを示すスクリーンショット

注

[図形の変更] 機能は Visio 2013 で導入されましたが、[コネクタ] ツールと [図形の接続] ツールは Visio 2007 で導入されています。

ページの先頭へ

オートコネクト ミニ ツール バーの図形を変更する

ミニ ツール バーの図形は、図の [クイック図形] ステンシルのものです。 ミニ ツール バーには、最大で 4 つの図形が表示されます。 ミニ ツール バーに表示される図形をカスタマイズすることができます。 次の手順では、例として [基本図] を使います。

  1. 既定では、ミニ ツール バーに表示される図形は、[クイック図形] ステンシルの直後にあるステンシルの最初の 4 つの図形です。 たとえば、[基本図] ステンシルではこれらが最初の 4 つの図形です。

    既定の基本図形を使用したミニ ツール バーを示すスクリーンショット

  2. 特定のステンシルのミニ ツール バーに別の図形を表示するには、図形をステンシルの先頭にドラッグして順序を変更できます。 たとえば、[星 4]、[星 5]、[星 6]、[星 7] の各図形を、[基本図] ステンシルの先頭にドラッグできます。

    新しい基本的な図形を含むミニ ツール バーを示すスクリーンショット

  3. また、[図形] ウィンドウの上または下にドラッグして、ステンシルの順序を変更することもできます。 これらの図形のサブセットが、[図形] ウィンドウと同じ順序で [クイック図形] ステンシルに表示されます。 たとえば、[装飾図形] ステンシルを [図形] ウィンドウの [クイック図形] ステンシルの直後にドラッグすると、[クイック図形] ステンシルの順序が変わります。

    並べ替えて別のステンシルを使うミニ ツール バーを示すスクリーンショット

    注

    図をいったん閉じて再び開くと、[図形] ウィンドウ内のステンシルの既定の順序が自動的に復元され、[クイック図形] に反映されます。

  4. ミニ ツール バーの基として別のステンシルを使うには、[クイック図形] ステンシルで、ステンシルの図形のサブセットの図形を選びます。 たとえば、[グラフと数学の図形] ステンシルで [ベン図] を選びます。

    選んで新しいステンシルを使うミニ ツール バーを示すスクリーンショット

ヒント

ステンシル内の図形の既定の順序に戻すには、[図形] ウィンドウでステンシル名を右クリックし、[ステンシルのリセット] を選択します。

注

ミニ ツール バーで使うことができる図形が含まれないステンシルもあります。 たとえば、[矢印図形] ステンシルの図形は、ミニ ツール バーに表示されません。

ページの先頭へ

オートコネクトを有効または無効にする

オートコネクトは、ファイル レベルのオプションです。 オプションをオンにすると、現在のファイルでは変わりません。ただし、別のファイルで作業を行う場合は、もう一度有効にする必要があります。 特定のテンプレートの場合、そのオプションは既定で有効になっています。 

アクティブな図でオートコネクトを有効または無効にする

  • [表示] タブの [視覚補助] グループで [オートコネクト] をオンまたはオフにします。

    [表示] タブでオートコネクトを選択またはオフにして、オートコネクトをアクティブまたは非アクティブにする方法を示すスクリーンショット。

[オートコネクト] オプションが淡色表示になっている場合は、[ファイル>オプション]>[詳細設定] に移動し、[オートコネクトを有効にする] を選択すると修正できます。

オートコネクトをアクティブまたは非アクティブにする

  1. [ファイル] タブ、[オプション] の順に選択します。

  2. [Visio のオプション] で、[詳細設定] を選択します。

  3. [編集オプション] で、[オートコネクトを有効にする] をオンにし、オートコネクトを有効にします。 オートコネクトを無効にするには、このチェックボックスをオフにします。

    [オートコネクトを有効にする] をオンまたはオフにして、すべての図面 & 図面のオートコネクトをアクティブまたは非アクティブにする方法を示すスクリーンショット。

  4. [OK] をクリックします。

ページの先頭へ

関連項目

コネクタの線、矢印、ポイントを編集する

コネクタのテキストを追加および編集する

カスタム コネクタを作成する

コネクタを接着または接着解除する

Visio デスクトップ コネクタ について知っておく必要があること

Visio のトレーニング