UML アクティビティ図を作成する

適用先
Visio Plan 1 Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2019 Visio Standard 2019 Visio Professional 2016 Visio Standard 2016 Visio Professional 2013

Visio の UML アクティビティ図は、フロー チャートのように表示されます。 制御のフローは、システム内のアクション (または アクティビティ) の完了によってトリガーされます。 フローは、シーケンシャル、同時、または分岐であり、スイムレーン、フォーク、結合などの図形で示されます。

アクティビティ図を使用して、サービスまたはその他の最終結果を提供するために、いくつかのアクティビティがどのように調整されるかを説明します。 アクティビティ図では、ユースケース内のイベントが相互にどのように関連しているか、またはユースケースのコレクションがビジネスワークフローを表すためにどのように調整されるかを示すことができます。

大学での学生入学の制御フローを示す UML アクティビティ図のサンプル。

代わりに 外部 イベントに応答してフローを表す場合は、 ステート マシン図を使用します。

アクティビティ図を開始する

  1. Visio を起動します。 または、既にファイルを開いている場合は、[ ファイル>新規作成] をクリックします。
  2. [検索] ボックスに「 UML activity」と入力します。
  3. UML アクティビティ図を選択します。
  4. ダイアログ ボックスで、[ メートル法] または [米国単位] を選択します。
  5. [作成] を選択します。
  6. ダイアグラムが開きます。 図の横に [図形] ウィンドウが表示されるはずです。 表示されない場合は、[表示] >[作業ウィンドウ] に移動し、[図形] が選択されていることを確認します。 それでも表示されない場合は、左側の [図形の展開] ウィンドウ ボタンをクリックします。
  7. [表示] タブで、[接続ポイント] の横のチェック ボックスがオンになっていることを確認します。 このオプションをオンにすると、図形の接続を開始するときに接続ポイントが表示されます。
  8. スイムレーンを挿入し、図にアクティビティ制御フローを構築できるようになりました。

図面を設計する

  • アクティビティ図に職務を示す場合は、[レーン] 図形を、表示したい各クラス、人、または組織単位のページにドラッグします。 そのためには、次の手順を実行します。

    1. 図面ページに [レーン] 図形をドラッグします。
      スイムレーンの形状。
    2. 図形の各ラベルをダブルクリックして、既定の名前を変更します。
    3. 必要なすべてのパーティションまたは組織単位を追加するまで、手順 a と b を繰り返します。
    4. スイムレーン図形のサイド選択ハンドルをドラッグして、レーンをお好みのサイズにします。
  • 初期ノード図形と最終ノード図形を使用して、初期状態と最終の擬似状態を表します。
    初期ノード。 最終ノード。

  • 表現する各アクションまたはアクティビティの状態に [アクション] 図形を追加します。
    アクション図形。

  • ガード条件付きの 決定 図形を使用して、アクションの状態から遷移の可能性を示します。
    決定図形。

  • [Fork (フォーク)] ノードを使用して、1 つのアクション状態を複数の並列状態に分岐させることを表します。
    フォーク ノード。

  • Join ノードを使用して、複数のアクション状態を 1 つの状態に同期することを表します。
    ノードを結合します。

関連項目

Visio での UML 図 

UML ステート マシン図を作成する

UML ユース ケース図を作成する