증상
Microsoft SQL Server 2012 또는 SQL Server 2014에서는 Backup-SqlDatabase cmdlet을 사용하여 대용량 데이터베이스를 백업하거나 Restore-SqlDatabase cmdlet을 사용하여 대용량 데이터베이스를 복원하려고 합니다. 이 경우 10분 후에 시간 초과 오류가 발생합니다. 또한 Windows PowerShell에서 다음과 같은 오류 메시지가 나타납니다.
참고
제한 시간이 초과되었습니다. 작업이 완료되기 전에 경과했거나 서버가 응답하지 않는 시간 제한 기간입니다.
원인
이 문제는 Backup-SqlDatabase 및 Restore-SqlDatabase cmdlet이 기본 시간 제한 값으로 600초를 사용하기 때문에 발생합니다.
해결 방법
이 문제는 다음 SQL Server 누적 업데이트에서 처음 해결되었습니다.
2014년 SQL Server용 누적 업데이트 1 /en-us/help/2931693
SQL Server 2012 SP1용 누적 업데이트 8 /en-us/help/2917531
SQL Server의 누적 업데이트 정보
SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.