증상
Microsoft SQL Server 2014에 클러스터형 columnstore 인덱스가 있는 분할된 테이블이 있고 테이블에 일부 데이터가 있다고 가정합니다. 테이블에서 인덱싱된 보기를 만들려고 하면 다음 오류 메시지가 나타납니다.
참고
내부 쿼리 프로세서 오류: 쿼리 프로세서에서 필요한 인터페이스에 대한 액세스 권한을 얻을 수 없습니다.
인덱싱된 보기를 만든 후 클러스터형 columnstore 인덱스를 만드는 경우 문제가 발생하지 않습니다. 그러나 테이블에서 BCP(대량 복사)를 실행하려고 할 때 테이블에 char, nchar, varchar, nvarchar 또는 varbinary 데이터 형식이 포함된 경우 어설션이 실패합니다.
해결 방법
이 문제는 다음 SQL Server 누적 업데이트에서 처음 해결되었습니다.
SQL Server 2014용 누적 업데이트 3 /en-us/help/2984923
SQL Server의 누적 업데이트 정보
SQL Server에 대한 각각의 새로운 누적 업데이트에는 이전 누적 업데이트에 포함된 모든 핫픽스와 모든 보안 수정 사항이 포함되어 있습니다. SQL Server에 대한 최신 누적 업데이트를 확인하세요.
상태
Microsoft에서 이는 "적용 대상" 섹션에 나열된 Microsoft 제품에서의 문제임을 확인했습니다.