Slik retter du en #DIV/0! #BUSY!-feil

Microsoft Excel viser #DIV/0! -feilen når et tall er dividert med null (0). Det skjer når du skriver inn en enkel formel som =5/0,eller når en formel refererer til en celle som har 0 eller er tom, som vist på dette bildet.

Eksempler på formler som forårsaker #DIV/0! feil.

Gjør følgende for å rette feilen:

  • Kontroller at divisoren i funksjonen eller formelen ikke er null eller en tom celle.

  • Endre cellereferansen i formelen til en annen celle som ikke inneholder null (0) eller en tom verdi.

  • Angi #I/T i cellen som er referert til som divisor i formelen, noe som vil endre formelresultatet til #I/T, for å indikere at divisorverdien ikke er tilgjengelig.

Mange ganger er #DIV/0! -feilen ikke kan unngås fordi formlene venter på inndata fra deg eller noen andre. I så fall vil du ikke at feilmeldingen skal vises i det hele tatt, så det finnes noen metoder for feilbehandling som du kan bruke til å undertrykke feilen mens du venter på inndata.

Evaluere nevneren for 0 eller ingen verdi

Den enkleste måten å undertrykke #DIV/0! -feilen er å bruke HVIS-funksjonen til å evaluere om nevneren finnes. Hvis verdien er 0 eller ingen, viser den 0 eller ingen verdi som formelresultat i stedet for #DIV/0! ellers beregner du formelen.

Hvis for eksempel formelen som returnerer feilen er =A2/A3, bruk =HVIS(A3,A2/A3,0) til å returnere 0 eller =IF(A3,A2/A3,"") for å returnere en tom streng. Du kan også vise en egendefinert feilmelding som dette: =HVIS(A3,A2/A3,"Inndata nødvendig"). Med KVOTIENT-funksjonen fra det første eksemplet vil du bruke =HVIS(A3,KVOTIENT(A2,A3),0). Dette forteller Excel at HVIS(A3 finnes, returner da resultatet av formelen, ellers ignorer det).

Eksempler på hvordan du løser #DIV/0! feil.

Bruk HVISF TIL å undertrykke #DIV/0! #BUSY!-feil

Du kan også undertrykke denne feilen ved å neste divisjonsoperasjonen inni HVISFEIL-funksjonen. Ved bruk av A2/A3, kan du bruke =HVISFEIL(A2/A3,0). Dette forteller Excel at hvis formelen evaluerer til en feil, skal 0 returneres, ellers skal resultatet av formelen returneres.

For versjoner av Excel før Excel 2007, kan du bruke HVIS(ERFEIL())-metoden: =HVIS(ERFEIL(A2/A3),0,A2/A3) (Se ER-funksjoner).

Obs: Både HVISFEIL- og HVIS(ERFEIL())-metoder behandler feil uten diskriminering, i det de undertrykker alle feil, ikke bare #DIV/0!. Du må passe på at formelen fungerer korrekt før du bruker noen feilbehandling, ellers vil du kanskje ikke oppdage at formelen ikke fungerer slik du venter.

Tips!: Hvis feilkontroll er aktivert i Excel, kan du klikke Knapp ved siden av cellen der feilen vises. Klikk Vis trinnene i beregningen hvis det er tilgjengelig, og velg løsningen som fungerer for dataene.

Har du spørsmål om en bestemt funksjon?

Legg inn et spørsmål i Excel-fellesskapsforumet

Hjelp oss med å forbedre Excel

Har du forslag til hvordan vi kan forbedre neste versjon av Excel? Hvis det er tilfelle, kan du se emnene på Excel User Voice.

Se også

HVIS (funksjon)

HVISFEIL (funksjon)

ER-funksjoner

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Funksjoner i Excel

Excel-funksjoner (etter kategori)

Trenger du mer hjelp?

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×