SUMMERHVIS (funksjon)

Du bruker SUMMERHVIS-funksjonen til å summere verdiene i et område som oppfyller kriteriene du angir. Anta for eksempel at i en kolonne som inneholder tall, vil du bare summere verdiene som er større enn 5. Du kan bruke følgende formel: =SUMMERHVIS(B2:B25,">5")

Få stor innflytelse med Kunngjøringer

Denne videoen er en del av opplæringskurset kalt Legge sammen tall i Excel.

Tips!: 

  • Hvis du vil, kan du bruke vilkårene på ett område og summere de tilsvarende verdiene i et annet område. Formelen =SUMMERHVIS(B2:B5, "John", C2:C5) summerer for eksempel bare verdiene i området C2:C5 der de tilsvarende cellene i området B2:B5 er lik "John".

  • Hvis du vil summere celler basert på flere vilkår, kan du se SUMMER.HVIS.SETT-funksjonen.

Viktig!: SUMMERHVIS-funksjonen returnerer uriktige resultater når du bruker den til å sammenligne strenger som er lengre enn 255 tegn, eller til strengen #VALUE!.

Syntaks

SUMMERHVIS(område; vilkår; [summeringsområde])

SUMMERHVIS-funksjonens syntaks har følgende argumenter:

  • område   Obligatorisk. Området av celler du vil evaluere med vilkår. Celler i hvert område må være tall eller navn, matriser eller referanser som inneholder tall. Tomme celler og tekstverdier ignoreres. Det valgte området kan inneholder datoer i standard Excel-format (eksempler nedenfor).

  • kriterier   Obligatorisk. Vilkårene i form av et tall, et uttrykk, en cellereferanse, tekst eller en funksjon som definerer hvilke celler som skal legges til. Joker tegn kan inkluderes – et spørsmåls tegn (?) for å sammenligne ett enkelt tegn, en stjerne (*) for å finne alle tegn sekvensene. Hvis du vil finne et spørsmålstegn eller en stjerne, skriver du en tilde (~) foran tegnet.

    Vilkår kan for eksempel uttrykkes som 32, ">32", B5, "3?", "Apple *", "* ~?" eller i dag ().

    Viktig!: Eventuelle tekstvilkår eller andre vilkår som omfatter logiske eller matematiske symboler, må stå i doble anførselstegn ("). Hvis vilkårene er numeriske, er ikke doble anførselstegn obligatorisk.

  • summeringsområde   Valgfritt. De faktiske cellene som skal legges til, hvis du vil legge til andre celler enn dem som er angitt i argumentet område. Hvis argumentet summeringsområde utelates, legger Excel til cellene som ble angitt i argumentet område (de samme cellene som vilkårene brukes på).

    Sum_range skal ha samme størrelse og form som område. Hvis det ikke er det, kan ytelsen bli redusert, og formelen vil summere et celle område som begynner med den første cellen i sum_range , men som har samme mål som område. Eksempel:

    område

    summeringsområde

    Faktiske summerte celler

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Eksempler

Eksempel 1

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Hvis du vil, kan du justere kolonnebreddene slik at du kan se alle dataene.

Salgsverdi

Provisjon

Data

kr 100 000

kr 7 000

kr 250 000

kr 200 000

kr 14 000

kr 300 000

kr 21 000

kr 400 000

kr 28 000

Formel

Beskrivelse

Resultat

=SUMMERHVIS(A2:A5;">160000";B2:B5)

Summen av provisjon for eiendomsverdier over kr 160 000.

kr 63 000

=SUMMERHVIS(A2:A5,">160 000")

Summen av eiendomsverdier over kr 160 000.

kr 900 000

=SUMMERHVIS(A2:A5;300000;B2:B5)

Summen av provisjon for eiendomsverdier over lik kr 300 000.

kr 21 000

=SUMMERHVIS(A2:A5;">" & C2;B2:B3)

Summen av provisjon for eiendomsverdier som er høyere enn verdien i C2.

kr 49 000

Eksempel 2

Kopier eksempeldataene i tabellen nedenfor, og lim dem inn i celle A1 i et nytt Excel-regneark. Hvis du vil at formlene skal vises resultater, merker du dem, trykker F2 og deretter ENTER. Du kan eventuelt justere kolonnebredden for å se alle dataene

Kategori

Matvarer

Salg

Grønnsaker

Tomater

kr 2 300

Grønnsaker

Selleri

kr 5 500

Frukt

Appelsiner

kr 800

Smør

kr 400

Grønnsaker

Gulrøtter

kr 4 200

Frukt

Epler

kr 1 200

Formel

Beskrivelse

Resultat

=SUMMERHVIS(A2:A7,"Frukt",C2:C7)

Summen av salg av alle matvarer på fanen Frukt.

kr 2 000

=SUMMERHVIS(A2:A7,"Grønnsaker",C2:C7)

Summen av salg av alle matvarer på fanen Grønnsaker.

kr 12 000

=SUMMERHVIS(B2:B7,"*er",C2:C7)

Summen av salg av alle matvarer som slutter på "er" (Tomater, Appelsiner og Epler).

kr 4 300

=SUMMERHVIS(A2:A7,"",C2:C7)

Summen av salg av alle matvarer som ikke har en angitt kategori.

kr 400

Til toppen av siden

Trenger du mer hjelp?

Du kan alltid spørre en ekspert i Excel tekniske fellesskap, få støtte i Svar-fellesskapet eller foreslå en ny funksjon eller forbedring på Excel User Voice.

Se også

SUMMER.HVIS.SETT-funksjonen legger sammen alle argumentene som oppfyller flere vilkår

SUMMERKVADRAT-funksjonen summerer flere verdier etter at den utfører en matematisk kvadrathandling på hver av dem

ANTALL.HVIS-funksjonen teller bare verdiene som oppfyller ett enkelt vilkår

ANTALL.HVIS.SETT -funksjonen teller bare verdiene som oppfyller flere vilkår

HVIS.SETT-funksjon (Office 365, Excel 2016 og senere)

Oversikt over formler i Excel

Unngå formler med feil

Oppdage feil i formler

Matematikk- og trigonometri-funksjoner

Funksjoner i Excel (alfabetisk)

Excel-funksjoner (etter kategori)

Obs!:  Denne siden er oversatt gjennom automatisering og kan inneholde grammatiske feil eller unøyaktigheter. Formålet vårt er at innholdet skal være nyttig for deg. Kan du fortelle oss om informasjonen var nyttig? Her er den engelske artikkelen for referanse.

Bli bedre på Office
Utforsk opplæring
Vær først ute med de nye funksjonene
Bli med i Office Insiders

Var denne informasjonen nyttig?

Takk for tilbakemeldingen!

Takk for tilbakemeldingen! Det høres ut som det kan være lurt å sette deg i kontakt med én av våre Office-kundestøtteagenter.

×