KB2345451 - Cumulatief updatepakket 4 voor SQL Server 2008 R2

Van toepassing op
SQL Server 2008 R2 Datacenter SQL Server 2008 R2 Developer SQL Server 2008 R2 Enterprise SQL Server 2008 R2 Express SQL Server 2008 R2 Express with Advanced Services SQL Server 2008 R2 Standard SQL Server 2008 R2 Standard Edition for Small Business SQL Server 2008 R2 Web SQL Server 2008 R2 Workgroup

INLEIDING

Cumulatieve update 4 bevat hotfixes voor de problemen met Microsoft SQL Server 2008 R2 die zijn opgelost sinds de release van SQL Server 2008 R2.

Opmerking: deze build van dit cumulatieve updatepakket staat ook bekend als build 10.50.1746.0.

Het is raadzaam hotfixes te testen voordat u ze in een productieomgeving implementeert. Omdat de builds cumulatief zijn, bevat elke nieuwe fixrelease alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige SQL Server 2008 R2-fixrelease. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:

981356 De SQL Server 2008 R2-builds die zijn uitgebracht nadat SQL Server 2008 R2 zijn uitgebracht

Belangrijke opmerkingen over het cumulatieve updatepakket

  • De hotfixes in dit cumulatieve updatepakket zijn opgenomen in SQL Server 2008 R2 Service Pack 1 (SP1).
  • SQL Server 2008 R2-hotfixes zijn nu beschikbaar in meerdere talen. Daarom is er slechts één cumulatief hotfixpakket voor alle talen.
  • Eén cumulatief hotfixpakket omvat alle onderdeelpakketten. Met het cumulatieve updatepakket worden alleen de onderdelen bijgewerkt die op het systeem zijn geïnstalleerd.

Meer informatie

Cumulatieve update 4 voor SQL Server 2008 R2 verkrijgen

Een ondersteund cumulatief updatepakket is nu beschikbaar bij Microsoft. Het is echter alleen bedoeld om de problemen op te lossen die in dit artikel worden beschreven. Pas het alleen toe op systemen die deze specifieke problemen ondervinden. Dit cumulatieve updatepakket kan aanvullende tests ontvangen. Daarom raden we u aan te wachten op het volgende servicepack voor SQL Server 2008 R2 dat de hotfixes in dit cumulatieve updatepakket bevat als u niet ernstig last hebt van een van deze problemen.

Als de cumulatieve update kan worden gedownload, vindt u de sectie 'Hotfix-download beschikbaar' bovenaan dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, neem dan contact op met de klantenservice en ondersteuning van Microsoft om het cumulatieve updatepakket te verkrijgen.

Opmerking: als er nog meer problemen optreden of als er problemen nodig zijn, moet u mogelijk een afzonderlijke serviceaanvraag maken. De gebruikelijke ondersteuningskosten zijn van toepassing op aanvullende ondersteuningsvragen en problemen die niet in aanmerking komen voor dit specifieke cumulatieve updatepakket. Voor een volledige lijst met telefoonnummers van de klantenservice en ondersteuning van Microsoft of om een afzonderlijke serviceaanvraag te maken, gaat u naar de volgende Microsoft-website:

/contactus/?ws=support

Hotfixes voor SQL Server 2008 die zijn opgenomen in cumulatieve update 4 voor SQL Server 2008 R2

  Microsoft Knowledge Base-artikelen waarin deze hotfixes worden besproken, worden gepubliceerd zodra ze beschikbaar zijn.

  Voor meer informatie over de SQL Server-bugs klikt u op de volgende artikelnummers in de Microsoft Knowledge Base:

VSTS-bugnummer KB-artikelnummer Beschrijving
549034 geen CDC-opnametaak kan de volgende assertvoorwaarde ervaren wanneer CDC is ingeschakeld in databasetabellen met XML of andere blobgegevenstypekolommen:

Bewering: Bestand: <bestandsnaam>
line=<line number> Failed Assertion = 'fNoWriters' -EN-
line=<line number> Failed Assertion = 'fNoReaderWriterConflict'
548984 980570 FIX: Foutbericht 'Indexfout in volledige tekst tijdens compressie of decompressie' wanneer u de zoekindex in volledige tekst opnieuw opbouwt in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
548986 980832 FIX: Foutbericht 'Een systeembevestigingscontrole is mislukt' wanneer u een Transaction-SQL-query uitvoert in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
451119 980849 FIX: Er is een hoge latentie voor peer-to-peer-distributieagents in Microsoft SQL Server 2005, Microsoft SQL Server 2008 of Microsoft SQL Server 2008 R2
548988 981120 FIX: Foutbericht wanneer u TDE inschakelt voor een database waarvoor de momentopname-isolatie is ingeschakeld in SQL Server 2008 of in SQL Server 2008 R2
548990 982034 FIX: De vertaalfunctie werkt niet wanneer u een groepeeractie uitvoert in een Excel-draaitabel die SSAS 2008 of SSAS 2008 R2 als gegevensbron gebruikt
548996 982854 FIX: Foutbericht 'Er is onvoldoende systeemgeheugen in de resourcegroep 'intern' om deze query uit te voeren' wanneer u een full-text query uitvoert waarin samengestelde woorden worden gebruikt in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
548998 982857 FIX: Foutbericht bij het configureren van transactionele replicatie voor een database in SQL Server 2008 of in SQL Server 2008 R2
549014 983577 FIX: Het exportproces wordt nooit voltooid wanneer u een rapport exporteert waarin tablix-items in Microsoft SQL Server Reporting Services 2008 zijn genest naar de extensies die worden ondersteund door de harde pagina-einderenderers
442541 2022254 SQL Server kan fout 18272 rapporteren tijdens herstelbewerkingen
549019 2028406 FIX: Spaties tussen sommige items worden onjuist gegenereerd in een rapport van SQL Server 2008 of van SQL Server 2008 R2
549021 2028755 FIX: Er wordt een onjuist resultaat geretourneerd wanneer u een LIKE-query met jokertekens en de sortering Latin1_General_100_CS_AS uitvoert in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
549040 2200755 FIX: Foutbericht wanneer u een MDX-query uitvoert in SSAS 2008 of SSAS 2008 R2
549042 2220252 FIX: een SQL Server 2005-rapport waarin de functie voor wisselknoppen voor zichtbaarheid wordt gebruikt, wordt niet goed uitgevoerd in SQL Server 2008 of in SQL Server 2008 R2
547877 2222998 FIX: er wordt een onjuiste kardinaliteitsschatting geretourneerd wanneer u een query uitvoert in SQL Server 2005, SQL Server 2008 of SQL Server 2008 R2
549032 2248999 FIX: Een index beschadigd wanneer u een weergave bijwerkt in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
549044 2255410 Een query retourneert inconsistente resultaten voordat de gegevenscache wordt opgewarmd in SSAS 2008 of SSAS 2008 R2
561761 2261403 FIX: het prestatieobject 'SQL Server:SSIS Pipeline 10.0' wordt niet weergegeven in de lijst 'Prestatieobject' terwijl een andere gebruiker toegang heeft tot enkele SSIS-pijplijntellers in SQL Server 2008 of in SQL Server 2008 R2
549030 2264562 FIX: een full-text query die gebruikmaakt van het predicaat CONTAINS of FREETEXT samen met de operator 'OR' duurt lang om uit te voeren in SQL Server 2008 of in SQL Server 2008 R2
561767 2276330 FIX: de functie "CHANGETABLE" is traag in SQL Server 2008 en in SQL Server 2008 R2
519628 2276495 FIX: 'Bestandssysteemfout' treedt op wanneer u probeert een procesupdatebewerking uit te voeren op een dimensie in Microsoft SQL Server 2008 R2 Analysis Services
561769 2276717 FIX: foutcode 1456 wanneer u een witness toevoegt aan een nieuwe sessie voor databasespiegeling die dezelfde databasenaam heeft als een bestaande sessie voor databasespiegeling in Microsoft SQL Server 2005, Microsoft SQL Server 2008 en Microsoft SQL Server 2008 R2
561772 2278042 FIX: Een afgeleide kolomtransformatie kan onjuiste resultaten opleveren in SSIS 2008 of SSIS 2008 R2 wanneer een kolom wordt afgeleid bij zowel alleen-lezen als lezen/schrijven
524544 2284503 OPLOSSING: Er treden twee problemen op wanneer u Microsoft SQL Server 2008 R2 Master Data Services (MDS) gebruikt
528558 2291551 FIX: Er treedt een fout op wanneer u een externe rapportserverdatabase probeert te configureren met behulp van Reporting Services Configuration Manager in de Datacenter-editie van SQL Server 2008 R2 Reporting Services
526900 2291705 FIX: De AMO-, ADOMD.NET- en XMLA-assembly's voor Microsoft SQL Server 2008 R2 bevatten onjuiste afhankelijkheden van de Microsoft.SharePoint.dll-assembly en de Microsoft.AnalysisServices.SharePoint.Integration.dll-assembly
536667 2293053 FIX: De kolomkop-id bevat onjuiste informatie over een voorvoegsel wanneer u het besturingselement 'ReportViewer' van Visual Studio 2010 gebruikt om lokaal een rapport uit te voeren
547891 2295869 FIX: Er ontstaat een onopgeloste impasse wanneer een database wordt hersteld in SQL Server 2005 SP3 of in SQL Server 2008 R2
534262 2297308 FIX: Het foutbericht 'Een vorige configuratiepoging voor een bestandsstroom was onvolledig' en er treedt een toegangsfout op wanneer u de configuratie van de functie FILESTREAM na installatie uitvoert op een failovercluster van SQL Server 2008 of SQL Server 2008 R2
534101 2300689 OPLOSSING: U kunt een back-up van een database niet terugzetten op een ander exemplaar van SQL Server als u transparante gegevensversleuteling uitschakelt voordat u de back-up maakt in SQL Server 2008 of in SQL Server 2008 R2
544205 2344694 FIX: bepaalde functies voor het bijhouden van wijzigingen en DMV's werken niet goed na een failover voor automatische databasespiegeling in SQL Server 2008 R2
536267 2359606 FIX: Het foutbericht 'System.OverflowException: waarde was te groot of te klein voor een Int32' treedt op wanneer u probeert een rapport te genereren in Microsoft SQL Server 2008 R2 Reporting Services
561798 2380361 FIX: Foutbericht wanneer u de opgeslagen procedure 'sp_createstats' uitvoert in SQL Server 2008 of in SQL Server 2008 R2 als de tabel een niet-deterministische berekende kolom bevat
561800 2380435 FIX: Het queryplan voor een opgeslagen procedure wordt niet in de cache opgeslagen als de opgeslagen procedure gebruikmaakt van een BLOB-variabele en de variabele wordt gebruikt in een tekenreeksfunctie in Microsoft SQL Server 2008 of in Microsoft SQL Server 2008 R2
561804 2384766 FIX: de eigenschap ANSI_NULLS van een geïndexeerde weergave wordt gewijzigd in ONWAAR nadat de geïndexeerde weergave is gerepliceerd naar de abonnementsdatabase in SQL Server 2008 of in SQL Server 2008 R2
561806 2387686 FIX: Foutbericht 'Er is een MOF-syntaxisfout opgetreden' treedt op wanneer u probeert SQL Server 2008 of SQL Server 2008 R2 te installeren
549656 2397020 FIX: 'Toegang geweigerd. Het foutbericht [0x80070005]' treedt op in SSCM wanneer u probeert het wachtwoord te wijzigen van een account van SQL Server 2008 R2 in Windows Vista of in een nieuwere versie van Windows
548720 2401453 FIX:"Search failed: Failed to retrieve data for this request" message when you search for some SQL Azure database objects in the "Objectverkenner Details' tab of SQL Server 2008 R2 Management Studio
554322 2407088 FIX: De fout 'Sys.ArgumentNullException' treedt op wanneer u een analyserapport opent in een webonderdeel Rapportviewer als u de geïntegreerde modus van SharePoint gebruikt in SQL Server 2008 R2 Reporting Services
555924 2410425 FIX: er treedt een uitzondering op wanneer u probeert een MDS-database te maken in MDS van SQL Server 2008 R2 als een niet-MDS-databasetabel de naam 'tblSystem' heeft
555933 2412136 FIX: Het Entiteiten Explorer-raster geeft enkele rijen weer op een MDS-website van SQL Server 2008 R2 als u een lage schermresolutie gebruikt
560368 2421014 FIX: Foutbericht 'Er is een ernstige fout opgetreden bij de huidige opdracht' wanneer u de functie Freetexttable of Containstable gebruikt in een geïndexeerde weergave in een CTE-query in SQL Server 2008 R2
554345 2428397 FIX: Het foutbericht 'Type komt niet overeen' treedt op wanneer u probeert een ingesloten PowerPivot-database te verwijderen uit een exemplaar van SQL Server 2008 R2 Analysis Services dat is geïnstalleerd in de SharePoint-integratiemodus
558922 2431362 FIX: Foutbericht wanneer u probeert een benoemde query te maken in een project dat Microsoft SQL Server 2008 R2 Parallel Data Warehouse als gegevensbron gebruikt: Trefwoord wordt niet ondersteund

Cumulatieve updatepakketinformatie

Informatie over opnieuw opstarten

  Nadat u deze cumulatieve update hebt toegepast, moet u de computer wellicht opnieuw opstarten.

Registergegevens

  Als u een van de hotfixes in dit pakket wilt gebruiken, hoeft u geen wijzigingen in het register aan te brengen.

Het cumulatieve updatepakket verwijderen

  Voer de volgende stappen uit om het cumulatieve updatepakket te verwijderen:

  1. Open in het Configuratiescherm de
    Programma's toevoegen of verwijderen
      -item.

  2. Klikt u op
    Programma's wijzigen of verwijderen
      .

  3. Als u alle updates voor de installatie van SQL Server 2008 R2 wilt zien, klikt u op de
    Toon Updates
      in.

  4. Verwijder het cumulatieve hotfixpakket.

Meer informatie

  Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:

935897
  Er is een incrementeel onderhoudsmodel beschikbaar van het SQL Server-team om hotfixes te leveren voor gemelde problemen

  Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:

822499
  Nieuw naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server
   Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over de terminologie van software-updates:

824684
  Beschrijving van de standaardterminologie die wordt gebruikt voor Microsoft-software-updates