Soms moet u controleren of een cel leeg is, in het algemeen omdat u niet wilt dat een formule een resultaat weergeeft zonder invoer.

De formule in cel E2 is =ALS(D2=1;"Ja";ALS(D2=2;"Nee";"Misschien"))

In dit geval gebruiken we ALS met de functie ISLEEG:

  • =ALS(ISLEEG (D2);"Leeg";"Niet leeg")

Dit betekent: als (D2 leeg is, retourneer dan 'Leeg'; retourneer anders 'Niet leeg'). U kunt even gemakkelijk uw eigen formule gebruiken voor de 'Niet leeg'-voorwaarde. In het volgende voorbeeld gebruiken we "" in plaats van ISLEEG. De "" betekent in feite 'niets'.

Controleren of een cel leeg is – De formule in cel E2 is =ALS(ISLEEG (D2);"Leeg";"Niet leeg")

=ALS(D3="";"Leeg";"Niet leeg")

Deze formule betekent: als (D3 niets bevat, retourneer dan 'Leeg', en anders 'Niet leeg'). Hier volgt een voorbeeld van een eenvoudige manier om "" te gebruiken om te voorkomen dat een formule wordt berekend als een afhankelijke cel leeg is:

  • =ALS(D3="";"";UwFormule())

    A (D3 leeg is, retourneer dan niets; bereken anders uw formule).

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×