Meer informatie over SOM

Meer informatie over de functie SOM

Als u snel de som van een bereik van cellen wilt weten, hoeft u alleen maar het bereik te selecteren en in de rechterbenedenhoek van het Excel-venster te kijken.

Schermafbeelding van het selecteren van een bereik van cellen, met daarna verschillende gegevens op de statusbalk


Dit is de status balk en wordt informatie weergegeven over alle items die u hebt geselecteerd, ongeacht of dit één cel of meerdere cellen is. Als u met de rechtermuisknop op de statusbalk klikt, ziet u een lijst met alle opties die u kunt kiezen. De statusbalk bevat ook waarden voor het geselecteerde bereik als u deze kenmerken hebt ingeschakeld. 

De eenvoudigste manier om een som-formule toe te voegen aan uw werkblad is met behulp van de wizard AutoSom. Selecteer een lege cel direct boven of onder het bereik dat u wilt optellen, en druk op de tab-toets op het tabblad Start of formule op de tab-toets > som. De wizard AutoSom beslaat automatisch het bereik dat wordt opgeteld en bouwt de formule voor u op. U kunt ook horizontaal werken als u een cel links of rechts van het bereik selecteert waarmee u wilt optellen. Opmerking Het is niet mogelijk om niet-aaneengesloten bereiken te werken, maar in het volgende gedeelte gaat u verder.

U kunt de wizard AutoSom gebruiken om automatisch een formule met SOM te maken.  Selecteer een bereik boven/onder of links/rechts van het bereik dat u wilt optellen en ga naar het tabblad Formules op het lint en selecteer AutoSom > SOM.


In het dialoogvenster AutoSom kunt u ook andere veelgebruikte functies selecteren, zoals:

AutoSom voor een verticaal bereik

Cel B6 bevat de SOM-formule die is gemaakt met AutoSom: =SOM(B2:B5)

De wizard AutoSom heeft de cellen B2: B5 automatisch vastgesteld als het bereik dat moet worden opgeteld. U hoeft alleen maar op ENTER te drukken om het te bevestigen. Als u meer cellen wilt toevoegen/uitsluiten, kunt u de Shift-toets ingedrukt > pijltoets van de gewenste optie totdat de selectie overeenkomt met wat u wilt en drukt u op ENTER wanneer u klaar bent.

IntelliSense-functiebeschrijving: het zwevende label SOM(getal1;[getal2]; …) onder de functie is de bijbehorende IntelliSense-beschrijving. Als u op de som of de functienaam klikt, verandert deze in een blauwe hyperlink waarmee u naar het Help-onderwerp voor die functie gaat. Als u op de afzonderlijke functie-elementen klikt, worden de bijbehorende onderdelen in de formule gemarkeerd. In dit geval zou alleen B2:B5 worden gemarkeerd, aangezien er slechts één verwijzing naar een getal in deze formule staat. Het IntelliSense-label wordt weergegeven voor elke functie.

AutoSom voor een horizontaal bereik

Cel D2 bevat de SOM-formule die is gemaakt met AutoSom: =SOM(B2:C2)

SOM gebruiken met niet-aaneengesloten bereiken.  Cel C8's formule is = som (C2: C3; C5: C6). U kunt ook benoemde bereiken gebruiken, dus is de formule = SUM (Week1, Week2).

De wizard AutoSom werkt in het algemeen alleen voor aaneengesloten bereiken, dus als u lege rijen of kolommen in het bereik met totalen hebt, wordt Excel bij de eerste opening gestopt. In dit geval moet u eerst een selectie optellen, waarbij u de afzonderlijke bereiken een voor een kunt toevoegen. In dit voorbeeld als u gegevens hebt in cel B4, wordt in Excel het volgende gegenereerd: = som (C2: C6) omdat een aaneengesloten bereik werd herkend.

U kunt snel meerdere, niet-aaneengesloten bereiken selecteren met CTRL + klikkenmet de linkermuisknop. Typ eerst "= som (" en selecteer vervolgens de verschillende bereiken, waarna het komma scheidingsteken tussen de bereiken automatisch wordt toegevoegd. Druk op ENTER wanneer u klaar bent.

TIP: gebruik ALT+ = om de functie SOM snel toe te voegen aan een cel. Vervolgens hoeft u alleen nog maar een of meer bereiken te selecteren.

Opmerking: u zult merken dat de verschillende functies in Excel zijn gemarkeerd op kleur en ze binnen de formule zelf passen, dus C2: C3 is één kleur, en C5: C6 is een andere kleur. Excel doet dit voor alle functies, tenzij het bereik waarnaar wordt verwezen, zich in een ander werkblad of in een andere werkmap bevindt. Voor uitgebreide toegankelijkheid met ondersteunende technologie kunt u benoemde bereikengebruiken, zoals "Week1", "Week2", "", enzovoort.

=SOM(Week1;Week2)

  1. U kunt SOM gebruiken met andere functies. Hier ziet u een voorbeeld om per maand een gemiddelde te berekenen:

    SOM gebruiken met andere functies.  Formule in cel M2 is =SOM(A2:L2)/AANTALARG(A2:L2).  Opmerking: de kolommen voor mei tot en met november zijn voor de duidelijkheid verborgen.
    • =SOM(A2:L2)/AANTALARG(A2:L2)

  2. Hiermee wordt de SOM berekend van A2:L2 gedeeld door het aantal niet-lege cellen in A2:L2 (mei tot en met december zijn leeg).

  1. Soms moet u de som van een bepaalde cel in verschillende werkbladen berekenen. Het kan dan verleidelijk zijn om in de verschillende bladen op de gewenste cel te klikken en het plusteken (+) te gebruiken om de celwaarden op te tellen, maar dat is nogal omslachtig en u maakt sneller fouten.

    • =Blad1!A1+Blad2!A1+Blad3!A1

    U kunt veel beter een 3D of driedimensionale SOM-functie gebruiken:

    3D SOM-bewerking - Formule in cel D2 is =SOM(Blad1:Blad3!A2)
    • =SOM(Blad1:Blad3!A1)

    Hiermee worden de waarden opgeteld van cel A1 op alle bladen van Blad 1 tot en met Blad 3.

    Dit is vooral handig in situaties waarin u één blad hebt voor elke maand (januari-december) en u een totaal nodig hebt op een overzichtsblad.

    3D-SOM-bewerking voor benoemde bereiken.  Formule in D2 is =SOM(januari:december!A2)
    • =SOM(januari:december!A2)

    Hiermee wordt de som berekend van de waarde van elke cel A2 in de werkbladen van januari tot en met december.

    Notities: Als de namen van de werkbladen een spatie bevatten, zoals 'Verkopen januari', moet u een apostrof gebruiken om in een formule naar de namen te verwijzen. U ziet de apostrof vóór de naam van het eerste werkblad en na de naam van het laatste werkblad.

    • =SOM(‘Verkopen januari:Verkopen december’!A2)

    De 3D-methode werkt ook met andere functies, zoals GEMIDDELDE, MIN, MAX, enzovoort:

    • =GEMIDDELDE(Blad1;Blad3!A1)

    • =MIN(Blad1;Blad3!A1)

    • =MAX(Blad1;Blad3!A1)

U kunt in Excel eenvoudig afzonderlijke wiskundige bewerkingen uitvoeren en in combinatie met Excel-functies zoals SOM. De volgende tabel bevat de operators die u kunt gebruiken en enkele gerelateerde functies. U kunt de operatoren invoeren via de cijfertoetsen op het toetsenbord of via het numerieke toetsenblok met tien toetsen, als u dit hebt. Met Shift + 8 voert u bijvoorbeeld het sterretje (*) in om te vermenigvuldigen.

Operator

Bewerking

Voorbeelden

+

Optellen

=1+1

=A1+B1

=SOM(A1:A10)+10

=SOM(A1:A10)+B1

-

Aftrekken

=1-1

=A1-B1

=SOM(A1:A10)-10

=SOM(A1:A10)-B1

*

Vermenigvuldigen

=1*1

=A1*B1

=SOM(A1:A10)*10

=SOM(A1:A10)*B1

=PRODUCT(1,1) - PRODUCT, functie

/

Delen

=1/1

=A1/B1

=SOM(A1:A10)/10

=SOM(A1:A10)/B1

=QUOTIENT(1,1) - QUOTIENT, functie

^

Machtsverheffen

=1^1

=A1^B1

=SOM(A1:A10)^10

=SOM(A1:A10)^B1

=MACHT(1,1) - MACHT, functie

Zie voor meer informatie Excel als rekenmachine.

Andere voorbeelden

  1. Stel dat u een procentuele korting wilt toepassen op een bereik met cellen die u hebt opgeteld.

    Operatoren gebruiken met SOM.  Formule in cel B16 is =SOM(A2:A14)*-25%.  De formule zou juist zijn samengesteld als -25% een celverwijzing was in plaats van een letterlijke waarde, zoals =SOM(A2:A14)*E2
    • =SOM(A2:A14)*-25%

    Geeft u 25% van het opgetelde bereik, zodat de 25% in de formule moeilijk te vinden is, of het nu later moeilijk te vinden is. U kunt veel beter de 25% in een cel plaatsen en hiernaar verwijzen, waar het zich bevindt in het geopende en gemakkelijk te wijzigen:

    • =SOM(A2:A14)*E2

    Als u wilt delen in plaats van vermenigvuldigen, vervangt u het sterretje (*) door een schuine streep (/): =SOM(A2:A14)/E2

  2. Een berekende som aanpassen door een waarde op te tellen of af te trekken

    i. U kunt een som eenvoudig groter of kleiner maken met behulp van + of -, zoals hier:

    • =SOM(A1:A10)+E2

    • =SOM(A1:A10)-E2

Opmerking:  Deze pagina is automatisch vertaald en kan grammaticale fouten of onnauwkeurigheden bevatten. Wij hopen dat deze inhoud nuttig voor je is. Wil je ons laten weten of deze informatie nuttig is? Hier is het Engelstalige artikel ter referentie.

Zie ook

Functie SOM

Meer hulp nodig?

Uw Office-vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Office Insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×