Meer informatie over de functie SOM

Als u snel de som van een bereik van cellen wilt weten, hoeft u alleen maar het bereik te selecteren en in de rechterbenedenhoek van het Excel-venster te kijken.

Schermafbeelding van het selecteren van een bereik van cellen, met daarna verschillende gegevens op de statusbalk


Dit is de statusbalk en er wordt informatie weergegeven over wat u hebt geselecteerd, ongeacht of dit één cel of meerdere cellen is. Als u met de rechtermuisknop op de statusbalk klikt, ziet u een lijst met alle opties die u kunt kiezen. De statusbalk bevat ook waarden voor het geselecteerde bereik als u deze kenmerken hebt ingeschakeld. 

De eenvoudigste manier om een SOM-formule toe te voegen aan uw werkblad is door de wizard AutoSom te gebruiken. Selecteer een lege cel direct boven of onder het bereik dat u wilt optelen en druk op de tabbladen Start of Formule op het lint op AutoSom > Som. De wizard AutoSom detecteert automatisch het bereik dat moet worden opgeteld en maakt de formule voor u. Het kan ook horizontaal werken als u links of rechts van het bereik een cel selecteert die moet worden opgeteld. Houd er rekening mee dat het niet werkt in niet-aaneengesloten bereik, maar we gaan daar in de volgende sectie op in.

U kunt de wizard AutoSom gebruiken om automatisch een formule met SOM te maken.  Selecteer een bereik boven/onder of links/rechts van het bereik dat u wilt optellen en ga naar het tabblad Formules op het lint en selecteer AutoSom > SOM.


In het dialoogvenster AutoSum kunt u ook andere veelgebruikte functies selecteren, zoals:

AutoSom voor een verticaal bereik

Cel B6 bevat de SOM-formule die is gemaakt met AutoSom: =SOM(B2:B5)

De wizard AutoSom heeft automatisch cellen B2:B5 gedetecteerd als het bereik dat moet worden opgeteld. U hoeft alleen maar op Enter te drukken om dit te bevestigen. Als u meer cellen wilt toevoegen of uitsluiten, kunt u shifttoets > pijl naar keuze houden totdat uw selectie overeenkomt met wat u wilt en op Enter drukken wanneer u klaar bent.

IntelliSense-functiebeschrijving: het zwevende label SOM(getal1;[getal2]; …) onder de functie is de bijbehorende IntelliSense-beschrijving. Als u op de som of de functienaam klikt, verandert deze in een blauwe hyperlink waarmee u naar het Help-onderwerp voor die functie gaat. Als u op de afzonderlijke functie-elementen klikt, worden de bijbehorende onderdelen in de formule gemarkeerd. In dit geval zou alleen B2:B5 worden gemarkeerd, aangezien er slechts één verwijzing naar een getal in deze formule staat. Het IntelliSense-label wordt weergegeven voor elke functie.

AutoSom voor een horizontaal bereik

Cel D2 bevat de SOM-formule die is gemaakt met AutoSom: =SOM(B2:C2)

Som gebruiken met niet-aaneengesloten bereik.  De formule van cel C8 is =SOM(C2:C3;C5:C6). U kunt ook Benoemde bereik gebruiken, zodat de formule =SOM(Week1;Week2) is.

De wizard AutoSom werkt over het algemeen alleen voor aaneengesloten bereik, dus als u lege rijen of kolommen in het totaalbereik hebt, stopt Excel bij de eerste tussenruimte. In dat geval moet u SOM per selectie, waarbij u de afzonderlijke reeksen een voor een toevoegt. Als u in dit voorbeeld gegevens in cel B4 hebt, Excel =SOM(C2:C6) gegenereerd omdat er een aaneengesloten bereik wordt herkend.

U kunt snel meerdere, niet-aaneengesloten bereik selecteren met Ctrl+Klik op links. Typ eerst '=SOM', selecteer vervolgens uw verschillende bereik en Excel het kommascheidingsteken automatisch tussen de verschillende bereikbereiken. Druk op Enter wanneer u klaar bent.

TIP: gebruik ALT+ = om de functie SOM snel toe te voegen aan een cel. Vervolgens hoeft u alleen nog maar een of meer bereiken te selecteren.

Opmerking: u ziet mogelijk hoe Excel de verschillende functiebereiken op kleur heeft gemarkeerd en ze overeenkomen binnen de formule zelf, dus C2:C3 is één kleur en C5:C6 is een andere. Excel doet dit voor alle functies, tenzij het waarnaar wordt verwezen op een ander werkblad of in een andere werkmap staat. Voor verbeterde toegankelijkheid met ondersteunende technologie kunt u benoemde bereikbereiken gebruiken,zoals 'Week1', 'Week2', enzovoort, en deze vervolgens in uw formule verwijzen:

=SOM(Week1;Week2)

  1. U kunt SOM gebruiken met andere functies. Hier ziet u een voorbeeld om per maand een gemiddelde te berekenen:

    SOM gebruiken met andere functies.  Formule in cel M2 is =SOM(A2:L2)/AANTALARG(A2:L2).  Opmerking: de kolommen voor mei tot en met november zijn voor de duidelijkheid verborgen.
    • =SOM(A2:L2)/AANTALARG(A2:L2)

  2. Hiermee wordt de SOM berekend van A2:L2 gedeeld door het aantal niet-lege cellen in A2:L2 (mei tot en met december zijn leeg).

  1. Soms moet u de som van een bepaalde cel in verschillende werkbladen berekenen. Het kan dan verleidelijk zijn om in de verschillende bladen op de gewenste cel te klikken en het plusteken (+) te gebruiken om de celwaarden op te tellen, maar dat is nogal omslachtig en u maakt sneller fouten.

    • =Blad1!A1+Blad2!A1+Blad3!A1

    U kunt veel beter een 3D of driedimensionale SOM-functie gebruiken:

    3D SOM-bewerking - Formule in cel D2 is =SOM(Blad1:Blad3!A2)
    • =SOM(Blad1:Blad3!A1)

    Hiermee worden de waarden opgeteld van cel A1 op alle bladen van Blad 1 tot en met Blad 3.

    Dit is vooral handig in situaties waarin u één blad hebt voor elke maand (januari-december) en u een totaal nodig hebt op een overzichtsblad.

    3D-SOM-bewerking voor benoemde bereiken.  Formule in D2 is =SOM(januari:december!A2)
    • =SOM(januari:december!A2)

    Hiermee wordt de som berekend van de waarde van elke cel A2 in de werkbladen van januari tot en met december.

    Notities: Als de namen van de werkbladen een spatie bevatten, zoals 'Verkopen januari', moet u een apostrof gebruiken om in een formule naar de namen te verwijzen. U ziet de apostrof vóór de naam van het eerste werkblad en na de naam van het laatste werkblad.

    • =SOM(‘Verkopen januari:Verkopen december’!A2)

    De 3D-methode werkt ook met andere functies, zoals GEMIDDELDE, MIN, MAX, enzovoort:

    • =GEMIDDELDE(Blad1;Blad3!A1)

    • =MIN(Blad1;Blad3!A1)

    • =MAX(Blad1;Blad3!A1)

U kunt in Excel eenvoudig afzonderlijke wiskundige bewerkingen uitvoeren en in combinatie met Excel-functies zoals SOM. De volgende tabel bevat de operators die u kunt gebruiken en enkele gerelateerde functies. U kunt de operatoren invoeren via de cijfertoetsen op het toetsenbord of via het numerieke toetsenblok met tien toetsen, als u dit hebt. Met Shift + 8 voert u bijvoorbeeld het sterretje (*) in om te vermenigvuldigen.

Operator

Bewerking

Voorbeelden

+

Optellen

=1+1

=A1+B1

=SOM(A1:A10)+10

=SOM(A1:A10)+B1

-

Aftrekken

=1-1

=A1-B1

=SOM(A1:A10)-10

=SOM(A1:A10)-B1

*

Vermenigvuldigen

=1*1

=A1*B1

=SOM(A1:A10)*10

=SOM(A1:A10)*B1

=PRODUCT(1,1) - PRODUCT, functie

/

Delen

=1/1

=A1/B1

=SOM(A1:A10)/10

=SOM(A1:A10)/B1

=QUOTIENT(1,1) - QUOTIENT, functie

^

Machtsverheffen

=1^1

=A1^B1

=SOM(A1:A10)^10

=SOM(A1:A10)^B1

=MACHT(1,1) - MACHT, functie

Zie voor meer informatie Excel als rekenmachine.

Andere voorbeelden

  1. Stel dat u een procentuele korting wilt toepassen op een bereik met cellen die u hebt opgeteld.

    Operatoren gebruiken met SOM.  Formule in cel B16 is =SOM(A2:A14)*-25%.  De formule zou juist zijn samengesteld als -25% een celverwijzing was in plaats van een letterlijke waarde, zoals =SOM(A2:A14)*E2
    • =SOM(A2:A14)*-25%

    Geeft u 25% van het opgetelde bereik, maar de 25% in de formule wordt hardcodeerd en het kan lastig zijn om het later te vinden als u het wilt wijzigen. U kunt de 25% beter in een cel plaatsen en dat in plaats daarvan verwijzen, waar de 25% in de open en gemakkelijk te wijzigen cel staat, zoals dit:

    • =SOM(A2:A14)*E2

    Als u wilt delen in plaats van vermenigvuldigen, vervangt u het sterretje (*) door een schuine streep (/): =SOM(A2:A14)/E2

  2. Een berekende som aanpassen door een waarde op te tellen of af te trekken

    i. U kunt een som eenvoudig groter of kleiner maken met behulp van + of -, zoals hier:

    • =SOM(A1:A10)+E2

    • =SOM(A1:A10)-E2

SOM, functie

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft Office Insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de taalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×