Verwante onderwerpen
×
Formules en functies
Formules en functies

X.ZOEKEN

Gebruik de functie X.ZOEKEN om items in een tabel of bereik per rij te zoeken. Zoek bijvoorbeeld de prijs van een auto-onderdeel op aan de hand van het onderdeelnummer of zoek een werknemersnaam op basis van hun werknemers-ID. Met X.ZOEKEN kunt u in één kolom zoeken naar een zoekterm en een resultaat uit dezelfde rij in een andere kolom retourneren, ongeacht aan welke kant de retourkolom zich bevindt.

Opmerking: X.ZOEKEN is niet beschikbaar in Excel 2016 en Excel 2019, maar het kan zijn dat u een werkmap in Excel 2016 of Excel 2019 gebruikt met de functie X.ZOEKEN die door iemand anders is gemaakt met een nieuwere versie van Excel.

Uw browser biedt geen ondersteuning voor video. Installeer Microsoft Silverlight, Adobe Flash Player of Internet Explorer 9.

Syntaxis

De functie X.ZOEKEN zoekt in een bereik of matrix en retourneert vervolgens het item dat overeenkomt met de eerste overeenkomst die wordt gevonden. Als er geen overeenkomst bestaat, kan X.ZOEKEN de dichtstbijzijnde (bij benadering) overeenkomst retourneren. 

=X.ZOEKEN(zoekwaarde; zoeken-matrix; matrix_retourneren; [indien_niet_gevonden]; [overeenkomstmodus]; [zoekmodus]) 

Argument

Beschrijving

zoekwaarde

Vereist*

De waarde waarnaar moet worden gezocht

*Als u X.ZOEKEN weglaat, worden lege cellen geretourneerd die in lookup_array worden gevonden.   

zoeken-matrix

Verplicht

De matrix of het bereik waarin u wilt zoeken

matrix_retourneren

Verplicht

De matrix of het bereik dat moet worden geretourneerd

[indien_niet_gevonden]

Optioneel

Wanneer geen geldige overeenkomst wordt gevonden, wordt de door u opgegeven tekst [indien_niet_gevonden] geretourneerd.

Als er geen geldige overeenkomst wordt gevonden en [if_not_found] ontbreekt, wordt #N/A geretourneerd.

[overeenkomstmodus]

Optioneel

Geef het type overeenkomst op:

0 - Exacte overeenkomst. Als niets wordt gevonden, wordt #N/A geretourneerd. Dit is de standaardinstelling.

-1 - Exacte overeenkomst. Als niets wordt gevonden, wordt het volgende kleinere item geretourneerd.

1 - Exacte overeenkomst. Als niets wordt gevonden, wordt het volgende grotere item geretourneerd.

2 - Een overeenkomst met een jokerteken waar *, ? en ~ speciale betekenishebben.

[zoekmodus]

Optioneel

Geef de zoekmodus op die u wilt gebruiken:

1 - Voer een zoekopdracht uit vanaf het eerste item. Dit is de standaardinstelling.

-1 - Voer een omgekeerde zoekopdracht uit vanaf het laatste item.

2 - Voer een binaire zoekopdracht uit op basis waarvan lookup_array in oplopende volgorde wordt gesorteerd. Als niet wordt gesorteerd, worden er ongeldige resultaten geretourneerd.

2 - Voer een binaire zoekopdracht uit op basis waarvan lookup_array in aflopende volgorde wordt gesorteerd. Als niet wordt gesorteerd, worden er ongeldige resultaten geretourneerd.

Voorbeelden

In voorbeeld 1    wordt X.ZOEKEN gebruikt om een landnaam in een bereik op te zoeken en vervolgens de landcode van de telefoon te retourneren. Het bevat de argumenten lookup_value (cel F2), lookup_array (bereik B2:B11) en return_array (bereik D2:D11). Het argument match_mode is niet opgenomen, omdat X.ZOEKEN standaard een exacte overeenkomst produceert.

Voorbeeld van de X.ZOEKEN-functie die wordt gebruikt om de naam van een medewerker en een afdeling te retourneren op basis van medewerker-ID. De formule is =X.ZOEKEN(B2;B5:B14;C5:C14).

Opmerking: X.ZOEKEN maakt gebruik van een opzoekmatrix en een retourmatrix, terwijl VERT.ZOEKEN één tabelmatrix gebruikt, gevolgd door een kolomindexnummer. De equivalente vert.ZOEKEN-formule in dit geval is: =VERT.ZOEKEN(F2;B2:D11;3;ONWAAR)

———————————————————————————

Voorbeeld 2    zoekt werknemersgegevens op op basis van een werknemer-id-nummer. In tegenstelling tot VERT.ZOEKEN kan X.ZOEKEN een matrix met meerdere items retourneren, zodat één formule zowel de naam van de werknemer als de afdeling kan retourneren uit de cellen C5:D14.

Voorbeeld van de X.ZOEKEN-functie die wordt gebruikt om de naam van een medewerker en een afdeling te retourneren op basis van medewerker-ID. De formule is =X.ZOEKEN(B2;B5:B14;C5:D14;0;1).

———————————————————————————

In voorbeeld 3    wordt een if_not_found argument toegevoegd aan het voorgaande voorbeeld.

Voorbeeld van de X.ZOEKEN-functie die wordt gebruikt om de naam van een medewerker en een afdeling te retourneren op basis van medewerker-ID, met het argument if_not_found. De formule is =X.ZOEKEN(B2;B5:B14;C5:D14;0;1;"Werknemer niet gevonden")

———————————————————————————

In voorbeeld 4    wordt in kolom C gezocht naar het persoonlijke inkomen dat is ingevoerd in cel E2 en wordt een overeenkomend belastingtarief gevonden in kolom B. Hiermee wordt het if_not_found argument ingesteld op 0 (nul) als er niets wordt gevonden. Het argument match_mode is ingesteld op 1, wat betekent dat de functie zoekt naar een exacte overeenkomst en als deze er geen kan vinden, wordt het volgende grotere item geretourneerd. Ten slotte is het argument search_mode ingesteld op 1, wat betekent dat de functie van het eerste item naar het laatste zoekt.

Afbeelding van de X.ZOEKEN-functie die wordt gebruikt om een belastingtarief te retourneren op basis van het maximale inkomen. Dit is een niet-geheel exacte overeenkomst. De formule is =X.ZOEKEN(E2;C2:C7;B2:B7;1;1)

Opmerking: De lookup_array kolom van XARRAY bevindt zich rechts van de return_array kolom, terwijl VERT.ZOEKEN alleen van links naar rechts kan zoeken.

———————————————————————————

Voorbeeld 5    gebruikt een geneste XLOOKUP-functie om zowel een verticale als horizontale overeenkomst uit te voeren. Er wordt eerst gezocht naar brutowinst in kolom B, vervolgens wordt gezocht naar Kwartaal1 in de bovenste rij van de tabel (bereik C5:F5) en ten slotte wordt de waarde op het snijpunt van de twee geretourneerd. Dit is vergelijkbaar met het gebruik van de functies INDEX en VERGELIJKEN .

Tip: U kunt ook X.ZOEKEN gebruiken om de HORIZ.ZOEKEN-functie te vervangen.

Afbeelding van de X.ZOEKEN-functie waarmee horizontale gegevens uit een tabel worden opgehaald door 2 X.ZOEKEN-functies te nesten. De formule is: =X.ZOEKEN(D2;$B6:$B17;X.ZOEKEN($C3;$C5:$G5;$C6:$G17))

Opmerking: De formule in de cellen D3:F3 is: =X.ZOEKEN(D2;$B 6:$B 17;X.ZOEKEN($C 3;$C 5:$G 5;$C 6:$G 17)))

———————————————————————————

Voorbeeld 6    gebruikt de functie SOM en twee geneste XLOOKUP-functies om alle waarden tussen twee bereiken op te tellen. In dit geval willen we de waarden voor druiven, bananen optellen en peren optellen, die tussen de twee liggen.

X.ZOEKEN gebruiken met SOM om een bereik van waarden te vinden dat tussen twee selecties valt

De formule in cel E3 is: =SOM(X.ZOEKEN(B3;B6:B10;E6:E10):X.ZOEKEN(C3;B6:B10;E6:E10))

Hoe werkt dit? X.ZOEKEN retourneert een bereik, dus wanneer deze wordt berekend, ziet de formule er als volgt uit: =SOM($E$7:$E$9). U kunt zelf zien hoe dit werkt door een cel te selecteren met een XLOOKUP-formule die vergelijkbaar is met deze formule, formules te selecteren > Formules controleren > Formule evalueren en vervolgens Evalueren te selecteren om de berekening te doorlopen.

Opmerking: Met dank aan Microsoft Excel MVP, Bill Jelen, voor het voorstellen van dit voorbeeld.

———————————————————————————

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Live en gratis antwoorden krijgen in Excel

Zie ook

X.VERGELIJKEN-functie

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft Office Insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de taalkwaliteit?
Wat heeft uw ervaring beïnvloed?

Bedankt voor uw feedback.

×