Inhoudsopgave
×
Formules en functies
Formules en functies

X.ZOEKEN

Gebruik de functie XLOOKUP om dingen te zoeken in een tabel of bereik per rij. Zoek bijvoorbeeld de prijs van een auto-onderdeel op aan de hand van het onderdeelnummer of zoek een werknemersnaam op basis van hun werknemers-ID. Met X.ZOEKEN kunt u in een kolom zoeken naar een zoekterm en een resultaat uit dezelfde rij in een andere kolom retourneren, ongeacht aan welke kant de kolom met retourwaarden zich bevindt.

Uw browser biedt geen ondersteuning voor video.

Syntaxis

De functie XLOOKUP zoekt in een bereik of een matrix en retourneert het item dat overeenkomt met de eerste overeenkomst die wordt gevonden. Als er geen overeenkomst bestaat, kan XLOOKUP de dichtstbijzijnde (geschatte) overeenkomst retourneren. 

=X.ZOEKEN(zoekwaarde; zoeken-matrix; matrix_retourneren; [indien_niet_gevonden]; [overeenkomstmodus]; [zoekmodus]) 

Argument

Beschrijving

zoekwaarde

Vereist*

De waarde om naar te zoeken

*Als dit wordt weggelaten, retourneert XLOOKUP lege cellen die worden gevonden in lookup_array.   

zoeken-matrix

Verplicht

De matrix of het bereik waarin u wilt zoeken

matrix_retourneren

Verplicht

De matrix of het bereik dat moet worden geretourneerd

[indien_niet_gevonden]

Optioneel

Wanneer geen geldige overeenkomst wordt gevonden, wordt de door u opgegeven tekst [indien_niet_gevonden] geretourneerd.

Als er geen geldige overeenkomst wordt gevonden en [if_not_found] ontbreekt, wordt #N/A geretourneerd.

[overeenkomstmodus]

Optioneel

Geef het type overeenkomst op:

0 - Exacte overeenkomst. Als niets wordt gevonden, wordt #N/A geretourneerd. Dit is de standaardinstelling.

-1 - Exacte overeenkomst. Als niets wordt gevonden, wordt het volgende kleinere item geretourneerd.

1 - Exacte overeenkomst. Als niets wordt gevonden, wordt het volgende grotere item geretourneerd.

2 - Een overeenkomst met een jokerteken waar *, ? en ~ speciale betekenishebben.

[zoekmodus]

Optioneel

Geef de zoekmodus op die u wilt gebruiken:

1 - Voer een zoekopdracht uit vanaf het eerste item. Dit is de standaardinstelling.

-1 - Voer een omgekeerde zoekopdracht uit vanaf het laatste item.

2 - Voer een binaire zoekopdracht uit op basis waarvan lookup_array in oplopende volgorde wordt gesorteerd. Als niet wordt gesorteerd, worden er ongeldige resultaten geretourneerd.

2 - Voer een binaire zoekopdracht uit op basis waarvan lookup_array in aflopende volgorde wordt gesorteerd. Als niet wordt gesorteerd, worden er ongeldige resultaten geretourneerd.

Voorbeelden

Voorbeeld 1    gebruikt XLOOKUP om een landnaam in een bereik op te zoeken en vervolgens de landcode van de telefoon te retourneren. Het bevat de lookup_value (cel F2), lookup_array (bereik B2:B11) en return_array (bereik D2:D11). Het argument wordt niet match_mode, omdat XLOOKUP standaard een exacte overeenkomst oplevert.

Voorbeeld van de X.ZOEKEN-functie die wordt gebruikt om de naam van een medewerker en een afdeling te retourneren op basis van medewerker-ID. De formule is =X.ZOEKEN(B2;B5:B14;C5:C14).

Opmerking: XLOOKUP gebruikt een opzoekarray en een retourarray, terwijl VERT.ZOEKEN één tabelarray gebruikt, gevolgd door een kolomindexnummer. De equivalente VERT.ZOEKEN-formule in dit geval is: =VERT.ZOEKEN(F2;B2:D11,3;ONWAAR)

———————————————————————————

Voorbeeld 2    zoekt werknemersgegevens op op basis van een werknemers-idnummer. In tegenstelling tot VERT.ZOEKEN kan XLOOKUP een matrix met meerdere items retourneren, zodat één formule zowel de naam van de werknemer als de afdeling kan retourneren vanuit de cellen C5:D14.

Voorbeeld van de X.ZOEKEN-functie die wordt gebruikt om de naam van een medewerker en een afdeling te retourneren op basis van medewerker-ID. De formule is =X.ZOEKEN(B2;B5:B14;C5:D14;0;1).

———————————————————————————

Voorbeeld 3    voegt een if_not_found toe aan het voorgaande voorbeeld.

Voorbeeld van de X.ZOEKEN-functie die wordt gebruikt om de naam van een medewerker en een afdeling te retourneren op basis van medewerker-ID, met het argument if_not_found. De formule is =X.ZOEKEN(B2;B5:B14;C5:D14;0;1;"Werknemer niet gevonden")

———————————————————————————

Voorbeeld 4    zoekt in kolom C naar het persoonlijke inkomen dat is ingevoerd in cel E2 en zoekt een overeenkomend belastingtarief in kolom B. Hiermee stelt u if_not_found argument 0 (nul) als er niets wordt gevonden. Het match_mode argument is ingesteld op 1,wat betekent dat de functie een exacte overeenkomst zal zoeken en als deze niet kan worden gevonden, wordt het volgende grotere item als retourneert. Ten slotte is search_mode argument ingesteld op 1,wat betekent dat de functie van het eerste item naar het laatste item zoekt.

Afbeelding van de X.ZOEKEN-functie die wordt gebruikt om een belastingtarief te retourneren op basis van het maximale inkomen. Dit is een niet-geheel exacte overeenkomst. De formule is =X.ZOEKEN(E2;C2:C7;B2:B7;1;1)

Opmerking: De kolom lookup_array XARRAY is rechts van de return_array kolom, terwijl VERT.ZOEKEN alleen van links naar rechts kan kijken.

———————————————————————————

Voorbeeld 5    gebruikt een geneste XLOOKUP-functie om zowel een verticale als horizontale overeenkomst uit te voeren. Er wordt eerst naar brutowinst in kolom B op zoek naar Qtr1 in de bovenste rij van de tabel (bereik C5:F5) en ten slotte wordt de waarde op het snijpunt van de twee als resultaat geeft. Dit is vergelijkbaar met het samen gebruiken van de functies INDEX en VERGELIJKEN.

Tip: U kunt ook X.ZOEKEN gebruiken om de HORIZ.ZOEKEN-functie te vervangen.

Afbeelding van de X.ZOEKEN-functie waarmee horizontale gegevens uit een tabel worden opgehaald door 2 X.ZOEKEN-functies te nesten. De formule is: =X.ZOEKEN(D2;$B6:$B17;X.ZOEKEN($C3;$C5:$G5;$C6:$G17))

Opmerking: De formule in cellen D3:F3 is: =XLOOKUP(D2,$B 6:$B 17,XLOOKUP($C 3,$C 5:$G 5,$C 6:$G 17)).

———————————————————————————

Voorbeeld 6    gebruikt de functie SOMen twee geneste XLOOKUP-functies om alle waarden tussen twee bereiken op te sommen. In dit geval willen we de waarden voor druiven, bananen optellen en peren optellen, die tussen de twee liggen.

X.ZOEKEN gebruiken met SOM om een bereik van waarden te vinden dat tussen twee selecties valt

De formule in cel E3 is: =SOM(XLOOKUP(B3;B6:B10;E6:E10):XLOOKUP(C3;B6:B10;E6:E10))

Hoe werkt dit? XLOOKUP retourneert een bereik, dus wanneer de formule wordt berekend, ziet de formule er zo uit: =SOM($E$7:$E$9). U kunt zelf zien hoe dit werkt door een cel te selecteren met een XLOOKUP-formule die vergelijkbaar is met deze formule en vervolgens Formules > Formules controleren > Formuleevalueren te selecteren en vervolgens Evalueren te selecteren om door de berekening te gaan.

Opmerking: Met dank Microsoft Excel MVP, Bill Jelen,voor het voorstellen van dit voorbeeld.

———————————————————————————

Meer hulp nodig?

U kunt altijd uw vraag stellen aan een expert in de Excel Tech Community of ondersteuning vragen in de Answers-community.

Zie ook

X.VERGELIJKEN-functie

Excel-functies (alfabetisch)

Excel-functies (per categorie)

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Hoe tevreden bent u met de vertaalkwaliteit?

Wat heeft uw ervaring beïnvloed?

Hebt u aanvullende feedback? (Optioneel)

Bedankt voor uw feedback.

×