Symptomen
Stel dat u een multidimensionale OLAP-dimensie (MOLAP) hebt waarvoor de functie Proactieve caching is ingeschakeld in Microsoft SQL Server Analysis Service (SSAS) en dat naar de dimensie wordt verwezen door een kubus met een relationele OLAP-partitie (ROLAP). Wanneer door wijzigingen in de brondatabase proactieve caching wordt geactiveerd voor de dimensie, treedt er een crash op en wordt het volgende foutbericht weergegeven:
Opmerking
Interne fout: er is een onverwachte fout opgetreden (bestand 'bestandsnaam', regelregelnummer, functie 'functienaam').
Oplossing
Het probleem is opgelost in de volgende cumulatieve updates voor SQL Server:
Cumulatieve update 8 voor SQL Server 2017
Cumulatieve update 1 voor SQL Server 2016 Service Pack 2
Cumulatieve update 9 voor SQL Server 2016 Service Pack 1
Cumulatieve update 2 voor SQL Server 2014 SP1
Cumulatieve update 6 voor SQL Server 2014
Cumulatieve update 4 voor SQL Server 2012 SP2
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2017
- Meest recente cumulatieve update voor SQL Server 2016
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP2
Tijdelijke oplossing
U kunt dit probleem omzeilen door de hybride OLAP-modus (HOLAP) te gebruiken in plaats van de relationele OLAP-modus (ROLAP) in SSAS 2012.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.