Symptomen
Stel dat u een Always On Availability Group (AG) hebt met alleen een primaire replica (geen secundaire replica's). Na verloop van tijd kunt u het volgende foutbericht tegenkomen:
Fout 9002. Het transactielogboek voor de database is vol vanwege 'AVAILABILITY_REPLICA'.
Wanneer u een back-up van een transactielogboek uitvoert, wordt de fout niet opgelost omdat het logboek niet wordt afgebroken en alle beschikbare ruimte wordt gebruikt.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:
- Cumulatieve update 1 voor SQL Server 2019
- Cumulatieve update 18 voor SQL Server 2017
- Cumulatieve update 10 voor SQL Server 2016 SP2
Over cumulatieve updates voor SQL Server:
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2019
- Meest recente cumulatieve update voor SQL Server 2017
- Meest recente cumulatieve update voor SQL Server 2016
Servicepack-informatie voor SQL Server 2016
Dit probleem is opgelost in het volgende servicepack voor SQL Server:
Over servicepacks voor SQL Server:
Servicepacks zijn cumulatief. Elk nieuw servicepack bevat alle correcties uit vorige servicepacks, samen met nieuwe oplossingen. U wordt aangeraden het nieuwste servicepack en de meest recente cumulatieve update voor dit servicepack toe te passen. U hoeft geen eerdere servicepack te installeren voordat u het nieuwste servicepack installeert. Gebruik tabel 1 in het volgende artikel voor meer informatie over het nieuwste servicepack en de meest recente cumulatieve update.
De versie, editie en update niveau van SQL Server en de onderdelen ervan bepalen
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.