Symptomen
Neem als voorbeeld het volgende scenario:
- U hebt een database waarin het herstelmodel BULK_LOGGED of SIMPLE wordt gebruikt in Microsoft SQL Server 2008, SQL Server 2008 R2, SQL Server 2012 of SQL Server 2014.
- U schakelt de schakeloptie SET XACT_ABORT in.
- U probeert meerdere BULK INSERT-instructies in één gedistribueerde transactie uit te voeren.
In dit scenario kan de instructie BULK INSERT mislukken en wordt het volgende foutbericht weergegeven:
Opmerking
Locatie: pageref.cpp:913
Expressie: IS_OFF (BUF_MINLOGGED, m_buf-bstat>) || pageModifyType != PageModifyType_Contents || GetPagePtr ()->IsTextPage ()
SPID: 56
Proces-id: 2136
Msg 3624, Level 20, State 1, Line 7
Een systeembevestigingscontrole is mislukt. Controleer het foutenlogboek van SQL Server voor meer informatie. Meestal wordt een beweringsfout veroorzaakt door een softwarefout of gegevensbeschadiging. Als u wilt controleren op beschadigde databases, kunt u DBCC CHECKDB uitvoeren. Als u tijdens de installatie hebt afgesproken om dumps naar Microsoft te verzenden, wordt er een minidump naar Microsoft verzonden. Er is mogelijk een update beschikbaar van Microsoft in het nieuwste servicepack of in een QFE van technische ondersteuning.
Msg 0, Level 20, State 0, Line 0
Er is een ernstige fout opgetreden in de huidige opdracht. De resultaten, indien aanwezig, moeten worden genegeerd.
Bovendien kan er een minidumpbestand worden gegenereerd in de logboekmap van SQL Server.
Opmerking: dit probleem treedt meestal op wanneer SQL Server Integration Services (SSIS) wordt gebruikt. MS DTC (Microsoft Distributed Transaction Coordinator) is bijvoorbeeld betrokken om gedistribueerde transacties samen met SET XACT_ABORT ON te starten als de eigenschap TransactionOption op pakketniveau is ingesteld op Vereist.
Oorzaak
Dit probleem treedt op vanwege een fout in SQL Server 2008, SQL Server 2008 R2, SQL Server 2012 of SQL Server 2014.
Oplossing
Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
Cumulatieve update 1 voor SQL Server 2014 /nl-nl/help/2931693
Cumulatieve update 8 voor SQL Server 2012 SP1 /nl-nl/help/2917531
Cumulatieve update 10 voor SQL Server 2008 R2 SP2 /nl-nl/help/2908087
Cumulatieve update 10 voor SQL Server 2008 SP1 /nl-nl/help/2279604
Cumulatieve update 1 voor SQL Server 2008 SP2 /nl-nl/help/2289254
Cumulatieve update 5 voor SQL Server 2008 R2 /nl-nl/help/2438347
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP1
- Laatste cumulatieve update voor SQL Server 2008 R2 SP2
- Laatste cumulatieve update voor SQL Server 2008 SP1
- Meest recente cumulatieve update voor SQL Server 2008 SP2
- Laatste cumulatieve update voor SQL Server 2008 R2
Tijdelijke oplossing
U kunt dit probleem omzeilen door het volledige herstelmodel in te stellen voor de database.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Ga voor meer informatie over de instelling SET XACT_ABORT naar de volgende MSDN-website (Microsoft Developer Network):
Algemene informatie over de instelling 'SET XACT_ABORT' Ga naar de volgende MSDN-website voor meer informatie over bewerkingen die minimaal worden geregistreerd:
Algemene informatie over bewerkingen die minimaal worden geregistreerd Ga naar de volgende MSDN-website voor meer informatie over het handhaven van gegevensintegriteit met behulp van transacties:
Algemene informatie over het handhaven van gegevensintegriteit met behulp van transacties Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:
935897 Er is een incrementeel servicemodel beschikbaar van het SQL Server-team om hotfixes voor gemelde problemen te leveren
Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:
822499 Nieuw naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over software-updateterminologie:
824684 Beschrijving van de standaardterminologie die wordt gebruikt om Microsoft-software-updates te beschrijven