KB2962767 - FIX: De fout 'Kan dubbele sleutel niet invoegen' treedt op wanneer u een tabel bijwerkt met behulp van een bitmapindex die een partitiesleutel bevat in SQL Server

Van toepassing op
SQL Server 2012 Enterprise SQL Server 2012 Developer SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use)

Symptomen

Stel dat u een tabel hebt met niet-unieke indexen in Microsoft SQL Server 2012 of SQL Server 2014. Wanneer u een query uitvoert om de tabel bij te werken met behulp van de bitmapindex die een partitiesleutel bevat, wordt het volgende foutbericht weergegeven:

Opmerking

Msg 2601, Level 14, State 1, Line 1
Het is niet mogelijk om een dubbele sleutelrij met een unieke indexindexnaam< in de objecttabelnaam><>in te voegen. De waarde van de dubbele sleutel is (0, <de waarde>).

Opmerking: De index is geen unieke index en staat duplicaten toe.

Oplossing

Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.

Cumulatieve update 4 voor SQL Server 2014 /nl-nl/help/2999197

Cumulatieve update 2 voor SQL Server 2012 SP2 /nl-nl/help/2983175

Cumulatieve update 11 voor SQL Server 2012 SP1 /nl-nl/help/2975396

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

      

Tijdelijke oplossing

U kunt dit probleem omzeilen door traceringsvlag 8690 in te schakelen om de spoolbewerking uit te schakelen. Deze tijdelijke oplossing kan echter leiden tot een prestatieregressie omdat de spoel is uitgeschakeld.

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.