Symptomen
Stel dat u transactionele replicatie van Microsoft SQL Server 2012 of SQL Server 2014 gebruikt. U probeert abonnementen toe te voegen die @sync\_type zijn opgegeven als 'alleen replicatieondersteuning', 'initialiseren met back-up' of 'initialiseren vanuit lsn' voor publicatie en de publicatie-id groter is dan 99. In deze situatie wordt het volgende foutbericht weergegeven:
Opmerking
Msg 8115, Level 16, State 2, Procedure sp_MSsetupnosyncsubscriptionwithlsn, Line 237
Rekenkundige overloopfout bij het converteren van expressie naar gegevenstype nvarchar.
Oplossing
Informatie over cumulatieve update
Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.
- Cumulatieve update 1 voor SQL Server 2014 SP1
- Cumulatieve update 5 voor SQL Server 2012 SP2
- Cumulatieve update 6 voor SQL Server 2014
- Cumulatieve update 14 voor SQL Server 2012 SP1
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2014 SP1
- Laatste cumulatieve update voor SQL Server 2012 SP2
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP1
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.