KB3016165 - FIX: Er treedt een rekenkundige overloopfout op wanneer u handmatig geïnitialiseerde abonnementen toevoegt voor publicatie in SQL Server

Van toepassing op
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Standard SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use)

Symptomen

Stel dat u transactionele replicatie van Microsoft SQL Server 2012 of SQL Server 2014 gebruikt. U probeert abonnementen toe te voegen die @sync\_type zijn opgegeven als 'alleen replicatieondersteuning', 'initialiseren met back-up' of 'initialiseren vanuit lsn' voor publicatie en de publicatie-id groter is dan 99. In deze situatie wordt het volgende foutbericht weergegeven:

Opmerking

Msg 8115, Level 16, State 2, Procedure sp_MSsetupnosyncsubscriptionwithlsn, Line 237
Rekenkundige overloopfout bij het converteren van expressie naar gegevenstype nvarchar.

Oplossing

Informatie over cumulatieve update

Het probleem werd voor het eerst opgelost in de volgende cumulatieve update van SQL Server.

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

      

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.