KB4010990 - FIX: SQL Server wordt gestopt wanneer u patches installeert op een exemplaar van SQL Server dat veel databases bevat

Van toepassing op
SQL Server 2014 Service Pack 2 - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise Core - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2016 Developer - duplicate (do not use) SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use) SQL Server 2016 Standard - duplicate (do not use) SQL Server 2016 Service Pack 1

Symptomen

Wanneer u patches installeert op een exemplaar van Microsoft SQL Server 2014 of 2016 dat een groot aantal databases bevat, kan de installatie mislukken. Mogelijk wordt het volgende foutbericht weergegeven:


Microsoft.SqlServer.Configuration.SqlEngine.SqlEngineConfigException: Failed to shutdown the instance with process ID xxxx. Error encountered: 
Microsoft.SqlServer.Configuration.Sco.ScoException: The service cannot accept control messages at this time.

Bovendien behoudt het SQL Server-exemplaar de status Gestopt.

Oorzaak

Dit probleem treedt op omdat tijdens de installatie van de patches voor SQL Server wordt geprobeerd de SQL Server-service opnieuw te starten om de patch toe te passen. Als het echter lang duurt voordat de SQL Server wordt beëindigd, mislukt de installatie.

      

Notitie Als er veel databases zijn (zoals 300~1000 of meer) en SQL Server is geconfigureerd voor het gebruik van grote hoeveelheden geheugen (zoals 20 GB~2 TB), kan het even duren voordat elke database is afgesloten bij SQL Server en kan de patchinstallatie mislukken omdat het erg lang duurt voordat SQL Server zichzelf afsluit.

Oplossing

Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:

Cumulatieve update 5 voor SQL Server 2016 RTM

Cumulatieve update 2 voor SQL Server 2016 SP1

Cumulatieve update 4 voor SQL Server 2014 Service Pack 2

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en beveiligingspatches uit de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

Meest recente cumulatieve update voor SQL Server 2016

Latest cumulatieve updates voor SQL Server 201

         Notitie Nadat u deze oplossing hebt toegepast, wacht het programma voor het instellen van patches tot SQL Server na maximaal 30 minuten stopt. Als meer dan 30 minuten van SQL Server nog steeds stopt, kan de patchinstallatie nog steeds mislukken.

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.

Verwijzing

Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.