Symptomen
Als u de PolyBase SQL Server-connector gebruikt om een externe tabel te maken waarin de naam van de externe database een punt ( . ) bevat, wordt een foutbericht van de volgende strekking weergegeven:
105082; Algemene ODBC-fout: [Microsoft][ODBC-stuurprogramma 17 voor SQL Server][SQL Server]Kan server 'xxxxx' niet vinden in sys.servers. Controleer of de juiste servernaam is opgegeven. Voer zo nodig de opgeslagen procedure uit sp_addlinkedserver om de server toe te voegen aan sys.servers.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve update voor SQL Server:
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en beveiligingspatches uit de vorige build. We raden u aan de nieuwste build voor uw versie van SQL Server te installeren:
Meest recente cumulatieve update voor SQL Server 2019
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.