KB3061218 - FIX: Fout 'Kan 8 bytes van bestand niet lezen met behulp van caching' wanneer u een SSIS 2014-pakket uitvoert

Van toepassing op
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Business Intelligence - duplicate (do not use)

Symptomen

Stel dat u een cacheverbindingsbeheer configureert voor het gebruik van een cachebestand in een Microsoft SQL Server 2014 Integration Services (SSIS 2014)-pakket. Vervolgens configureert u twee of meer gelijktijdige opzoektransformaties die dezelfde cacheverbindingsbeheerder gebruiken. Wanneer u het SSIS-pakket uitvoert, wordt een foutbericht van de volgende strekking weergegeven:

Opmerking

<De opzoektaak> is mislukt in de voorbereidende fase en heeft foutcode geretourneerd 0xC020930C.
Kan de cache niet laden vanuit het bestand '<Cachebestandspad>'.
De RAW-adapter probeerde 8 bytes te lezen in het invoerbestand voor kolom '<Join Key>' met <herkomst-ID,> maar er is een fout opgetreden. De fout die wordt geretourneerd door het besturingssysteem, had eerder moeten zijn gerapporteerd.
Kan geen 8 bytes lezen uit het bestand '<Cachebestandspad>'. De oorzaak van de storing had eerder moeten worden gemeld.

      

Oplossing

Het probleem is voor het eerst opgelost in de volgende cumulatieve update voor SQL Server:

Cumulatieve update 1 voor SQL Server 2014 Service Pack 1 (SP1)

Informatie over cumulatieve updates voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:

      

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.