Symptomen
Stel dat u een ALTER INDEX-opdracht voor opnieuw opbouwen uitvoert met de optie RESUMABLE=ON in Microsoft SQL Server. Als dit een gefilterde index is met een voorwaarde zoals kolom IS NULL, kan de bewerking mislukken en een beweringsfout retourneren. Bovendien kan er een crashdumpbestand worden gegenereerd.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve update voor SQL Server:
Opmerking: Afhankelijk van de indexstructuur en de gefilterde indexvoorwaarde kan de SQL Server-versie de hervatbare indexopbouw niet veilig voltooien. Nadat de CU is geïnstalleerd, genereert de SQL Server de bewerking niet langer een bevestiging en dump, maar wordt de bewerking netjes beëindigd en wordt een nieuwe foutcode 10675 geretourneerd.
'Interne queryprocessorfout: de queryprocessor kan geen queryplan produceren. De optie HERVATBAAR wordt niet ondersteund voor deze indexbuild. Verwijder de optie HERVATBAAR en voer de instructie opnieuw uit.'
Over cumulatieve updates voor SQL Server:
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.