Symptomen
Stel dat u Oracle-publicatie configureert in Microsoft SQL Server 2008 R2, SQL Server 2012, SQL Server 2014, SQL Server 2016. Wanneer HREPL_SEQ de INT-capaciteit van 2147483647 overschrijdt, mislukt de Log Reader-agent. Bovendien wordt het volgende foutbericht weergegeven:
Opmerking
ORA-01455: converteren van kolomoverloop integer datatype (Bron: MSSQL_REPL_ORACLE, Error number: 1455)
Hulp vragen: http://help/1455
Heterogene Logreader heeft een fout aangetroffen in de aanroep van LoadReplCmds bij het verwerken van status 'FETCH'. (Bron: MSSQL_REPL, Foutnummer: MSSQL_REPL22037)
Hulp vragen: http://help/MSSQL_REPL22037
Oplossing
Het probleem werd voor het eerst opgelost in de volgende cumulatieve updates van SQL Server.
- Cumulatieve update 1 voor SQL Server 2016
- Cumulatieve update 1 voor SQL Server 2012 SP2
- Cumulatieve update 2 voor SQL Server 2014
- Cumulatieve update 10 voor SQL Server 2012 SP1
- Cumulatieve update 12 voor SQL Server 2008 R2 SP2
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
- Meest recente cumulatieve update voor SQL Server 2016
- Laatste cumulatieve update voor SQL Server 2012 SP2
- Meest recente cumulatieve update voor SQL Server 2014
- Laatste cumulatieve update voor SQL Server 2012 SP1
- Laatste cumulatieve update voor SQL Server 2008 R2 SP2
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.