KB2407088 - FIX: De fout 'Sys.ArgumentNullException' treedt op wanneer u een analyserapport opent in een webonderdeel Rapportviewer als u de geïntegreerde modus van SharePoint gebruikt in SQL Server 2008 R2 Reporting Services

Van toepassing op
SQL Server 2008 R2 Visual Studio 2010

Microsoft distribueert Microsoft SQL Server 2008 R2-oplossingen als één downloadbaar bestand. Omdat de oplossingen cumulatief zijn, bevat elke nieuwe release alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige release voor SQL Server 2008 R2.

Symptomen

Neem als voorbeeld het volgende scenario:

  • U voert Microsoft SQL Server 2008 R2 Reporting Services (SSRS) uit in de modus SharePoint Integrated.
  • U integreert een Microsoft SharePoint 2010-site met SSRS 2008 R2.
  • U voert de SharePoint-site uit in de foutopsporingsmodus.
  • U implementeert een rapport naar een documentbibliotheek op de SharePoint-site. Het rapport bevat een drillthrough-rapport.
  • U voegt een webonderdeel Rapportviewer toe aan een SharePoint-pagina om het rapport weer te geven.
  • U klikt op de koppeling voor de analyseprocedure om het analyserapport te openen op de SharePoint-pagina.

In dit geval wordt een foutbericht van de volgende strekking weergegeven:

Opmerking

Bericht: Sys.ArgumentNullException: waarde kan niet null zijn.
Parameternaam: panelsCreated[6]
Lijn: 129

Teken: 12

Code: 0

URI: http://ServerName/ScriptResource.axd?d=eIta46jBcyLp_5IiiP-xPYuM8iTgFWIJYJ1hdQQhytwzGZrxHUy3xfhvGgvjnG17BofUwEtaQ7Yik54n3MpmW77MX1gjt2yj-Zgalo8nheYxZrca6zgrx0VoNFUyBrAw0&t=ffffffffec2d9970

Opmerking: dit probleem treedt meestal op wanneer u de geïntegreerde modus van SharePoint gebruikt. Bovendien kan dit probleem ook optreden wanneer u de systeemeigen modus gebruikt als aan de volgende voorwaarden is voldaan:

  • U gebruikt het besturingselement WebForms ReportViewer dat samen met Visual Studio 2010 is uitgebracht op een webpagina.
  • U stelt de eigenschap ShowToolbar van het besturingselement in op Onwaar.
  • U voert de website uit in de foutopsporingsmodus.
  • U configureert bepaalde elementen van de pagina zodat deze naar de gebeurtenis PageRequestManager.pageLoaded luisteren.

Oorzaak

Dit probleem treedt op omdat het besturingselement ReportViewer het rapport niet juist genereert.

Oplossing

Informatie over cumulatieve updates

SQL Server 2008 R2

De oplossing voor dit probleem is voor het eerst uitgebracht in cumulatieve update 4. Klik voor meer informatie over het verkrijgen van dit cumulatieve updatepakket voor SQL Server 2008 R2 op het volgende artikelnummer in de Microsoft Knowledge Base:

2345451 Cumulatief updatepakket 4 voor SQL Server 2008 R2 Opmerking Omdat de builds cumulatief zijn, bevat elke nieuwe fixversie alle hotfixes en alle beveiligingspatches die aanwezig waren bij de vorige herstelrelease van SQL Server 2008 R2. Het is raadzaam om de meest recente fixversie toe te passen die deze hotfix bevat. Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:

981356 De SQL Server 2008 R2-builds die zijn uitgebracht nadat SQL Server 2008 R2 is uitgebracht

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.

Tijdelijke oplossing

U kunt dit probleem omzeilen door de foutopsporingsmodus in het Web.config bestand van de SharePoint-site uit te schakelen. Hiervoor stelt u de foutopsporingseigenschap van het compilatielabel in het Web.config bestand in op onwaar.

Hieronder volgt een voorbeeld van tekst die de debug-eigenschap van de compilatietag op false aantoont:

<?xml version="1.0" encoding="utf-8"?>
<<configuration>

...

  <system.web>

...
<compilation defaultLanguage="c#" debug="false" ... />

Meer informatie

Voor meer informatie over het Incremental Servicing Model voor SQL Server klikt u op het volgende artikelnummer in de Microsoft Knowledge Base:

935897 Het SQL Server-team heeft een incrementeel onderhoudsmodel om hotfixes te leveren voor gemelde problemen

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over het naamgevingsschema voor SQL Server-updates:

822499 Nieuw naamgevingsschema voor software-updatepakketten voor Microsoft SQL Server Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie over de terminologie van software-updates:

824684 Beschrijving van de standaardterminologie die wordt gebruikt om Microsoft-software-updates te beschrijven