FIX: Fout 'De gebruiker heeft geen machtigingen of de object-id is ongeldig' wanneer u een lid publiceert in MDS

Van toepassing op
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use)

Symptomen

Stel dat u de MDS-invoegtoepassing Microsoft SQL Server 2014 voor Excel gebruikt om verbinding te maken met een Master Data Services-opslagplaats. Wanneer u een lid publiceert waarvan het codeveld vaste spaties bevat, wordt het volgende foutbericht weergegeven:

Opmerking

De gebruiker heeft geen machtigingen of de object-id is ongeldig.

Opmerking: Dit probleem treedt niet op wanneer u leden toevoegt of bewerkt in de MDS-verkenner.

Oplossing

Informatie over cumulatieve updates

Het probleem is voor het eerst opgelost in de volgende cumulatieve update van SQL Server 2014:

Aanbeveling: Installeer de meest recente cumulatieve update voor SQL Server

Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. U wordt aangeraden de meest recente cumulatieve updates voor SQL Server 2014 te downloaden en te installeren:

      

      

Status

Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.