Symptomen
Stel dat u een TDE-gecodeerde database (Transparent Data Encryption) hebt in een exemplaar van Microsoft SQL Server. Wanneer u het exemplaar van SQL Server opnieuw start, wordt mogelijk een time-outfout voor vergrendeling van de volgende strekking weergegeven:
Opmerking
Databasenaam> opstarten<.
Fout: 1222, ernst: 16, toestand: 55.
Time-outperiode vergrendelingsaanvraag overschreden.
Fout: 9016, ernst: 21, status: 7.
Er is een fout opgetreden tijdens het verwerken van het logboek voor databasenaam<>. De logboekblokkering kan niet worden gedecodeerd.
De database krijgt dan de status verdacht. U kunt de database weer online zetten met behulp van de noodmodus. U zult geen corruptie tegenkomen.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:
Cumulatieve update 2 voor SQL Server 2016 SP1
Cumulatieve update 4 voor SQL Server 2016
Cumulatieve update 3 voor SQL Server 2014 SP2
Cumulatieve update 10 voor SQL Server 2014 SP1
Cumulatieve update 6 voor SQL Server 2012 Service Pack 3
Informatie over cumulatieve updates voor SQL Server
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meest recente cumulatieve update voor SQL Server 2016
Meest recente cumulatieve update voor SQL Server 2014 SP1/SP2
Meest recente cumulatieve update voor SQL Server 2012
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.