Symptomen
Neem als voorbeeld het volgende scenario:
- U hebt een gedistribueerde beschikbaarheidsgroep in SQL Server 2017 of 2019 op Linux geconfigureerd tussen de beschikbaarheidsgroepen (AG's), AG1 en AG2.
- Stel dat AG1 de primaire beschikbaarheidsgroep is met de knooppunten N1, N2 en N3.
- Als u een failover uitvoert van N1 naar N3 in beschikbaarheidsgroep AG1, blijft de synchronisatie steken in een niet-synchrone status en wordt deze nooit gezond. Bovendien kunt u de volgende fout opmerken in het foutenlogboek van N3:
Fout: 41166, Ernst: 16, Status: 9
Er is een fout opgetreden tijdens het wachten op toegang tot de lokale beschikbaarheidsreplica van beschikbaarheidsgroep 'Naam beschikbaarheidsgroep'. De bewerking is SQL OS-fout 2 tegengekomen en is beƫindigd. Controleer of de replica van de lokale beschikbaarheid in de juiste status staat en voer de opdracht nogmaals uit.
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in het gedeelte 'Van toepassing op'.
Oplossing
Dit probleem is opgelost in de volgende cumulatieve updates voor SQL Server:
Over cumulatieve updates voor SQL Server:
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.