Symptomen
Stel dat u verbinding maakt met Microsoft Azure SQL Database versie 12 met behulp van Microsoft SQL Server Management Studio 2014. Wanneer u de optie voor het bijhouden van Wijzigingen bijhouden voor Azure SQL Database inschakelt via het dialoogvenster Database-eigenschappen, wordt er mogelijk een foutbericht weergegeven.
Als u bijvoorbeeld de waarde van de optie voor het bijhouden van Wijzigingen bijhouden wijzigt in Waar in het dialoogvenster Database-eigenschappen van Azure SQL Database en u vervolgens op OK klikt, ziet u een foutbericht van de volgende strekking:
Opmerking
Alter mislukt voor database 'Databasenaam'. (Microsoft.SqlServer.Smo)
Aanvullende informatie:
Er is een uitzondering opgetreden tijdens het uitvoeren van een Transact-SQL-instructie of -batch.
(Microsoft.SqlServer.ConnectionInfo)
STATUS VAN DATABASE WEERGEVEN machtiging geweigerd in database 'master'.
De gebruiker is niet gemachtigd om deze actie uit te voeren. (Microsoft SQL Server, fout: 262)
Oplossing
Dit probleem is voor het eerst opgelost in de volgende cumulatieve update voor SQL Server:
Cumulatieve update 1 voor SQL Server 2014 Service Pack 1
Informatie over cumulatieve updates voor SQL Server
Elke nieuwe cumulatieve update voor SQL Server bevat alle hotfixes en alle beveiligingspatches die deel uitmaakten van de vorige cumulatieve update. Bekijk de meest recente cumulatieve updates voor SQL Server:
Buildversies van SQL Server 2014
Status
Microsoft heeft bevestigd dat dit een probleem is bij de Microsoft-producten die worden vermeld in de sectie Van toepassing op.
Meer informatie
Meer informatie over de terminologie die Microsoft gebruikt om software-updates te beschrijven.