FIX: U kunt niet starten een RemoteApp-toepassing wanneer de naam bevat tekens met accenten

Symptomen

Overweeg het volgende scenario:

  • U publiceert een RemoteApp-toepassing op een Microsoft Forefront Unified Access Gateway (UAG)-trunk.

  • De naam van de RemoteApp-toepassing bevat tekens met accenten en juist op de portal-pagina wordt weergegeven.

  • U probeert de toepassing te starten.


In dit scenario wordt het volgende foutbericht weergegeven:

RemoteApp

Deze RDP-bestand is beschadigd. De RAS-verbinding kan niet worden gestart.


Bovendien zult u merken dat het dialoogvenster RemoteApp-naam van de toepassing als nietszeggende tekens weergegeven.

Opmerking Ā Waarvan de naam alleen ASCII-tekens gebruiken toepassingen starten zonder problemen.

Oorzaak

Dit probleem treedt op omdat de tekens met accenten worden niet correct gecodeerd in de stoom RDP-gegevens. Dit zorgt ervoor dat de client van het bestand beschadigd is.

Oplossing

Dit probleem is opgelost in updatepakket 1 voor Forefront Unified Access Gateway 2010 Service Pack 4.

Tijdelijke oplossing

De naam van de RemoteApp-toepassing wijzigen zodat deze alleen ASCII-tekens gebruikt om dit probleem te omzeilen, en de toepassing vervolgens opnieuw te publiceren. U moet deze wijziging aanbrengen in RemoteApp-beheer, en een nieuw TSPUB-bestand moet worden geƫxporteerd UAG kunt.

Status

Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Referenties

Meer informatie over de terminologie die door Microsoft wordt gebruikt om softwareupdates te beschrijven.

Meer hulp nodig?

Uw vaardigheden uitbreiden
Training verkennen
Als eerste nieuwe functies krijgen
Deelnemen aan Microsoft insiders

Was deze informatie nuttig?

Bedankt voor uw feedback.

Hartelijk dank voor uw feedback! Het lijkt ons een goed idee om u in contact te brengen met een van onze Office-ondersteuningsagenten.

×