Van toepassing op
Windows 7 Service Pack 1 Windows 7 Enterprise Windows 7 Professional Windows 7 Ultimate Windows 7 Home Premium Windows 7 Starter Windows Server 2008 R2 Service Pack 1 Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 for Itanium-Based Systems Windows Server 2008 R2 Foundation Windows Server 2008 R2 Standard Windows Server 2008 R2 Web Edition

Symptomen

Stel u hebt een printer wordt gedeeld op een afdrukserver waarop Windows Server 2008 R2 wordt uitgevoerd. Wanneer u probeert een bestand afdrukken vanaf een client met Windows 7 met de gedeelde printer kan niet afdrukken. Bovendien wordt de volgende gebeurtenis vastgelegd op de afdrukserver:Opmerking De printerserver kan worden uitgevoerd voor Windows Server 2008, Windows Server 2012 of Windows Server 2012 R2 in plaats daarvan.

Oorzaak

Dit probleem doet zich voor omdat in het register op de client Windows 7 de registersleutel DependentFiles voor het stuurprogramma dat wordt gebruikt door de printer leeg is. De registersleutel DependentFiles wordt onder de volgende registersubsleutel:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\<architecture>\Drivers\Version-3\<drivername>

Oplossing

U kunt dit probleem oplossen door de volgende stappen uit te voeren:

  1. Toepassing van hotfix 3001232.

  2. Toepassing van hotfix 2896881.Opmerking Hoewel de hotfix voor een probleem met Windows Server 2008 R2 wordt verwezen, kan de hotfix ook worden toegepast op Windows 7-computers waarop dit probleem optreedt.

Tijdelijke oplossing

U kunt dit probleem omzeilen, kunt u herstellen, verwijderen en sluit de netwerkprinter.

Status

Microsoft heeft bevestigd dat dit probleem kan optreden in de Microsoft-producten die worden vermeld in de sectie 'Van toepassing op'.

Meer informatie

Voor meer informatie over terminologie voor software-updates klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:

824684 Beschrijving van de standaardterminologie die wordt gebruikt voor het beschrijven van Microsoft-software-updatesAls het probleem zich voordoet, kunt u zien 372 gebeurtenis vastgelegd in het logboek PrintService Admin. Ga hiervoor als volgt te werk:

  1. Open Logboeken en vouw Logboeken toepassingen en Services.

  2. Vouw de map Microsoft .

  3. Vouw de map Windows .

  4. Vouw de map PrintService en klik vervolgens op beheer.

Meer hulp nodig?

Meer opties?

Verken abonnementsvoordelen, blader door trainingscursussen, leer hoe u uw apparaat kunt beveiligen en meer.