Aanmelden met Microsoft
Meld u aan of maak een account.
Hallo,
Selecteer een ander account.
U hebt meerdere accounts
Kies het account waarmee u zich wilt aanmelden.

Symptomen

Wanneer u een van de project-gerelateerde pagina's, zoals Tijdsinvoer, uitgaven invoer, het Communicator-webonderdeel, de project analist en de executive project analist in Business Portal bezoekt, wordt een lang rood foutbericht weergegeven dat lijkt op een van de volgende items:

Foutbericht 1:

Fout: bijlage: maximum aantal pogingen voor de verbinding is overschreden. HRESULT = 0x80004005: niet-opgegeven fout-client: er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag. HRESULT = 0x80004005: niet-opgegeven fout-client: verzenden van het SOAP-bericht mislukt of geen herkenbare reactie ontvangen HRESULT = 0x80004005: niet-gespecificeerde fout-client: niet-gespecificeerde fout-client: niet-gespecificeerde clientfout. HRESULT = 0x80004005: niet-gespecificeerde fout FaultCode = client FaultString = bijlage: maximum opnieuw proberen van de verbinding is overschreden.

Zie de resoluties 6, 7, 8 en 9.

Foutbericht 2:

Connector: time-out van de verbinding. HRESULT = 0x800A1527-client: er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag. HRESULT = 0x800A1527-client: het SOAP-bericht is mislukt of er is geen herkenbare antwoord ontvangen of er is een fout opgetreden met de 0x800A1527-client: onbekende clientfout.

Zie de resoluties 6, 7, 8 en 9.

Foutbericht 3:

Connector: ongeldig certificaat. HRESULT = 0x800A1529-client: er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag. HRESULT = 0x800A1529-client: het SOAP-bericht is mislukt of er is geen herkenbare antwoord ontvangen of er is een fout opgetreden met de 0x800A1529-client: onbekende clientfout. HRESULT=0x800A1529

Zie oplossing 6 en 9

Foutbericht 4:

Connector: niet-gespecificeerde HTTP-fout. HRESULT = 0x800A1518-client: er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag. HRESULT = 0x800A1518-client: het SOAP-bericht is mislukt of er is geen herkenbare antwoord ontvangen of er is een fout opgetreden met de 0x800A1518-client: onbekende clientfout. HRESULT=0x800A1518

Zie de resoluties 6, 7, 8 en 9.

Foutbericht 5:

Verbinding mislukt.: geen bijbehorend autorisatieschema inschakelen op connector. HRESULT = 0x80004005: niet-opgegeven fout-client: er is een onverwachte fout opgetreden tijdens de verwerking van deze aanvraag. HRESULT = 0x80004005: niet-opgegeven fout-client: verzenden van het SOAP-bericht mislukt of geen herkenbare reactie ontvangen HRESULT = 0x80004005: niet-gespecificeerde fout-client: niet-gespecificeerde fout-client: niet-gespecificeerde clientfout. HRESULT = 0x80004005: onbekende fout

Zie resoluties 7 en 9

Foutmelding 6:

Client: het laden van de aanvraag naar SoapReader is mislukt. HRESULT = 0x80070057: de parameter is onjuist. -Client: niet-opgegeven clientfout. HRESULT = 0x80070057: de parameter is onjuist. FaultCode = client.

Zie de resoluties 6, 7, 8 en 9.

Foutmelding 7:

De toepassing kan de systeemdatabase niet openen. [DBNETLIB] [ConnectionOpen (verbinding ()).] SQL Server bestaat niet of toegang geweigerd.De systeembeheerder dient pcConfiguration uit te voeren op de Business Portal Server om dit probleem op te lossen.

Zie oplossingen 5 en 9

Foutmelding 8:

Er is een fout opgetreden. Fout: er is een fout opgetreden bij het openen van de systeem database. (pcconnect)

Zie resoluties 1, 2, 3, 4 en 9.

Foutbericht 9:

De toepassing kan de verbindingsgegevens van de Solomon niet lezen. De systeembeheerder dient pcConfiguration uit te voeren op de Business Portal Server om dit probleem op te lossen

Zie resoluties 1, 2, 3, 4 en 9.

Foutmelding 10:

Kan geen verbinding maken met de systeemdatabase PCConfiguration uitvoeren. Ongeldige gebruikersnaam en wachtwoord.

Zie de resoluties 4 en 9

Foutmelding 11:

Fout: SOAP-client: er is een fout opgetreden tijdens de verwerking van de SOAP-aanvraag. Ongeldig pad voor PCService. asmx opgegeven in ProjectService. wsdlYour systeembeheerder dient pcConfiguration-update web service op de Business Portal Server uit te voeren om dit probleem op te lossen.

Zie resoluties 6 en 9

Oorzaak

De project pagina's kunnen alleen worden gebruikt als IIS (Internet Information Services) een SOAP-aanvraag (Simple Object Access Protocol) kan voorbereiden en verzenden naar het bestand PCService. asmx.  Er zijn diverse zaken die moeten worden ingesteld om dit te laten werken.  Als een of meer van de volgende instellingen niet juist zijn ingesteld, kan het zijn dat de fouten worden weergegeven in de sectie ' Symptomen ':

  1. De aanmeldingsgegevens voor de Microsoft Dynamics SL-database ontbreken of zijn onjuist opgeslagen in het register.

  2. De Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll ontbreekt, is niet geregistreerd of de gebruikers hebben geen machtigingen voor het bestand.

  3. De identiteit van de toepassingsgroep heeft geen machtigingen voor de \SOFTWARE\Microsoft\Business-Portal\PMA\Solomon-registersleutel van HKEY_LOCAL_MACHINE

  4. De CAPICOM. dll ontbreekt, niet geregistreerd, van een onjuiste versie of de gebruikers hebben geen machtigingen voor het bestand.

  5. De server met IIS en de SQL-Server moet kunnen communiceren met behulp van het TCP/IP-protocol

  6. Het pad naar het bestand PCService. asx in de ProjectService. WSDL is onjuist

    1. Het pad moet verwijzen naar de naam van de IIS-server.

    2. Het pad moet het poortnummer bevatten.

    3. Het pad moet een niet-SSL-URL zijn

    4. Als u IIS host headers gebruikt, moet het pad naar de juiste website zijn omgezet.

  7. De IIS-site maakt geen gebruik van Windows-verificatie (NTLM)

  8. De SessionState-variabele in het web. config is onjuist ingesteld

Het foutbericht bevat meestal niet veel informatie over welke van de eerdere items onjuist kunnen zijn.  We raden u aan om alle mogelijke oplossingen te proberen.

Oplossing

Oplossing 1- Het hulpprogramma PCConfiguration uitvoeren

  1. Blader naar het bestand PCConfiguration. exe op de Business Portal-Server en dubbelklik erop om het uit te voeren.  Deze bevindt zich meestal in de map c:\Inetpub\wwwroot\bin of in de C:\Inetpub\wwwroot\wss\VirtualDirectories\80\bin-map.

  2. Vul de volgende vakken in:

    1. SQL Server Name-Voer de naam in van de SQL-Server die als host fungeert voor de Microsoft Dynamics SL-databases.

    2. Systeemdatabase: Typ de naam van de Microsoft Dynamics SL-systeemdatabase

    3. SQL-gebruiker: Typ de naam van een SQL-gebruiker die toegang heeft tot de systeemdatabase.  ' SA ' of ' BusinessPortalUser ' zijn algemene opties.

    4. Wachtwoord-Voer het wachtwoord in voor de gebruiker die is ingevoerd in het vak SQL User

  3. Klik op verbinding testen.  Als er een foutbericht wordt weergegeven, bekijkt u de waarden in stap 2. Opmerking: Met deze knop kan de actie mogelijk niet worden uitgevoerd vanwege een bug 55474.

  4. Klik op register bijwerken.  Het volgende bericht wordt weergegeven: "de gegevens zijn geschreven naar het register"

  5. Sluit het hulpprogramma en probeer de Business Portal-pagina's opnieuw.

Oplossing 2 : Controleer het bestand Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll.

  1. Op de Business Portal-Server start u IIS (Internet Information Services)

  2. Klik met de rechtermuisknop op de website van de Business Portal en selecteer Eigenschappen.

  3. Let op het tabblad Start lijst met de waarde in het vak lokaal pad

  4. Let op het tabblad startpagina op de waarde in de keuzelijst met invoervak toepassingsgroep

  5. Klik op OK om het venster Eigenschappen te sluiten.

  6. Vouw in IIS Manager de optie toepassingen groepen uit.  Klik met de rechtermuisknop op de groep toepassingen die is gevonden in stap 4 en selecteer Eigenschappen.

  7. Onder het tabblad ' identiteit ' ziet u de gebruiker die is opgegeven als de identiteit van de toepassingsgroep.

  8. Klik op OK om het venster Eigenschappen te sluiten.

  9. Van IIS-beheer sluiten

  10. Blader in Windows Verkenner naar de map die wordt gevonden in stap 3.

  11. Schuif in de map bin omlaag en zoek het bestand Microsoft. Solomon. PMA. Security. ImpersonateDLL. dll.

    1. Als dit bestand ontbreekt, moet u mogelijk de Business Portal opnieuw installeren.

  12. Klik met de rechtermuisknop op het bestand en selecteer Eigenschappen.

  13. Zorg ervoor dat de gebruiker in stap 7 onder het tabblad ' Beveiliging ' en ' Lees & Execute '-rechten heeft.

  14. Klik op OK om het venster Eigenschappen te sluiten.

  15. Klik nogmaals met de rechtermuisknop op het bestand en selecteer openen met...

  16. Selecteer het programma selecteren in een lijst.

  17. Klik op Bladeren...

  18. Blader naar de map C:\Windows\System32, zoek het bestand Regsvr32. exe en klik vervolgens op openen.

  19. Klik op OK.  Het volgende bericht wordt weergegeven: "DllRegisterServer in C:\Inetpub\wwwroot\bin\Microsoft.Solomon.Pma.Security.ImpersonateDLL.dll geslaagd."

  20. Probeer opnieuw de Business Portal-pagina's te laden

Oplossing 3 : de registersleutel controleren

  1. Op de Business Portal-Server start u IIS (Internet Information Services)

  2. Klik met de rechtermuisknop op de website van de Business Portal en selecteer Eigenschappen.

  3. Let op het tabblad startpagina op de waarde in de keuzelijst met invoervak toepassingsgroep

  4. Klik op OK om het dialoogvenster Eigenschappen te sluiten en sluit IIS Manager af.

  5. Klik op Start-> run en typ RegEdt32.  De Register-editor wordt geopend.

  6. Ga naar HKEY_LOCAL_MACHINE \SOFTWARE\Microsoft\Business Portal\PMA\Solomon

    1. Als deze registersleutel ontbreekt, raadpleegt u oplossing 1 voor het uitvoeren van het hulpprogramma PCConfiguration

  7. Klik met de rechtermuisknop op "Solomon" en selecteer machtigingen.

  8. Zorg ervoor dat de gebruiker uit stap 3 machtigingen voor lezen heeft.

  9. Probeer opnieuw de Business Portal-pagina's te laden

Zie de Knowledge Base-artikelen 912363 voor meer informatie.

Oplossing 4 : Controleer het bestand CAPICOM. dll

  1. Blader op de Business Portal-Server naar de map C:\Windows\System32

  2. Klik met de rechtermuisknop op het CAPICOM. DLL-bestand en selecteer Eigenschappen.

    1. Als dit bestand ontbreekt, moet u het bestand mogelijk kopiëren vanaf een ander werkstation of de bedrijfs portal opnieuw installeren.

  3. Controleer onder het tabblad versie of de bestandsversie 2.1.0.1 bevat

    1. Als de bestandsversie onjuist is, moet u het bestand mogelijk kopiëren van een ander werkstation of de bedrijfs portal opnieuw installeren.

  4. Controleer onder het tabblad Beveiliging of de DOMAIN\Users-groep de rechten voor dit bestand heeft gelezen en gelezen &.  Zie hetKnowledge Base-artikel 927618

  5. Klik op OK om het dialoogvenster Eigenschappen te sluiten.

  6. Klik nogmaals met de rechtermuisknop op het bestand en selecteer openen met...

  7. Selecteer het programma selecteren in een lijst.

  8. Klik op Bladeren...

  9. Ga naar de map C:\Windows\System32, zoek het bestand Regsvr32. exe en klik vervolgens op openen.

  10. Klik op OK.  Het volgende bericht wordt weergegeven: "DllRegisterServer in C:\WINDOWS\system32\capicom.dll geslaagd."

  11. Probeer opnieuw de Business Portal-pagina's te laden

  12. Als u nog steeds de foutmelding krijgt:

    1. Zie oplossing 1 om het hulpprogramma PCConfiguration opnieuw uit te voeren.

    2. Start IIS opnieuw door te klikken op Start-> run en typ ' IISReset '

    3. Probeer opnieuw de Business Portal-pagina's te laden

Zie de Knowledge Base-artikelen 909144 voor meer informatie.

Oplossing 5- Controleer of de IIS-server en de SQL-Server kunnen communiceren met behulp van het TCP/IP-protocol

  1. Het TCP/IP-protocol moet worden ingeschakeld op de SQL Server en op de server waarop de Business Portal-sites worden gehost.

  2. Zie voor informatie over het controleren van dit artikel Knowledge Base-artikel 954024

Oplossing 6 : Controleer het pad van het bestand PCService. asx in het bestand ProjectService. WSDL

  1. Blader op de Business Portal-Server naar het bestand ProjectService. WSDL.  Dit bevindt zich meestal in de directory C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.

  2. Open het bestand in Kladblok.

  3. Schuif naar de onderkant van het bestand en zoek de tag die begint met ' <SOAP: Address Location = '

  4. Het bestand PCService. asmx moet binnen deze tag een URL bevatten.  Dit kan op de volgende lijken: "HTTP://MachineName: 80/BusinessPortal/Applications/PMA/PCService. asmx" deze URL heeft diverse specifieke vereisten.  Controleer en corrigeer zo nodig de volgende items:

    1. Voor de URL moet de computernaam (bijvoorbeeld BPSERVER) zijn opgegeven.  IP-adressen (zoals 192.168.0.10), localhost of een domeinnaam (zoals BP.contoso.com) werken niet voor SOAP-aanvragen.

      1. U vindt de computernaam door te klikken op Start-> run en CMD te typen.

      2. Typ HOSTNAME en druk op ENTER.

      3. De naam van de computer wordt als resultaat gegeven.  De naam van de computer in de URL moet overeenkomen.

    2. De URL mag geen SSL gebruiken.  De URL moet beginnen met ' http://' en niet ' https://'.

      1. Zie Knowledge Base-artikel 924723 voor instructies over het instellen van een uitzondering op een niet-SSL-verbinding met het bestand PCService. asmx als de ondersteuning voor de website is vereist.

    3. De URL moet worden omgezet in de BusinessPortal-website in IIS

      1. Dit kan een probleem zijn als u hostheaders gebruikt om onderscheid te maken tussen meerdere websites die op dezelfde server worden uitgevoerd.

      2. Zie de Knowledge Base-artikelen 2005711 voor meer informatie.

  5. Test de URL om ervoor te zorgen dat deze geldig is.  U doet dit door de URL te kopiëren en in Internet Explorer op de Business Portal Server te plakken.  Een pagina met de naam ' PCServices ' moet worden geopend.  Als er in plaats van een SharePoint-fout een foutbericht wordt weergegeven of een ' pagina kan niet worden weergegeven ' wordt weergegeven, controleert u de items in stap 4 opnieuw.

  6. Nu het bestand ProjectService. WSDL een geldige URL heeft, kunt u de Business Portal-pagina's opnieuw proberen

Zie het Knowledge Base-artikel 892356 of Knowledge base-artikel 897024 voor meer informatie.

Resolutie 7 -de verificatiemethode controleren in IIS

  1. Op de Business Portal-Server start u IIS (Internet Information Services)

  2. Klik met de rechtermuisknop op de website van de Business Portal en selecteer Eigenschappen.

  3. Ga naar het tabblad Directory-beveiliging en klik in de sectie authenticatie en toegangsbeheer op bewerken...

  4. Zorg ervoor dat geïntegreerde Windows-verificatie is ingeschakeld

  5. Zorg ervoor dat u ' anonieme toegang inschakelen ', ' Digest Authentication for Windows Domain servers ' en ' .NET Passport Authentication ' niet hebt ingeschakeld.

  6. Basisverificatie moet niet worden ingeschakeld. Dit kan echter geen probleem veroorzaken als dit is ingeschakeld

  7. Klik op OK en klik vervolgens nogmaals op OK om het dialoogvenster Eigenschappen te sluiten.

  8. Van IIS-beheer sluiten

  9. Start IIS opnieuw door te klikken op Start-> run en typ ' IISReset '

  10. Probeer opnieuw de Business Portal-pagina's

Oplossing 8 -Controleer de sessionState-variabele in het bestand Web. config

  1. Op de Business Portal-Server start u IIS (Internet Information Services)

  2. Klik met de rechtermuisknop op de website van de Business Portal en selecteer Eigenschappen.

  3. Let op het tabblad Start lijst met de waarde in het vak lokaal pad

  4. Klik op OK om het dialoogvenster Eigenschappen te sluiten en sluit IIS Manager af.

  5. Ga naar de map die wordt gevonden in stap 3 en zoek het bestand Web. config.

  6. Maak een back-upkopie van het bestand Web. config

  7. Het bestand Web. config openen in Kladblok

  8. De tag zoeken die begint met ' <sessionState '

  9. U kunt de hele tag vervangen door ' <sessionState-modus = "InProc"/> "

  10. Sla het bestand op en sluit Kladblok.

  11. Start IIS opnieuw door te klikken op Start-> run en typ ' IISReset '

  12. Probeer opnieuw de Business Portal-pagina's te laden

 Oplossing 9 -Voer het PCConnectDebug-script uit en dien de resultaten in voor ondersteuning. 

  1. Download B2004933_pcConnectDebug. zip

  2. Het bestand uitpakken op de Business Portal-Server

  3. Kopieer het bestand pcConnectDebug. asp naar de map C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.

  4. Open Internet Explorer op de Business Portal-Server en meld u aan bij Business Portal

  5. Klik op de webpagina projecten

  6. Plak de volgende URL om de PCConnectDebug-pagina te openen: http://servernaam:poort/BusinessPortal/Applications/PMA/pcconnectdebug.asp vervangt de naam van de server door de naam van de server met de naam van de server.  Vervang de "poort" door het poortnummer waarop de website wordt uitgevoerd.

  7. Als u wilt doorgaan, klikt u op OK om door te gaan.  Klik op OK.

  8. Er verschijnt een webpagina die begint met ' bezig met beginnen met debug... '.   Klik in Internet Explorer op bestand-> opslaan als... en sla de pagina op in een bestand.

    1. Waarschuwing: afhankelijk van de manier waarop de debug is bereikt, kan de zoekresultaten een wachtwoord bevatten met leesbare tekst.  U kunt het bestand in Kladblok ook bewerken en het werkelijke wachtwoord vervangen door het woord ' thePassword ' voordat u het bestand verzendt ter ondersteuning.

  9. Stuur dit bestand naar Microsoft Customer Support Services voor verdere analyse.

  10. Wanneer het probleem is opgelost, verwijdert u het bestand pcConnectDebug. asp in de directory C:\Program Files\Microsoft Dynamics\Business Portal\Applications\PMA.

Meer hulp nodig?

Meer opties?

Verken abonnementsvoordelen, blader door trainingscursussen, leer hoe u uw apparaat kunt beveiligen en meer.

Community's helpen u vragen te stellen en te beantwoorden, feedback te geven en te leren van experts met uitgebreide kennis.

Was deze informatie nuttig?

Hoe tevreden bent u met de taalkwaliteit?
Wat heeft uw ervaring beïnvloed?
Als u op Verzenden klikt, wordt uw feedback gebruikt om producten en services van Microsoft te verbeteren. Uw IT-beheerder kan deze gegevens verzamelen. Privacyverklaring.

Hartelijk dank voor uw feedback.

×