Aby uniemożliwić innym użytkownikom przypadkowe lub celowe zmodyfikowanie, przeniesienie lub usunięcie danych w arkuszu, możesz zablokować komórki w arkuszu programu Excel, a następnie zabezpieczyć arkusz hasłem. Załóżmy, że jesteś właścicielem arkusza zawierającego raport stanu zespołu i chcesz, aby członkowie zespołu dodawali dane tylko w konkretnych komórkach i nie mogli modyfikować innych elementów. Dzięki chronieniu arkusza możesz sprawić, że tylko konkretne części arkusza będą mogły być edytowane, a użytkownicy nie będą mogli edytować danych w żadnym innym obszarze arkusza.
Przestroga
Limit długości haseł w programie Excel dla komputerów Mac wynosi 15 znaków. Nie można otworzyć skoroszytu lub dokumentu, który został zabezpieczony hasłem przekraczającym ten limit w programie Excel lub Word dla systemu Windows. Jeśli chcesz otworzyć plik w pakiecie Office dla komputerów Mac, poproś jego autora korzystającego z systemu Windows o dostosowanie długości hasła. Ochrony elementów arkusza i skoroszytu nie należy mylić z zabezpieczeniami haseł na poziomie skoroszytu. Ochrona elementów nie chroni skoroszytu przed użytkownikami mającymi złe zamiary. W celu zapewnienia dodatkowej warstwy zabezpieczeń należy chronić cały plik skoroszytu za pomocą hasła.
Chronienie elementów arkusza
Ochrona arkusza jest procesem dwuetapowym: najpierw należy odblokować komórki, które mogą być edytowane przez innych użytkowników, a następnie włączyć ochronę arkusza za pomocą hasła lub bez użycia hasła.
Otwórz arkusz, który chcesz chronić.
Kliknij pozycję Przejrzyj>chroń arkusz.
Na liście Zezwalaj użytkownikom tego arkusza na zaznacz te elementy, które użytkownicy będą mogli zmieniać.
Opcja Umożliwia użytkownikom Zaznaczanie zablokowanych komórek Przenoszenie wskaźnika do komórek, dla których zaznaczono pole wyboru Zablokuj na karcie Ochrona w oknie dialogowym Formatowanie komórek. Zaznaczanie zablokowanych komórek jest domyślnie dozwolone. Zaznaczanie odblokowanych komórek Przenoszenie wskaźnika do komórek, dla których wyczyszczono pole wyboru Zablokuj na karcie Ochrona w oknie dialogowym Formatowanie komórek. Zaznaczanie odblokowanych komórek jest domyślnie dozwolone, a użytkownicy mogą przechodzić między odblokowanymi komórkami chronionego arkusza, naciskając klawisz TAB. Formatowanie komórek Zmienianie jakichkolwiek opcji w oknach dialogowych Formatowanie komórek i Formatowanie warunkowe. Jeśli przed włączeniem ochrony arkusza zastosowano formatowanie warunkowe, formatowanie komórek będzie nadal ulegać zmianie, gdy użytkownik wprowadzi wartość pasującą do innego zdefiniowanego warunku. Formatowanie kolumn Używanie dowolnych poleceń formatowania kolumn, w tym zmienianie szerokości kolumn i ukrywanie kolumn (karta Narzędzia główne, grupa Komórki, przycisk Formatuj). Formatowanie wierszy Używanie dowolnych poleceń formatowania wierszy, w tym zmienianie wysokości wierszy i ukrywanie wierszy (karta Narzędzia główne, grupa Komórki, przycisk Formatuj). Wstawianie kolumn Wstawianie kolumn. Wstawianie wierszy Wstawianie wierszy. Wstawianie hiperłączy Wstawianie nowych hiperłączy, nawet w niezablokowanych komórkach. Usuwanie kolumn Usuwanie kolumn.
Uwaga: Jeśli polecenie usuwania kolumn jest chronione, a wstawianie kolumn nie jest chronione, użytkownik może wstawiać kolumny, ale nie może ich usuwać.Usuwanie wierszy Usuwanie wierszy.
Uwaga: Jeśli polecenie Usuwanie wierszy jest chronione, a polecenie Wstawianie wierszy nie jest chronione, użytkownik może wstawiać wiersze, ale nie może ich usuwać.Sortuj Użyj dowolnych poleceń, aby posortować dane.
Uwaga: Bez względu na ustawienie tej opcji użytkownicy nie mogą sortować zakresów zawierających zablokowane komórki w chronionym arkuszu.Filtr Do filtrowania danych używaj dowolnych poleceń. Używanie raportów w formie tabeli przestawnej Formatowanie, zmienianie układu, odświeżanie lub innego rodzaju modyfikowanie raportów w formie tabel przestawnych lub tworzenie nowych raportów. Edytowanie obiektów Wykonywanie jakiejkolwiek z poniższych czynności: - Wprowadzanie zmian w obiektach graficznych, takich jak mapy, wykresy osadzone, kształty, pola tekstowe i kontrolki, o ile nie zostały one odblokowane przed włączeniem ochrony arkusza. Jeśli na przykład arkusz zawiera przycisk uruchamiający makro, przycisk można kliknąć, aby uruchomić makro, ale nie można go usunąć.
- Dokonywanie zmian, takich jak formatowanie, w wykresach osadzonych. Wykres będzie nadal aktualizowany po zmianie danych źródłowych.
- Dodawanie lub edytowanie komentarzy.
Edytowanie scenariuszy Wyświetlanie scenariuszy ukrytych przez użytkownika, wprowadzanie zmian w scenariuszach, których modyfikowanie jest zabronione, oraz usuwanie takich scenariuszy. Użytkownicy mogą zmieniać wartości w komórkach, które nie są chronione, oraz dodawać nowe scenariusze. Opcjonalnie — wprowadź hasło arkusza, a następnie potwierdź je w obszarze Weryfikuj.
Uwaga
Hasło jest opcjonalne. Jeśli go nie wpiszesz, każdy użytkownik będzie mógł wyłączyć ochronę arkusza i zmienić chronione elementy. Jeśli decydujesz się na hasło, dopilnuj, aby było łatwe do zapamiętania lub zapisz je i schowaj w bezpiecznym miejscu. Jeśli utracisz hasło, stracisz dostęp do chronionych części notesu.
Wybierz przycisk OK.
Jak sprawdzić, czy arkusz jest chroniony?
Po włączeniu ochrony arkusza opcja Chroń arkusz na wstążce jest zmieniana w opcję Nie chroń arkusza.
Wyłączanie ochrony arkusza programu Excel
- Zaznacz chroniony arkusz.
- Na karcie Recenzja kliknij pozycję Nie chroń arkusza.
- Jeśli zostanie wyświetlony monit, wprowadź hasło chronionego arkusza.
Po wyłączeniu ochrony arkusza możesz odblokować grafikę, obiekty i formuły. Zobacz kolejne sekcje, aby uzyskać więcej informacji.
Odblokuj inne elementy
Po wyłączeniu ochrony arkusza możesz odblokować grafikę, obiekty, zakresy i formuły. Zobacz poniższą sekcję, aby uzyskać więcej informacji.
| Aby | Czynność |
|---|---|
| Odblokuj wszelkie komórki, które użytkownicy będą mogli modyfikować | Zaznacz każdą komórkę lub zakres. W menu Format kliknij polecenie Komórki, kliknij kartę Ochrona , a następnie wyczyść pole wyboru Zablokowane . |
| odblokowywanie dowolnej grafiki, która może być zmieniana przez użytkowników | Zaznacz grafikę, a następnie w menu Format kliknij polecenie odpowiadające typowi grafiki, który chcesz odblokować: Kształt, Tekst lub Obraz. W okienku nawigacji kliknij pozycję Właściwości, a następnie wyczyść pole wyboru Blokada . |
| Odblokowywanie dowolnego obiektu lub formantu, który powinien być modyfikowany przez użytkowników | Zaznacz obiekt lub kontrolkę, a następnie w menu Format kliknij polecenie Formatuj obiekt lub kontrolkę. Kliknij kartę Ochrona , a następnie wyczyść pole wyboru Zablokowane . Wyczyść pole wyboru Zablokuj tekst , jeśli istnieje. |
| Ukryj formuły, które nie mają być widoczne dla użytkowników | Zaznacz komórki zawierające formuły. W menu Format kliknij polecenie Komórki, kliknij kartę Ochrona , a następnie zaznacz pole wyboru Ukryte . |
Masz pytanie dotyczące konkretnej kwestii?
Zadaj pytanie na forum społeczności programu Excel
Pomoc w ulepszaniu programu Excel
Jeśli chcesz poprosić o funkcję, wyślij swoją opinię, aby pomóc określić priorytety nowych funkcji w przyszłych aktualizacjach. Aby uzyskać więcej informacji, zobacz Jak mogę przekaż opinię na temat platformy Microsoft 365.