Błąd #REF! jest wyświetlany, gdy formuła odwołuje się do nieprawidłowej komórki. Najczęściej tak się stanie, gdy zostaną usunięte komórki, do których odwołują się formuły, lub zostanie do nich wklejona zawartość.

W poniższym przykładzie w kolumnie E jest używana formuła: =SUMA(B2;C2;D2).

Formuła używająca jawnych odwołań do komórek, takich jak =SUMA(B2;C2;D2), może powodować #REF! w przypadku usunięcia kolumny.

Usunięcie kolumny B, C lub D spowodowałoby #REF! . W tym przypadku usuniemy kolumnę C (Sprzedaż 2007), a teraz formuła odczyta formułę =SUMA(B2;#REF!;C2). Jeśli używasz jawnych odwołań do komórek, takich jak ten (gdzie odwołujesz się do każdej komórki osobno, oddzielonych przecinkami) i usuwasz wiersz lub kolumnę, do których prowadzi odwołanie, program Excel nie może go rozpoznać, więc zwraca #REF! . Jest to główny powód, dla którego używanie jawnych odwołań do komórek w funkcjach nie jest zalecane.

Przykład błędu #ADR! spowodowanego przez usunięcie kolumny.

Rozwiązanie

  • W razie przypadkowego usunięcia wierszy lub kolumn możesz od razu kliknąć przycisk Cofnij na pasku narzędzi Szybki dostęp (lub nacisnąć klawisze CTRL+Z), aby je przywrócić.

  • Dopasuj formułę tak, aby używała odwołania do zakresu, a nie do pojedynczych komórek, jak formuła: =SUMA(B2:D2). Teraz możesz usunąć dowolną kolumnę w zakresie funkcji SUMA, a program Excel automatycznie dostosuje formułę. Możesz również użyć formuły: =SUMA(B2:B5) do obliczenia sumy wierszy.

W poniższym przykładzie funkcja =WYSZUKAJ.PIONOWO(A8;A2:D5;5;FAŁSZ) zwróci #REF! ponieważ szuka wartości do zwrócenia z kolumny 5, ale zakres odwołania to A:D, który wynosi tylko 4 kolumny.

Przykład formuły WYSZUKAJ.PIONOWO z niepoprawnym zakresem.  Formuła to =WYSZUKAJ.PIONOWO(A8;A2:D5;5;FAŁSZ).  W zakresie WYSZUKAJ.PIONOWO nie ma piątej kolumny, więc 5 powoduje #REF! .

Rozwiązanie

Dostosuj zakres, powiększając go, lub zmniejsz wartość odnośnika kolumny, aby był zgodny z zakresem odwołania. =WYSZUKAJ.PIONOWO(A8;A2:E5;5;FAŁSZ) będzie prawidłowym zakresem odwołania, tak jak =WYSZUKAJ.PIONOWO(A8;A2:D5;4;FAŁSZ).

W tym przykładzie formuła =INDEKS(B2:E5;5;5) zwraca #REF! ponieważ zakres FUNKCJI INDEKS to 4 wiersze na 4 kolumny, ale formuła prosi o zwrócenie danych z piątego wiersza i piątej kolumny.

Przykład formuły INDEKS z odwołaniem do nieprawidłowego zakresu.  Formuła ma postać: =INDEKS(B2:E5;5;5), ale zakres to tylko 4 wiersze na 4 kolumny.

Rozwiązanie

Dostosuj odwołania wiersza lub kolumny, aby występowały wewnątrz zakresu wyszukiwania funkcji INDEKS. Formuła =INDEKS(B2:E5;4;4) zwróci prawidłowy wynik.

W poniższym przykładzie funkcja ADR.POŚR próbuje odwołać się do zamkniętego skoroszytu, powodując #REF! .

Przykład błędu #ADR! spowodowanego przez odwołanie ADR.POŚR do zamkniętego skoroszytu.

Rozwiązanie

Otwórz skoroszyt, do którego prowadzi odwołanie. Ten sam błąd wystąpi, jeśli odwołujesz się do zamkniętego skoroszytu z funkcją tablicy dynamicznej.

Odwołania strukturalne do nazw tabel i kolumn w połączonych skoroszytach nie są obsługiwane.

Odwołania obliczeniowe do połączonych skoroszytów nie są obsługiwane.

Przenoszenie lub usuwanie komórek spowodowało nieprawidłowe odwołanie do komórki lub funkcja zwraca błąd odwołania.

Jeśli użyto linku do łączenia i osadzania obiektów (OLE), który zwraca #REF! , a następnie uruchom program, do których prowadzi połączenie.

Uwaga: OLE to technologia, która umożliwia współdzielenie informacji między programami.

Jeśli użyto tematu dynamicznej wymiany danych (DDE), który zwraca #REF! najpierw sprawdź, czy odwołujesz się do właściwego tematu. Jeśli nadal otrzymujesz #REF! sprawdź ustawienia Centrum zaufania pod kątem zawartości zewnętrznej zgodnie z opisem w sekcji Blokowanie lub odblokowywanie zawartości zewnętrznej w dokumentach pakietu Office.

Uwaga: Dynamiczna wymiana danych (DDE)to ustalony protokół wymiany danych między programami opartymi na systemie Microsoft Windows.

Problemy dotyczące makr

Jeśli makro wprowadzi w arkuszu funkcję odwołującego się do komórki powyżej funkcji, a komórka zawierająca tę funkcję znajduje się w wierszu 1, funkcja zwróci #REF! ponieważ nad wierszem 1 nie ma żadnych komórek. Sprawdź funkcję, aby sprawdzić, czy argument odwołuje się do nieprawidłowej komórki lub zakresu komórek. Może to wymagać edytowania makra w Edytorze Visual Basic (VBE), aby uwzględnić tę sytuację.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności

Poznaj szkolenia >

Uzyskuj nowe funkcje w pierwszej kolejności

Dołącz do niejawnych testerów firmy Microsoft >

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×