Używanie funkcji jako jednego z argumentów w formule, która korzysta z funkcji, nosi nazwę zagnieżdżania. Na przykład zagnieżdżając funkcje ŚREDNIA i SUMA w argumentach funkcji JEŻELI, następująca formuła sumuje zbiór liczb (G2:G5) tylko wtedy, gdy średnia innego zestawu liczb (F2:F5) jest większa niż 50. W przeciwnym razie zwraca 0.

Funkcje zagnieżdżone

Funkcje ŚREDNIA i SUMA są zagnieżdżone w funkcji JEŻELI.

W formule można zagnieździć maksymalnie 64 poziomy funkcji.

  1. Kliknij komórkę, w której chcesz wprowadzić formułę.

  2. Aby rozpocząć formułę od funkcji, kliknij pozycję Wstaw funkcję Obraz przycisku na pasku formuły Obraz przycisku.

    Program Excel wstawi znak równości (=).

  3. W polu Lub wybierz kategorię wybierz pozycję Wszystkie.

    Użytkownik zaznajomiony z kategoriami funkcji może także wybrać kategorię.

    Jeśli użytkownik nie wie, której funkcji użyć, może wpisać pytanie opisujące żądaną funkcję w polu Wyszukaj funkcję (na przykład „dodawanie liczb” zwraca funkcję SUMA).

  4. Aby wprowadzić kolejną funkcję jako argument, wprowadź ją w odpowiednim polu argumentu.

    Elementy formuły wyświetlane w oknie dialogowym Argumenty funkcji odpowiadają funkcji wybranej w poprzednim kroku.

    W przypadku kliknięcia przycisku JEŻELIw oknie dialogowym Argumenty funkcji zostaną wyświetlone argumenty dla funkcji JEŻELI. Aby zagnieździć inną funkcję, możesz ją wprowadzić w polu argumentu. Na przykład funkcję SUMA(G2:G5) można wprowadzić w Value_if_true funkcji JEŻELI.

  5. Wprowadź wszelkie dodatkowe argumenty, które są potrzebne do ukończenia formuły.

    Zamiast wpisywać odwołania do komórek, można także zaznaczyć komórki, na które ma wskazywać odwołanie. Kliknij Obraz przycisku aby zminimalizować okno dialogowe, zaznacz komórki, do których chcesz się odwołać, a następnie kliknij przycisk Obraz przycisku , aby ponownie rozwinąć okno dialogowe.

    Porada: Aby uzyskać więcej informacji o funkcji i jej argumentach, należy kliknąć łącze Pomoc dotycząca tej funkcji.

  6. Po zakończeniu wybierania argumentów dla formuły kliknij przycisk OK.

  1. Kliknij komórkę, w której chcesz wprowadzić formułę.

  2. Aby rozpocząć formułę od funkcji, kliknij pozycję Wstaw funkcję Obraz przycisku na pasku formuły Obraz przycisku.

  3. W oknie dialogowym Wstawianie funkcji w polu Wybierz kategorię wybierz pozycję Wszystkie.

    Użytkownik zaznajomiony z kategoriami funkcji może także wybrać kategorię.

  4. Aby wprowadzić inną funkcję jako argument, wprowadź ją w polu argumentu w Konstruktorze formuł lub bezpośrednio w komórce.

  5. Wprowadź wszelkie dodatkowe argumenty, które są potrzebne do ukończenia formuły.

  6. Po zakończeniu wprowadzania argumentów dla formuły naciśnij klawisz ENTER.

Przykłady

Poniżej przedstawiono przykład użycia zagnieżdżonych funkcji JEŻELI w celu przypisania oceny literowej do numerycznego wyniku testu.

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Wynik

45

90

78

Formuła

Opis

Wynik

'=JEŻELI(A2>89;"A";JEŻELI(A2>79;"B"; JEŻELI(A2>69;"C";JEŻELI(A2>59;"D";"F"))))

Używa zagnieżdżonych warunków JEŻELI w celu przypisania oceny literowej do wyniku w komórce A2.

=JEŻELI(A2>89;"A";JEŻELI(A2>79;"B";JEŻELI(A2>69;"C";JEŻELI(A2>59;"D";"F"))))

'=JEŻELI(A3>89;"A";JEŻELI(A3>79;"B"; JEŻELI(A3>69;"C";JEŻELI(A3>59;"D";"F"))))

Używa zagnieżdżonych warunków JEŻELI w celu przypisania oceny literowej do wyniku w komórce A3.

=JEŻELI(A3>89;"A";JEŻELI(A3>79;"B";JEŻELI(A3>69;"C";JEŻELI(A3>59;"D";"F"))))

'=JEŻELI(A4>89;"A";JEŻELI(A4>79;"B"; JEŻELI(A4>69;"C";JEŻELI(A4>59;"D";"F"))))

Używa zagnieżdżonych warunków JEŻELI w celu przypisania oceny literowej do wyniku w komórce A4.

=JEŻELI(A4>89;"A";JEŻELI(A4>79;"B";JEŻELI(A4>69;"C";JEŻELI(A4>59;"D";"F"))))

Porady: 

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel lub uzyskać pomoc techniczną w społeczności witryny Answers.

Zobacz też

Klip wideo: zagnieżdżone funkcje JEŻELI

Potrzebna dalsza pomoc?

Rozwijaj swoje umiejętności
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów Microsoft Office

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?

Dziękujemy za opinię!

×