KB3018269 — Błąd 912 lub 3417 podczas instalowania dodatku SP1 SQL Server 2014 (kompilacja 12.0.4050.0)

Uwaga: Jeśli masz zainstalowaną wersję 12.0.4050.0 dodatku Service SP1 (KB3018269) dla SQL Server 2014, przed zainstalowaniem tej aktualizacji musisz odinstalować ją ze wszystkich wystąpień instalacji. W tym celu należy skorzystać z apletu Dodaj lub usuń programy w Panelu sterowania. Aby uzyskać więcej informacji, zobacz 3018269 z bazy wiedzy.

Należy pamiętać, że instalacja KB3018269 mogła nastąpić z dowolnego z następujących powodów:

  • Zastosowano aktualizację do istniejącego wystąpienia programu SQL Server 2014.
  • Zainstalowano nowe wystąpienie dodatku SP1 SQL Server 2014 przy użyciu KB3018269 "Slipstream Package" (na przykład SQLServer2014SP1-FullSlipstream-x64-ENU).
  • Zainstalowano dowolny pakiet programu SQL Server 2014 z dodatkiem SP1 Express Edition.

Objawy

Załóżmy, że istnieje wystąpienie SQL Server z włączonym wykazem bazy danych SSISDB w programie Microsoft SQL Server 2014. Podczas próby uaktualnienia do programu SQL Server z dodatkiem Service Pack 1 (SP1) o numerze 12.0.4050.0 są wyświetlane następujące komunikaty o błędach:

Uwaga

Błąd: 912, Ważność: 21, Stan: 2.

Uaktualnianie na poziomie skryptu dla bazy danych "master" nie powiodło się, ponieważ krok uaktualniania "SSIS_hotfix_install.sql" napotkał błąd 3602, stan 251, ważność 25. Jest to poważny błąd, który może zakłócić normalne działanie, przez co baza danych zostanie przełączona w tryb offline. Jeśli wystąpił błąd podczas uaktualniania głównej bazy danych, uniemożliwi to uruchomienie całego wystąpienia programu SQL Server. Należy sprawdzić poprzednie wpisy dziennika błędów pod kątem błędów, podjąć odpowiednie działania naprawcze i ponownie uruchomić bazę danych, aby kroki uaktualniania skryptu zostały wykonane pomyślnie.

        
      

Uwaga

Błąd: 3417, Ważność: 21, Stan: 3.

Nie można odzyskać głównej bazy danych. Nie można uruchomić programu SQL Server. Przywróć wzorzec z pełnej kopii zapasowej, napraw go lub odbuduj. Aby uzyskać więcej informacji na temat odbudowywania głównej bazy danych, zobacz Książki online dotyczące programu SQL Server. Zainicjowano zamknięcie programu SQL Server

Uwaga: wystąpienie jest wtedy w stanie nieprawidłowym i nienadającym się do użytku.

Stan

Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.

Rozwiązanie

Aby rozwiązać ten problem, wykonaj następujące czynności:

  1. Użyj Dodaj lub usuń programy w programie Panel sterowania, aby odinstalować wersję 12.0.4050.0 systemu SQL Server 2014 z dodatkiem SP1 (KB3018269).
  2. Zainstaluj dodatek SP1 dla programu SQL Server 2014 w wersji 12.0.4100.1 (wersja 12.0.4100.1).

Źródła informacji

Aby uzyskać więcej informacji na temat tego problemu, zobacz wydany dodatek Service Pack 1 dla programu SQL Server 2014.