Objawy
Istio proxy fails in SQL Server 2019, as automountServiceAccountToken property is set default to FALSE in Cumulative Update 5 (CU5) for SQL Server 2019.
Stan
Firma Microsoft potwierdziła, że jest to problem dotyczący produktów firmy Microsoft wymienionych w sekcji „Dotyczy”.
Rozwiązanie
Ten problem został rozwiązany w następującej aktualizacji zbiorczej dla programu SQL Server:
Informacje o aktualizacjach zbiorczych programu SQL Server:
Każda nowa aktualizacja zbiorcza programu SQL Server zawiera wszystkie poprawki zabezpieczeń uwzględnione w poprzedniej aktualizacji skumulowanej. Sprawdź najnowsze aktualizacje zbiorcze dla programu SQL Server:
Obejście
Aby obejść ten problem, możesz ręcznie edytować definicję replicaset/statefulset z automountServiceAccountToken jako FALSE, a następnie ponownie uruchomić odpowiednie zasobniki, aby zastosować ustawienia.
Źródła informacji
Dowiedz się więcej o terminologii używanej przez firmę Microsoft do opisywania aktualizacji oprogramowania.