Przejdź do głównej zawartości
Pomoc techniczna
Zaloguj się przy użyciu konta Microsoft
Zaloguj się lub utwórz konto.
Witaj,
Wybierz inne konto.
Masz wiele kont
Wybierz konto, za pomocą którego chcesz się zalogować.

Objawy

Rozważ następujący scenariusz:

  • Internet Information Services (IIS) 7.5 zainstalować na komputerze, na którym jest uruchomiony system Windows 7 lub Windows Server 2008 R2.

  • Host niektóre dokumenty Portable Document Format (PDF) w witrynie sieci Web usług IIS na tym komputerze.

  • Masz komputer kliencki, który ma PDF wtyczki Adobe Reader włączone w przeglądarce sieci Web.

  • Ta przeglądarka sieci Web umożliwia otwieranie jednego z dokumentów PDF, które znajduje się w witrynie sieci Web usług IIS.

W tym scenariuszu nie można otworzyć dokumentu PDF. Ponadto przeglądarka sieci Web może przestać odpowiadać.



Uwaga

  • Nadal można otwierać inne dokumenty PDF w tej witrynie sieci Web usług IIS, gdy występuje ten problem.

  • Ten problem nie wpływa na wszystkie wersje pliku PDF programu Adobe Reader dodatku plug-in.

Przyczyna

Ten problem występuje z powodu zmiany projektu w usługach IIS 7.5.

Podczas próby otwarcia dokumentu PDF w witrynie sieci Web usług IIS, wtyczki Adobe PDF Reader wysyła żądanie zawiera wiele zakresów bajtów do usług IIS 7.5. Jeżeli Unia wielu zakresów bajtów jest zakresem pojedynczy bajt, odpowiedź z usług IIS 7.5 zawiera zakresów bajtów scalone w zakresie pojedynczy bajt (znany również jako żądanie scalone zakres bajtów). Odpowiedź do tego zakresu pojedynczy bajt nie zawiera typu zawartości multipart/byteranges . Jednakże oczekuje multipart/byteranges typu zawartości mają zostać uwzględnione w odpowiedzi na żądanie scalone zakres bajtów. To zachowanie powoduje, że czytnik PDF firmy Adobe dodatek typu plug-in do obsługi odpowiedzi niepoprawnie. W związku z tym nie można otworzyć dokumentu PDF.

Uwaga Typ zawartości multipart/byteranges znajduje się w regularnym wielu zakresów bajtów odpowiedzi.

Rozwiązanie

Aby rozwiązać ten problem, należy zastosować tę poprawkę, na komputerze, na którym działa program IIS 7.5.

Informacje o poprawce

Obsługiwana poprawka jest udostępniana przez firmę Microsoft. Jednak ta poprawka jest przeznaczona tylko do usunięcia problemu opisanego w tym artykule. Zastosuj poprawkę tylko w systemach, w których występuje problem opisany w tym artykule. Ta poprawka może być wciąż w fazie testowania. Jeśli dany system nie jest poważnie narażony na ten problem, firma Microsoft zaleca, aby poczekać na następną aktualizację oprogramowania zawierającą tę poprawkę.

Jeśli poprawka jest dostępna do pobrania, pojawi się sekcja "Poprawka dostępna do pobrania" na początku tego artykułu z bazy wiedzy Knowledge Base. Jeśli nie ma tej sekcji, skontaktuj się z Obsługą i Wsparciem Klienta Microsoft w celu uzyskania poprawki.

Uwaga Jeśli wystąpią dodatkowe błędy lub konieczność rozwiązania problemu, być może trzeba będzie utworzyć osobne zlecenie usługi. Zwykłe koszty obsługi będą zastosowane do dodatkowych pytań i problemów, których nie można rozwiązać przy użyciu określonej poprawki. Aby uzyskać pełną listę numerów telefonów pomocy technicznej i obsługi klienta firmy Microsoft lub utworzyć osobne zlecenie usługi, odwiedź następującą witrynę firmy Microsoft w sieci Web:

Uwaga "Poprawka dostępna do pobrania" zawiera listę języków, dla których dostępna jest poprawka. Jeśli odpowiedni język nie jest widoczny, to dlatego, że poprawka nie jest dostępna dla danego języka.

Wymagania wstępne

Aby zastosować tę poprawkę, zostanie uruchomiony system Windows 7 lub Windows Server 2008 R2.

Wymagania dotyczące ponownego uruchomienia

Po zastosowaniu tej poprawki należy ponownie uruchomić komputer.

Informacje dotyczące zastępowania poprawek

Ta poprawka nie zastępuje wcześniej wydanej poprawki.

Informacje o plikach

Wersja globalna tej poprawki instaluje pliki, których atrybuty wymieniono w poniższych tabelach. Daty i godziny odpowiadające tym plikom są podane w formacie uniwersalnego czasu koordynowanego (UTC, Coordinated Universal Time). Daty i godziny odpowiadające tym plikom na komputerze lokalnym są wyświetlane w formacie czasu lokalnego, wraz z Twoim bieżącym bias czasu letniego (DST). Dodatkowo, daty mogą ulec zmianie podczas wykonywania pewnych operacji na plikach.

Informacje o plikach w systemie Windows 7 i Windows Server 2008 R2


Ważne Poprawki systemu Windows 7 i Windows Server 2008 R2 są zawarte w tych samych opakowaniach. Jednak poprawki na stronie żądanie poprawki są wymienione w obu systemach operacyjnych. Aby zażądać pakietu poprawek, który dotyczy jednej lub obu systemów operacyjnych, wybierz poprawkę, która jest wyświetlana w obszarze "Windows 7/Windows Server 2008 R2" na stronie. Zawsze sprawdzaj w sekcji „Stosuje się do”, do jakiego systemu operacyjnego dotyczy każda z poprawek.

  • Pliki MANIFESTU (.manifest) i pliki MUM (.mum) zainstalowane dla każdego środowiska są wymienione osobno w sekcji "Informacje o dodatkowych plikach dla systemów Windows Server 2008 R2 i Windows 7". Pliki MUM i pliki MANIFESTU oraz skojarzone zabezpieczeń pliki wykazu (.cat), są bardzo ważne dla utrzymania stanu zaktualizowanego składnika. Pliki katalogu zabezpieczeń, których atrybuty nie zostały wymienione, są podpisane za pomocą podpisu cyfrowego firmy Microsoft.

Wszystkie obsługiwane wersje systemu Windows 7 x86

Potrzebujesz dalszej pomocy?

Chcesz uzyskać więcej opcji?

Poznaj korzyści z subskrypcji, przeglądaj kursy szkoleniowe, dowiedz się, jak zabezpieczyć urządzenie i nie tylko.

Społeczności pomagają zadawać i odpowiadać na pytania, przekazywać opinie i słuchać ekspertów z bogatą wiedzą.

Czy te informacje były pomocne?

Jaka jest jakość języka?
Co wpłynęło na Twoje wrażenia?
Jeśli naciśniesz pozycję „Wyślij”, Twoja opinia zostanie użyta do ulepszania produktów i usług firmy Microsoft. Twój administrator IT będzie mógł gromadzić te dane. Oświadczenie o ochronie prywatności.

Dziękujemy za opinię!

×