Importar dados do Excel, Access, sites do SharePoint, SQL Server e outras fontes externas

Aplica-se a
Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2019 Visio Standard 2019 Visio Professional 2016 Visio Standard 2016

Você pode importar e exibir dados rapidamente diretamente em suas formas no Visio. A primeira etapa é conectar-se à fonte de dados e importar dados para o desenho. A segunda etapa é vincular os dados importados às formas.

Etapa 1: importar seus dados

Nesta primeira etapa, use o Assistente para Seletor de Dados para importar seus dados.

Os dados que aparecem na janela Dados Externos são um snapshot dos dados de origem no momento da importação. Você pode atualizar os dados em seu desenho para corresponder às alterações em seus dados de origem. No entanto, você não pode atualizar sua fonte de dados alterando os dados em seu desenho. Consulte Atualizar dados importados.

  1. Na guia Dados, do grupo Dados Externos, clique em Vincular Dados a Formas.

  2. Na primeira página do Assistente para Seletor de Dados, escolha qual dos seguintes tipos de fontes de dados você deseja usar:

    • Pasta de trabalho do Microsoft Excel
    • Banco de dados do Microsoft Access
    • Lista básica do Microsoft SharePoint
    • Banco de dados do Microsoft SQL Server
    • Outra fonte de dados OLEDB ou ODBC
    • Conexão criada anteriormente
  3. Conclua o restante do assistente.

    Observação

    Se você escolher uma opção diferente de uma pasta de trabalho do Excel, banco de dados do Access ou lista do SharePoint na primeira página do assistente, poderá ser temporariamente desviado para o Assistente de Conexão de Dados durante a conclusão do Assistente do Seletor de Dados.

Após clicar em Concluir na última página do Assistente para Conexões de Dados, a janela Dados Externos será exibida com os dados importados mostrados em uma grade.

Existem três métodos para vincular linhas de dados a formas no desenho: você pode vincular linhas a formas existentes uma de cada vez, pode vincular as linhas às formas automaticamente ou pode criar formas a partir dos dados.

Essa abordagem é melhor para desenhos existentes com relativamente poucas formas.

  • Arraste uma linha da Janela de Dados Externos para uma forma no desenho.

    Observação

    Se você não vir a Janela de Dados Externos, vá para a guia Dados e, no grupo Mostrar/Ocultar , marque a caixa de seleção ao lado de Janela de Dados Externos.

    Seus dados aparecem na forma e um ícone de link aparece à esquerda da linha na Janela Dados Externos.
    Arrastar linha para forma

    Observação

    • Você pode vincular uma única linha a várias formas, mas não é possível vincular várias linhas a uma única forma.
    • Para alterar ou aprimorar a aparência das formas e dos dados, confira Aprimorar seus dados com gráficos de dados.
    • Para exibir a janela Dados Externos , no menu Exibir , clique em Janela Dados Externos.

Essa abordagem é melhor para desenhos existentes com um grande número de formas. Isso só funcionará se as formas já contiverem dados que você possa combinar com os dados da fonte de dados.

  1. No menu Dados , clique em Atualizar Tudo e selecione Vincular automaticamente após a atualização estar marcada, se ainda não estiver marcado.
  2. Siga as etapas no Assistente de Vinculação Automática.
    Seus dados aparecerão em suas formas. Para alterar ou aprimorar a aparência das formas e dos dados, confira Aprimorar seus dados com gráficos de dados.

Método 3: Criar formas a partir dos seus dados

Essa abordagem é melhor se o seu desenho ainda não tiver formas e você não precisar usar formas específicas.

  1. Clique em uma forma no painel Formas .
  2. Arraste uma linha ou um conjunto de linhas da janela Dados Externos para um espaço em branco no desenho.
    Uma instância da forma em que você clica aparece para cada linha que você arrasta para o desenho.