Ao consultar dados no Excel, convém usar um valor de entrada - um parâmetro - para especificar algo sobre a consulta. Para fazer isso, crie uma consulta parâmetro no Microsoft Query:
- Os parâmetros são usados na cláusula WHERE da consulta – eles sempre funcionam como um filtro para os dados recuperados.
- Os parâmetros podem solicitar ao usuário um valor de entrada quando a consulta for executada ou atualizada, usar uma constante como valor de entrada ou usar o conteúdo de uma célula especificada como valor de entrada.
- Um parâmetro faz parte da consulta que ele modifica e não pode ser reutilizado em outras consultas.
Observação Se você quiser a outra maneira de criar consultas de parâmetro, consulte Criar uma consulta de parâmetro (Power Query).
Procedimento
Clique em Dados>Obter & Transformar Dados>Obter dados>de outras fontes>no Microsoft Query.
Siga as etapas do Assistente de Consulta. Na tela Assistente de consulta - Concluir , selecione Exibir dados ou editar consulta no Microsoft Query e clique em Concluir. A janela do Microsoft Query é aberta e exibe sua consulta.
Clique em Exibir>SQL. Na caixa de diálogo SQL exibida, encontre a cláusula WHERE – uma linha que começa com a palavra WHERE, geralmente no final do código SQL. Se não houver nenhuma cláusula WHERE, adicione uma digitando WHERE em uma nova linha no final da consulta.
Depois de WHERE, digite o nome do campo, um operador de comparação (=, <, >, LIKE etc.) e um dos seguintes:
- Para um prompt de parâmetro genérico, digite um ponto de interrogação (?). Nenhuma frase útil é exibida no prompt que aparece quando a consulta é executada.
- Para um prompt de parâmetro que ajude as pessoas a fornecer informações válidas, digite uma frase entre colchetes. A frase é exibida no prompt de parâmetro quando a consulta é executada.
- Para um prompt de parâmetro genérico, digite um ponto de interrogação (?). Nenhuma frase útil é exibida no prompt que aparece quando a consulta é executada.
Depois de terminar de adicionar condições com parâmetros à cláusula WHERE, clique em OK para executar a consulta. O Excel solicita que você forneça um valor para cada parâmetro e, em seguida, o Microsoft Query exibe os resultados.
Quando estiver pronto para carregar os dados, feche a janela do Microsoft Query para retornar os resultados ao Excel. A caixa de diálogo Importar Dados é aberta.
Para revisar seus parâmetros, clique em Propriedades. Em seguida, na caixa de diálogo Propriedades da Conexão, na guia Definição , clique em Parâmetros.
A caixa de diálogo Parâmetros exibe os parâmetros usados na consulta. Selecione um parâmetro em Nome do parâmetro para revisar ou alterar Como o valor do parâmetro é obtido. Você pode alterar o prompt de parâmetro, inserir um valor específico ou especificar uma referência de célula.
Clique em OK para salvar suas alterações e fechar a caixa de diálogo Parâmetros e, em seguida, na caixa de diálogo Importar Dados, clique em OK para exibir os resultados da consulta no Excel.
Agora sua pasta de trabalho tem uma consulta de parâmetro. Sempre que você executa a consulta ou atualiza sua conexão de dados, o Excel verifica o parâmetro para concluir a cláusula WHERE da consulta. Se o parâmetro solicitar um valor, o Excel exibirá a caixa de diálogo Inserir Valor do Parâmetro para coletar a entrada – você pode digitar um valor ou clicar em uma célula que contém o valor. Você também pode especificar que o valor ou a referência fornecidos sempre deve ser usado e, se usar uma referência de célula, poderá especificar que o Excel deverá atualizar automaticamente a conexão de dados (ou seja, executar a consulta novamente) sempre que o valor da célula especificada for alterado.
Veja Também
Personalizar uma consulta de parâmetro