Sumário
×

Há duas maneiras de importar dados de um arquivo de texto com o Excel: você pode abri-los no Excel ou importá-los como um intervalo de dados externos. Para exportar dados do Excel para um arquivo de texto, use o comando Salvar como e altere o tipo de arquivo do menu suspenso.

Há dois formatos de arquivo de texto comumente usados:

  • Arquivos de texto delimitados (.txt), nos quais o caractere TAB (código de caracteres ASCII 009) normalmente separa cada campo de texto.

  • Valores separados por vírgulas arquivos de texto (.csv), nos quais o caractere de vírgula (,) normalmente separa cada campo de texto.

Você pode alterar o caractere separador usado em arquivos de texto delimitados e .csv. Isso pode ser necessário para garantir que a operação de importação ou exportação funcione da maneira que você deseja.

Observação: Você pode importar ou exportar até 1.048.576 linhas e 16.384 colunas.

Importar um arquivo de texto abrindo-o no Excel

Você pode abrir um arquivo de texto criado em outro programa como uma pasta de trabalho do Excel usando o comando Abrir. Abrir um arquivo de texto no Excel não altera o formato do arquivo — você pode ver isso na barra de título do Excel, onde o nome do arquivo mantém a extensão de nome do arquivo de texto (por exemplo, .txt ou .csv).

  1. Vá para Arquivo >Abra e navegue até o local que contém o arquivo de texto.

  2. Selecione Arquivos de Texto na lista suspenso tipo de arquivo na caixa de diálogo Abrir.

  3. Localize e clique duas vezes no arquivo de texto que você deseja abrir.

    • Se o arquivo for um arquivo de texto (.txt), o Excel iniciará o Assistente de Importação de Texto. Quando terminar as etapas, clique em Concluir para concluir a operação de importação. Consulte Assistente de Importação de Texto para obter mais informações sobre delimitadores e opções avançadas.

    • Se o arquivo for um arquivo .csv, o Excel abrirá automaticamente o arquivo de texto e exibirá os dados em uma nova pasta de trabalho.

      Observação: Quando o Excel abre um arquivo .csv, ele usa as configurações de formato de dados padrão atuais para interpretar como importar cada coluna de dados. Se quiser mais flexibilidade na conversão de colunas em diferentes formatos de dados, use o Assistente de Importação de Texto. Por exemplo, o formato de uma coluna de dados no arquivo .csv pode ser MDY, mas o formato de dados padrão do Excel é YMD ou você deseja converter uma coluna de números que contém zeros à esquerda em texto para que você possa preservar os zeros principais. Para forçar o Excel a executar o Assistente de Importação de Texto, você pode alterar a extensão de nome de arquivo de .csv para .txt antes de abri-lo ou pode importar um arquivo de texto conectando-se a ele (para obter mais informações, consulte a seção a seguir).

Importar um arquivo de texto conectando-se a ele (Consulta do Power)

Você pode importar dados de um arquivo de texto para uma planilha existente.

  1. Na guia Dados, no grupo Obter & Transformar Dados, clique em De Texto/CSV.

  2. Na caixa de diálogo Importar Dados, localize e clique duas vezes no arquivo de texto que você deseja importar e clique em Importar.

  3. Na caixa de diálogo visualização, você tem várias opções:

    • Selecione Carregar se quiser carregar os dados diretamente em uma nova planilha.

    • Como alternativa, selecione Carregar para se quiser carregar os dados em uma tabela, tabela dinâmica/gráfico dinâmica, uma planilha existente/nova do Excel ou simplesmente criar uma conexão. Você também tem a opção de adicionar seus dados ao Modelo de Dados.

    • Selecione Transformar Dados se quiser carregar os dados no Power Query e edite-os antes de trazê-los para o Excel.

Se o Excel não converter uma determinada coluna de dados no formato que você deseja, você poderá converter os dados depois de importá-los. Para obter mais informações, consulte Converter números armazenados como texto em números e Converter datas armazenadas como texto em datas.

Exportar dados para um arquivo de texto salvando-os

Você pode converter uma planilha do Excel em um arquivo de texto usando o comando Salvar como.

  1. Vá para Arquivo > Salvar como.

  2. Clique em Procurar.

  3. Na caixa de diálogo Salvar como, em Salvar como tipo, escolha o formato de arquivo de texto da planilha; por exemplo, clique em Texto (Delimitado por tabulação) ou CSV (Delimitado por vírgula).

    Observação: Os diferentes formatos suportam diferentes conjuntos de recursos. Para obter mais informações sobre os conjuntos de recursos suportados pelos diferentes formatos de arquivo de texto, consulte Formatosde arquivo com suporte no Excel .

  4. Navegue até o local onde você deseja salvar o novo arquivo de texto e clique em Salvar.

  5. Uma caixa de diálogo é exibida, lembrando que somente a planilha atual será salva no novo arquivo. Se você tiver certeza de que a planilha atual é a que você deseja salvar como um arquivo de texto, clique em OK. Você pode salvar outras planilhas como arquivos de texto separados repetindo este procedimento para cada planilha.

    Você também pode ver um alerta abaixo da faixa de opções de que alguns recursos podem ser perdidos se você salvar a lista de trabalho em um formato CSV.

Para obter mais informações sobre como salvar arquivos em outros formatos, consulte Salvar uma pasta de trabalho em outro formato de arquivo.

Importar um arquivo de texto conectando-se a ele

Você pode importar dados de um arquivo de texto para uma planilha existente.

  1. Clique na célula onde deseja colocar os dados do arquivo de texto.

  2. Na guia Dados, no grupo Obter Dados Externos, clique em De Texto.

  3. Na caixa de diálogo Importar Dados, localize e clique duas vezes no arquivo de texto que você deseja importar e clique em Importar.

    Siga as instruções no Assistente de Importação de Texto. Clique em Ajudar Expressão do parâmetro em qualquer página do Assistente de Importação de Texto para obter mais informações sobre como usar o assistente. Quando terminar com as etapas do assistente, clique em Concluir para concluir a operação de importação.

  4. Na caixa de diálogo Importar Dados, faça o seguinte:

    1. Em Onde você deseja colocar os dados?, faça um dos seguintes:

      • Para retornar os dados ao local selecionado, clique em Planilha existente.

      • Para retornar os dados para o canto superior esquerdo de uma nova planilha, clique em Nova planilha.

    2. Opcionalmente, clique em Propriedades para definir opções de atualização, formatação e layout para os dados importados.

    3. Clique em OK.

      O Excel coloca o intervalo de dados externos no local especificado.

Se o Excel não converter uma coluna de dados no formato que você deseja, você poderá converter os dados depois de importá-los. Para obter mais informações, consulte Converter números armazenados como texto em números e Converter datas armazenadas como texto em datas.

Exportar dados para um arquivo de texto salvando-os

Você pode converter uma planilha do Excel em um arquivo de texto usando o comando Salvar como.

  1. Vá para Arquivo > Salvar como.

  2. A caixa de diálogo Salvar como é exibida.

  3. Na caixa Salvar como tipo, escolha o formato de arquivo de texto da planilha.

    • Por exemplo, clique em Texto (Delimitado por tabulação) ou CSV (Delimitado por vírgula).

    • Observação: Os diferentes formatos suportam diferentes conjuntos de recursos. Para obter mais informações sobre os conjuntos de recursos suportados pelos diferentes formatos de arquivo de texto, consulte Formatosde arquivo com suporte no Excel .

  4. Navegue até o local onde você deseja salvar o novo arquivo de texto e clique em Salvar.

  5. Uma caixa de diálogo é exibida, lembrando que somente a planilha atual será salva no novo arquivo. Se você tiver certeza de que a planilha atual é a que você deseja salvar como um arquivo de texto, clique em OK. Você pode salvar outras planilhas como arquivos de texto separados repetindo este procedimento para cada planilha.

  6. Uma segunda caixa de diálogo é exibida, lembrando que sua planilha pode conter recursos que não são suportados por formatos de arquivo de texto. Se você estiver interessado apenas em salvar os dados da planilha no novo arquivo de texto, clique em Sim. Se você não tiver certeza e quiser saber mais sobre quais recursos do Excel não são suportados por formatos de arquivo de texto, clique em Ajuda para obter mais informações.

Para obter mais informações sobre como salvar arquivos em outros formatos, consulte Salvar uma pasta de trabalho em outro formato de arquivo.

A maneira como você altera olimiter ao importar é diferente, dependendo de como você importa o texto.

  • Se você usar Get & Transformar Dados > De Texto/CSV, depois de escolher o arquivo de texto e clicar em Importar, escolha um caractere a ser usado na lista em Delimiter. Você pode ver o efeito de sua nova opção imediatamente na visualização de dados, para que você possa ter certeza de fazer a escolha que deseja antes de prosseguir.

  • Se você usar o Assistente de Importação de Texto para importar um arquivo de texto, poderá alterar olimiter usado para a operação de importação na Etapa 2 do Assistente de Importação de Texto. Nesta etapa, você também pode alterar a maneira como delimitadores consecutivos, como aspas consecutivas, são manipulados.

    Consulte Assistente de Importação de Texto para obter mais informações sobre delimitadores e opções avançadas.

Se você quiser usar um ponto e vírgula como separador de lista padrão ao salvar como .csv, mas precisar limitar a alteração para o Excel, considere alterar o separador decimal padrão para uma vírgula - isso força o Excel a usar um ponto e vírgula para o separador de lista. Obviamente, isso também mudará a maneira como os números decimais são exibidos, portanto, também considere alterar o separador Milhares para limitar qualquer confusão.

  1. Limpar Opções do Excel> opções >edição avançadas> Usar separadores do sistema.

  2. De definir separador decimal como , (uma vírgula).

  3. Definir o separador Milhares como . (um ponto).

Quando você salva uma pasta de trabalho como um arquivo .csv, o separador de lista padrão (delimiter) é uma vírgula. Você pode alterá-lo para outro caractere separador usando as configurações da Região do Windows. 

Cuidado: Alterar a configuração do Windows causará uma alteração global em seu computador, afetando todos os aplicativos. Para alterar apenas olimiter do Excel, consulte Alterar o separador de lista padrão para salvar arquivos como texto (.csv) no Excel.

  1. No Microsoft Windows 10, clique com o botão direito do mouse no botão Iniciar e clique em Configurações.

  2. Clique em Idioma& Hora e clique em Região no painel esquerdo.

  3. No painel principal, em Configurações Regionais, clique em Data, hora e configurações regionais adicionais.

  4. Em Região,clique em Alterar formatos de data, hora ou número.

  5. Na caixa de diálogo Região, na guia Formatar, clique em Configurações adicionais.

  6. Na caixa de diálogo Personalizar Formato, na guia Números, digite um caractere a ser usado como o novo separador na caixa Separador de lista.

  7. Clique em OK duas vezes.

  1. No Microsoft Windows, clique no botão Iniciar e em Painel de Controle.

  2. Em Relógio, Idioma e Região, clique em Alterar formatos de data, hora ou número.

  3. Na caixa de diálogo Região, na guia Formatar, clique em Configurações adicionais.

  4. Na caixa de diálogo Personalizar Formato, na guia Números, digite um caractere a ser usado como o novo separador na caixa Separador de lista.

  5. Clique em OK duas vezes.

Observação:  Depois de alterar o caractere separador de lista do computador, todos os programas usarão o novo caractere como separador de lista. Você pode alterar o caractere de volta para o caractere padrão seguindo o mesmo procedimento.

Precisa de mais ajuda?

Você pode sempre consultar um especialista na Excel Tech Community ou obter suporte na Comunidade de respostas.

Confira também

Importar dados de fontes de dados externas (Power Query)

Precisa de mais ajuda?

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Microsoft Insider

Estas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade da tradução?
O que afetou sua experiência?

Obrigado por seus comentários!

×